Getting Started

This chapter describes the hardware and system requirements necessary to use Retrospect, then explains how to install or upgrade the Retrospect software. It also provides a basic overview of how to use Retrospect. Requirements and installation of Retrospect Clients are described in Networked Clients.

Overview of Retrospect

Designed for use in small to mid-sized businesses, Retrospect Multi Server, Single Server, and Single Server (Disk-to-Disk) provide thorough, fast backups, and 100%-accurate restores of networked servers, desktops, notebook computers, and business critical applications. Retrospect Desktop delivers the proven capabilities of Retrospect’s enterprise-class products to the home and small business user. The Retrospect product line protects against loss due to viruses, newly installed software, user error, damaged hardware, hardware upgrades, hackers, and lost or stolen computers. The industry leader in data protection for more than a decade, Retrospect has received numerous awards and protects millions of computers worldwide.

Which Edition is Right for You?

There are four editions of Retrospect available. Depending on the needs of your organization, one of these editions is right for you. The following table lists some Retrospect features and shows which editions they are available with.

  • Multi Server – Protects any number of networked Windows, Mac, and Linux servers, desktops, and notebooks from a single host computer running Retrospect. Supports disk, cloud, and tape storage devices.
  • Single Server – Protects one server and any number of networked Windows, Mac, and Linux desktops and notebooks from a single host computer running Retrospect. Additional server client licenses can be purchased to protect more networked Windows, Mac, or Linux servers. Supports disk, cloud, and tape storage devices.
  • Single Server (Disk-to-Disk) – Protects a single Windows Server and five workstations using local, network, and cloud disk- based storage. Formerly Retrospect Disk-to-Disk.
  • Desktop – Protects a single non-server Windows PC and up to five additional Windows, Mac, and Linux desktops and notebooks. Formerly Retrospect Professional.

Retrospect Add-on Products

A number of advanced Retrospect features are only available if you have the appropriate license code. Click Configure>Licenses to view your current licenses or purchase new ones.

  • VMware Host Server – Protects VMs with file-based agent-less backups and restores in ESX 4 and ESXi 5.0/5.1 environments.
  • Open File Backup Unlimited – Protects open files on NTFS-formatted volumes on Windows servers, desktops, and laptops. This add-on makes it possible to protect line-of-business applications—such as accounting, CRM, and proprietary database systems—while they’re running, even those with data files spread across multiple volumes. Retrospect’s Open File Backup Unlimited add-on extends to all Windows systems protected by your Retrospect host server, including end-user desktops and laptops.
  • Open File Backup Disk-to-Disk Edition – Protects open files on NTFS-formatted volumes on the one Windows server. This add-on makes it possible to protect line-of-business applications—such as accounting, CRM, and proprietary database systems—while they’re running, even those with data files spread across multiple volumes. Retrospect’s Open File Backup Disk-to-Disk Edition add-on covers your Retrospect host server only. Specifically for Retrospect Single Server (Disk-to-Disk) and Desktop (Professional).
  • Dissimilar Hardware Restore Unlimited – Makes it possible to recover an entire boot volume—including the OS, applications, registry, and data—to a different physical computer, such as a newer model or even one from a different manufacturer entirely. Retrospect’s Dissimilar Hardware Restore Unlimited add-on extends to all Windows systems protected by your Retrospect host server, including end-user desktops and laptops.
  • Dissimilar Hardware Restore Disk-to-Disk Edition – Makes it possible to recover your Windows server—including the OS, applications, registry, and data—to different physical hardware, such as a newer model or even one from a different manufacturer entirely. Retrospect’s Dissimilar Hardware Restore Disk-to-Disk Edition add-on covers your Retrospect host server only. Specifically for Retrospect Single Server (Disk-to-Disk) and Desktop (Professional).
  • Microsoft SQL Server Agent – Provides hot backups of Microsoft SQL Server 2019, 2017, 2016, 2014, 2012, 2008, and 2005. Automatically restores a SQL Server or individual databases to a specific point in time. Licensed for use on a SQL server running either the Retrospect application or as a Retrospect Client; includes a Retrospect Server Client license.
  • Microsoft Exchange Server Agent – Provides hot backups of Microsoft Exchange Server 2019, 2016, 2013, 2010, 2007, and 2003 storage groups, databases, and mailboxes. Automatically restores an Exchange Server or individual components to a specific point in time. Licensed for use on an Exchange Server running either the Retrospect application or as a Retrospect Client; includes a Retrospect Server Client license.
  • Advanced Tape Support – Improves backup times by utilizing multiple tape drives in parallel, including multiple stand-alone drives, drives in libraries, or drives in autoloaders. The Advanced Tape Support add-on is licensed per Retrospect host server, not per tape drive. For example, only one Advanced Tape Support add-on license is required for a library with four tape drive mechanisms.
  • Retrospect Client Packs – Extends the number of networked desktops and notebook computers that can be backed up using Retrospect Disk-to-Disk or Desktop editions. Available in 1, 5, and 10 client license packs.
  • Retrospect Server Client – Extends the number of networked servers that can be backed up using Retrospect Single Server editions. Each Retrospect Server Client adds a license for protecting one additional server as a network client.
  • Annual Support & Maintenance (ASM) – Provides technical support via email and phone (available in select regions) and all upgrades/updates of purchased product at no additional cost for 1 year from the date of ASM purchase.

Requirements

In order to run and use Retrospect, certain minimum requirements of hardware, software, and memory must be met. Requirements of client computers are detailed in Networked Clients.

System Requirements

 

Retrospect 16 for Windows

Supported Operating Systems:
  • Microsoft Windows Vista, 7, 8, 10
  • Microsoft Windows Server 2003, 2008, 2012, 2012 R2, 2016
  • Microsoft Windows Server Core 2008 R2, 2012, 2016
  • Microsoft Windows Server 2012 Essentials
  • Microsoft Windows SBS 2003, 2008, 2011
  • Microsoft Windows Storage Server 2003, 2008

*Retrospect Desktop doesn’t run on a Windows Server.

Supported Hardware:
  • Intel processor (64-bit) with one or more multicore processors
Recommended Configuration:
  • Latest Service Pack for Windows
  • For Windows 10, Retrospect requires the 64-bit version
  • 1 GB for each concurrent activity; 4 GB minimum for 64-bit Windows
  • 10-15 GB of temp hard disk space for each concurrent activity (backup, restore, etc.)
  • Adequate storage for backups
  • RAM that meets Microsoft's guidelines for each OS

Retrospect 16 Client for Windows

  • Microsoft Windows XP, Vista, 7, 8, 10
  • Microsoft Windows Server 2003, 2008, 2012, 2012 R2, 2016
  • Microsoft Windows Server Core 2008 R2, 2012, 2016
  • Microsoft Windows Server 2012 Essentials
  • Microsoft Windows SBS 2003, 2008, 2011
  • Microsoft Windows Storage Server 2003, 2008

*Backing up server OS clients requires Retrospect Multi Server or other Server edition with available Server Client Licenses.

Retrospect 16 Client for Mac

  • Apple macOS Mojave / Mojave Server 10.14
  • Apple macOS High Sierra / High Sierra Server 10.13
  • Apple macOS Sierra / Sierra Server 10.12
  • Apple OS X El Capitan / El Capitan Server 10.11.6
  • Apple OS X Yosemite / Yosemite Server 10.10.5
  • Apple OS X Mavericks / Mavericks Server 10.9.5
  • Apple OS X Mountain Lion / Mountain Lion Server 10.8.5
  • Apple OS X Lion / Lion Server 10.7.5
  • Apple OS X Snow Leopard / Snow Leopard Server 10.6.8

*Backing up server OS clients requires Retrospect Multi Server or other Server edition with available Server Client Licenses.

Retrospect 16 Client for Linux

  • x86- or x64-based system running Red Hat Linux, Red Hat Enterprise Linux, CentOS, Debian, Ubuntu Server and SUSE Linux (Details)
  • glibc version 2 or later

Storage Devices

Retrospect supports a wide variety of storage devices as the destination for backups, including hard drives (both direct- and network-attached), tape drives and libraries, flash storage, and removable disk drives (RDX, REV, etc.). See the Retrospect Device Support Database for a complete list of supported tape drives and libraries.

Creating a Retrospect User Account

In order to back up any disk, remote share, and SQL or Exchange database, Retrospect must be run under a user account that has access to those disks and databases.

Retrospect, Inc. recommends that you create an account that has administrator access to all resources before installing Retrospect.

For SQL and Exchange, make sure the account has the necessary privileges to access all the database servers you want to back up. Make this account a member of:

  • Domain Users
  • Domain Admins
  • Administrators
  • Backup Operators

See SQL Server Agent and Exchange Server Agent for more information.

For network volumes, make sure the account has the necessary privileges to access any volume you want to use as a source, destination, or location for saving Catalog Files.

For more information about the Retrospect User Account and how to modify login information, see Security Preferences.

Installing Retrospect

The process for installing Retrospect is the same, regardless of whether you are installing the application for the first time, or upgrading from an earlier version of Retrospect. If you are upgrading, Retrospect automatically copies your previous configuration—including your scripts, schedules, selectors, and clients—for use with the new version. After installing Retrospect, it is a good idea to check for any updates to the application before starting to use it.

To install or upgrade Retrospect:

  1. Save all unsaved documents in other running applications.
  2. Under Windows, log in to the computer so that you have Administrator privileges.
  3. Insert the Retrospect CD in the computer’s CD/DVD drive. In the menu that appears, click Install Retrospect.

    If you downloaded the Retrospect installer, run Setup.exe.

  4. Follow the instructions in the Setup Wizard to install the software or update an existing installation, then choose the option to restart the computer, if necessary.
  5. Some Retrospect upgrades include new application license codes. If your upgrade includes a new code, you will need it. After running the installer, enter the new license code the first time you launch Retrospect.

Installation of Retrospect Clients is described in Networked Clients.

Retrospect Updates

Retrospect Updates are free downloads that provide additional device support or address issues with earlier versions of Retrospect. By default, Retrospect is set up to regularly check for Retrospect Updates and notify you if any are available. You can also manually check for updates at any time.

Automatically Checking for Retrospect Updates

By default, Retrospect checks for free updates to your current version of Retrospect on a regular basis. To make sure Retrospect’s preference is enabled, choose Configure>Preferences from Retrospect’s navigation bar. In the Notification category of preferences, click Updates and make sure the check box for “Automatically check for available updates” is selected. See Updates Preferences for more information.

If Retrospect finds an update, you can download it or install it immediately. See Installing Retrospect Updates for more information.

Manually Checking for Retrospect Updates

You can search for free updates to your current version of Retrospect by choosing Retrospect Updates from the Help menu. The dialog box that displays lists the currently installed versions of Retrospect, as well as any device support updates and hot fixes. It also lists the date of the last successful check for updates.

Click Check Now to check the Retrospect web site for available updates.

If there are any updates, Retrospect displays a list of the items available to download and install.

Installing Retrospect Updates

When Retrospect finds an update to your currently installed version of the application, it displays a list of available updates. Select an item from the list, then choose a command:

  • Click “More info about this update” to view details about the selected update.
  • Click Download to download an installer for the selected update to a location you choose. You can install the update at any time. After installing the update, you must delete the downloaded update installer manually.
  • Click Install to download and install the update. Retrospect downloads the update, then prompts you to quit so it can run the update installer. After installing the update Retrospect automatically deletes the update installer. If you decide not to quit Retrospect after downloading the update, the update installer is deleted and the update is not installed.
  • Select the “Ignore this update” check box to ignore an update you don’t want to install. The update will still appear in the list, but it will be grayed out.
  • Click Close to close the dialog without downloading or installing any updates.

You can only download or install one update at a time. If you want to install multiple updates, select Help>Retrospect Updates and click Check Now after the first update is installed.

Adding Functionality to Retrospect

You can easily expand the functionality of Retrospect with add-on products or upgrade to a more powerful version of the Retrospect family.

To upgrade, choose License Manager from Retrospect’s Window menu. Click Purchase and then click Web to visit the Retrospect Online Store using your web browser.

After you have received your purchased license code by e-mail, click Add in Retrospect’s License Manager window and enter the code, completing your upgrade.

Using Retrospect

Retrospect has a familiar, user-friendly interface. It includes a navigation bar, as well as a toolbar, and keyboard shortcuts, for quick access to frequently used commands.

Starting Retrospect

To start Retrospect, choose Retrospect 16.1 from the Retrospect program group in the Start menu.

Getting Started Wizard

The first time you start Retrospect, the Getting Started Wizard displays.

1

Enter your application license code in the space provided, then click Next.

If you do not have a license code, you can click the Purchase button for more information about obtaining one.

2

If you have separate license codes for any Retrospect add-on products, you can enter them here. You can always enter add-on codes later using the License Manager. Click Next to continue.

3

Enter your name and company name and click Next.

4

At the registration screen prompt, select one of the following radio buttons, then click Next.

  • Register Now, if you have not registered your copy of Retrospect and you would like to do so.
  • Register Later, if you want to skip this step.
  • Already Registered, if you have already registered your copy of Retrospect.

6

In order to back up any disk, remote share, and SQL or Exchange database, Retrospect must be running under a user account that has access to those disks and databases.

If you plan to back up remote shares, including SQL or Exchange, Retrospect, Inc. recommends that you create an account that has administrator access to all resources, and enter that information in the fields below “Always run Retrospect as the specified user”.

See Creating a Retrospect User Account for more information.

If you want to use Terminal Services to administer Retrospect when it is running on a remote server, see Terminal Services and Remote Desktop.

7

Retrospect is now set up. To start a backup immediately, click Next. To explore the application on your own, clear the “Perform a backup” check box and click Finish.

See Backing Up in Wizard Mode for more information on setting up your first backup.

Leaving Retrospect

Once the Retrospect application is started, you can leave it temporarily by clicking on a program window in the background, or by choosing another program from the Start menu or taskbar. This puts Retrospect in the background, and though it is not the active program, it will continue to perform its current operation, if any, and perform any scheduled operations which come up later.

To exit Retrospect entirely, choose Exit from its File menu. Before exiting, Retrospect informs you of the next scheduled operation, if any.

The Navigation Bar

When you start Retrospect, the program displays its main window, with a navigation bar on the left and a toolbar across the top.

8

You can access all areas of Retrospect through its navigation bar.

  • Click
  • 9 to hide the navigation bar.
  • Click
  • 10 to display the navigation bar.

The navigation bar is organized hierarchically with different categories of functions. Clicking a + icon reveals a category’s items.

11

Clicking a – icon hides the lower-level items. Clicking a top-level category item shows an overview window. (By default, the Backup overview window is shown when you open Retrospect.)

Each overview window has buttons along the left. To the right of each button is a description of its function or action. Each button’s function requires additional steps and involves more windows or dialogs and buttons.

Right-clicking anywhere in the navigation bar provides access to display options:

  • Hide overview/Show overview
  • Dock on right/Dock on left
  • Right align text/Left align text

Use these option to customize how Retrospect displays the navigation bar.

The Toolbar

When you become familiar with the functions accessible from the navigation bar, you may wish to use the shortcuts arranged in the toolbar beneath Retrospect’s menus.

12

Hold the mouse pointer over a toolbar icon to see its function.

The System Tray Icon

When you exit Retrospect, a Retrospect icon 13 appears in the system tray of your Windows taskbar by default.

14

Right-clicking the icon displays the following commands:

  • Launch Retrospect
  • Options...
  • Exit

Choose Launch Retrospect to launch the application. Retrospect displays as it was when you exited the application. You can also double-click the icon to launch retrospect.

Choose Options to set a shortcut key to launch the immediate Backup Wizard and to specify whether or not to display the icon.

To set up a shortcut to the Backup Wizard:

  1. Right-click the Retrospect icon in the system tray and choose Options.

    15

  2. Click in the Shortcut key text entry field and enter a set of keystrokes to use as the shortcut.

    You must use the Ctrl, Alt, or Shift key in combination with one or more other keys (letters, function keys, etc.) on the keyboard.

  3. Click OK.

You can type the shortcut keys when Retrospect is not running to launch the application and open the immediate Backup Wizard. See Backing Up in Wizard Mode for more information.

Retrospect displays the most recent immediate backup settings you specified. The shortcut keys provide an easy way to access these settings and start a backup quickly. Click Start Now to run a backup with the current settings.

Backup settings are displayed in Wizard Mode, even if you last edited them in Advanced Mode.

To hide the Retrospect system tray icon:

  1. Right-click the Retrospect icon in the system tray and choose Options.
  2. Clear the check box next to “Show Retrospect icon launcher in the taskbar”.
  3. Click OK.

The Retrospect icon no longer displays.

If you want to display the icon again later, you can turn it on using a Retrospect preference. See Startup Preferences for more information.

Choose Exit to remove the Retrospect icon from the system tray temporarily. The next time you launch and exit Retrospect, the icon will display again (depending on your preferences).

When you exit from the system tray icon, the shortcut you specified to launch the Backup Wizard no longer works.

When you stop all Retrospect executions (from either the toolbar or the countdown dialog), the Retrospect icon in the system tray of your Windows taskbar will flash until you click the Stop all execution activity button in the Retrospect toolbar. As long as the icon is flashing, Retrospect will not execute any immediate or scripted operations. See Stop Button for more information on stopping all Retrospect executions.

Keyboard Navigation

For users that do not have a mouse, Retrospect uses standard Windows shortcuts to provide access to the functions of the application from the keyboard.

For example, Ctrl+F4 closes the active window and Alt+F opens the File menu.

In addition, Retrospect’s navigation bar can be accessed via the keyboard using Ctrl+1.

Using Windows 8, 7, Vista, Server 2012 and Server 2008

Automated operations

When Retrospect automatically launches on Windows 8, 7, Vista, Server 2012, or Server 2008, the application window is hidden. If an operation is running and Retrospect is manually launched, the Retrospect Monitor will be displayed if available. If the Retrospect Monitor is not installed, an alert is displayed warning that an operation is in progress. You are then able to close the alert and let the operation continue or stop the operation and show the Retrospect window.

Retrospect icon

Retrospect does not display the icon in the task bar when running in these versions of Windows.

Upgrading from a previous version of Retrospect

Older backup sets

You can use older Backup Sets with Retrospect 8. However, once you use a Backup Set with Retrospect, you can no longer access it from versions of Retrospect earlier than 7.7.

Retrospect Updates

Retrospect adds support for devices by releasing Retrospect Updates, which are “plug-in” files you place in the folder with Retrospect. When circumstances permit, Retrospect includes the latest update with Retrospect and it is automatically installed when you install Retrospect. (To reinstall the update, reinstall Retrospect.)

To see which version of Retrospect Update you have, choose About Retrospect from Retrospect’s Help menu. It lists the version of Retrospect, as well as the Retrospect Update version.

If you don't have a Retrospect Update, or your update version is too old for your device, you can get the latest Retrospect Update from the Retrospect web site.