Retrospect Compatibility with Apple File System (APFS)

Top Articles


The new Apple File System (APFS) will debut on macOS with High Sierra (10.13) in September 2017, and Retrospect 14.5 for Mac is certified to work with High Sierra and APFS with the known issues below. Previous versions of Retrospect for Mac have varying compatibility. See below for our results installing Retrospect on the default configuration of APFS.

Apple File System (APFS)

Apple File System (APFS) is the new file system on macOS. It replaces HFS+, a file system that Apple has maintained for the last twenty years. iOS and watchOS have already been migrated to using APFS this year, and with High Sierra, Apple is migrating macOS as well.

For customers with flash storage, High Sierra will automatically migrate your storage from HFS+ to APFS. For customers with hard disk drives (HDDs) and Fusion drives, your systems won’t be migrated. For more information, see Apple’s Prepare for APFS in macOS High Sierra.

HFS+ and APFS Compatibility

Retrospect fully supports restoring an HFS+ volume to an APFS volume. Retrospect also fully supports restoring an APFS volume to an HFS+ volume as long as there are no case-sensitivity issues with files in the same directory, and you can always work around case-sensitivity restore problems by using "Copy to a new folder" mode.

Known Issues

  • As of beta 9, Retrospect cannot perform a bootable restore or bootable duplicate for an APFS destination volume. We are in touch with Apple to resolve this issue.

Retrospect 9 for Mac

Retrospect for Mac will install on APFS, but licensing is not functional and prevents any operation. Retrospect Client for Mac also is able to install but does not run. You will need to upgrade to protect your APFS volume.

Retrospect 10 for Mac through Retrospect 14.1 for Mac

Retrospect is able to install and backup/restore APFS volumes. These show up as SMBFS in the user interface. However, Retrospect Client for Mac is able to install but not run. You will need to upgrade to protect your APFS volume on any Mac client.

Retrospect 8 for Windows through Retrospect 12.1 for Windows

Retrospect Client for Mac is able to install but not run. You will need to upgrade to protect your APFS volume on any Mac client.


Last Update: September 15, 2017