ネットワーク接続クライアント

この章では、クライアントソフトウェアのインストール、設定、および管理に関する手順について説明します。ユーザは、クライアントソフトウェアを使用することにより、バックアップコンピュータからネットワーク上の Retrospect クライアントコンピュータにアクセスできるようになります。また、Retrospect クライアントが利用できるオプションやコントロールについても説明します。さらに、この章では、これらのクライアントをバックアップする方法について説明し、ワークグループの効率的なバックアップを設定するための情報とワークシートを示します。

ネットワーク接続クライアントの概要

Retrospect を使用すると、記憶装置を装備した 1 台のコンピュータで、Retrospect クライアントソフトウェアが動作している Windows、Macintosh、Linux、および コンピュータを、ネットワーク経由でバックアップすることができます。

バックアップ管理者(あなた)は、クライアントコンピュータ(クライアントとも呼びます)の各々に、Retrospect クライアントソフトウェアをインストールします。バックアップ管理者は、Retrospect アプリケーションを使用して、バックアップコンピュータが使用するクライアントにログインします。管理者は、クライアントの設定後、クライアントボリュームを元ボリュームに指定して、ボリュームがバックアップコンピュータに直接接続されている場合のように、スクリプトの作成とスケジュール設定を行うことができます。

クライアントライセンス

Retrospect はライセンス供与された台数分のクライアントで動作します。Retrospect Single Server、および Multi Server では、使用できるデスクトップ/ノートブックのクライアント数は無制限です。Retrospect Desktop で使用できるクライアント数は、ライセンスを追加購入して増やすことができます。

Retrospect Multi Server は無制限のサーバクライアントをサポートしています。Retrospect Single Server では、ライセンスを追加購入することで、使用できるサーバクライアントの数を増やすことができます。

Retrospect のライセンスマネージャは、ユーザが入力するライセンスコードでクライアントのライセンスを管理します。クライアントのライセンスコードは Retrospect に組み込まれており、Retrospect クライアントで個別に使用できます。新たにライセンスを購入すると、追加のコードが与えられます。

  • 現在のライセンスを表示するには、「設定」>「ライセンス」を順にクリックします。バックアップクライアントのコンテナは、使用済みクライアントと利用可能なクライアントの台数を表示し、追加したクライアントのライセンスを表示します。
  • クライアントのライセンスを追加するには、「追加..」ボタンをクリックし、表示されるダイアログボックスに新規のライセンスコードを入力します。
  • クライアントライセンスを追加購入するには、「購入」をクリックします。

バージョン 4.1 とそれ以前の Retrospect クライアントソフトウェアのライセンスを持つクライアントにログインすると、クライアントのライセンスはライセンスマネージャによって自動的に追加されます。

セキュリティ

インターネットに接続されているクライアントには、わずかなものであっても、権限のないアクセスが行われる危険性が伴います。Retrospect クライアントのインストーラプログラムでは、Retrospect を所有する外部ユーザによるインターネット経由での不正アクセスを防止するため、クライアントへのパスワード割り当てが要求されます。(「全般」タブ

クライアントのインストール

バックアップするすべてのクライアントコンピュータには、Retrospect クライアントソフトウェアがインストールしてある必要があります。以下の項には、システムの必要条件と、Windows、Mac OS、Linux、および クライアントのインストール方法があります。

Windows 用 Retrospect Client

  • Microsoft Windows 10/8/7/Vista/XP
  • Microsoft Windows Server 2012 R2/2012/2008/2003*
  • Microsoft Windows Server 2012 Essentials*
  • Microsoft Windows SBS 2011/2008/2003*
  • Microsoft Windows Storage Server 2008/2003*
  • Pentium 以上のプロセッサー
  • 各 OS に関する Microsoft 社のガイドラインを満たす RAM

*サーバー OS クライアントのバックアップには、利用可能なサーバー クライアント ライセンスを有する Retrospect Multi Server またはその他の Server エディションが必要です。

Mac 用 Retrospect Client

  • Mac OS X または Mac OS X Server 10.6.8 以降 (OS X Yosemite 10.10 を含む)
  • Intel プロセッサー
  • 各 OS に関する Apple 社のガイドラインを満たす RAM

* サーバー OS クライアントのバックアップには、利用可能なサーバー クライアント ライセンスを有する Retrospect Multi Server またはその他の Server エディションが必要です。

Linux 用 Retrospect Client

  • x86 または x64 ベースシステムで実行される Red Hat Linux, Red Hat Enterprise Linux, CentOS, Debian, Ubuntu Server または SUSE Linux オペレーティングシステム
  • glibc バージョン 2 以降

Windows コンピュータへの Retrospect クライアントソフトウェアのインストール

Retrospect クライアントソフトウェアは、いくつかの方法で Windows コンピュータにインストールすることができます。いずれの方法を選択するかは、クライアントを Retrospect のバックアップクライアントデータベースにログインする方法によって異なります。所有しているクライアント数と使用している Retrospect の版によって、クライアントを 1 つずつログインするか、複数のクライアントを同時にログインすることができます。

個々のログイン用の Windows クライアントのインストール

所有するクライアント数が少数であるか、Retrospect Desktop を使用している場合は、Retrospect CD を使用するか、クライアントコンピュータがアクセス可能なネットワーク場所にクライアントインストーラファイルをコピーすることで、Windows 版 Retrospect クライアントをインストールすることができます。個々ののクライアントは、インストール時に指定されたパスワードを使用して Retrospect のバックアップクライアントデータベースにログインします。

ネットワークを経由してバックアップ対象の Windows コンピュータにクライアントソフトウェアをインストールするには、次の手順に従います。

個々のログイン用に Windows クライアントをインストールするには

  1. Windows では、クライアントコンピュータに管理者権限でログインします。
  2. 実行中の他のアプリケーションプログラムで保存していないすべての文書を保存します。
  3. Retrospect の CD をクライアントコンピュータの CD-ROM ドライブに挿入します。
  4. 「Retrospect クライアントをインストール」ボタンをクリックします。
  5. ウィザードの指示に従って、クライアントソフトウェアをインストールします。
  6. インストール時には、クライアントへの権限のないアクセスを防止するために使用するパスワードを入力します。このパスワードを忘れないようにしてください。

コンピュータを起動すると、クライアントソフトウェアが自動的に読み込まれます。この時点で、バックアップコンピュータからクライアントにいつでもアクセスできます。詳細については、クライアントの操作を参照してください。

CD を使用しないでクライアントをインストールするには、クライアントインストーラファイルをネットワーク上の任意の場所にコピーします。これで、これらのファイルに各クライアントコンピュータからアクセスし、setup.exe を実行してソフトウェアをインストールすることができます。この方法を使用すると、Retrospect クライアントユーザ自身がソフトウェアをインストールすることができます。ただし、ユーザのクライアントパスワードをバックアップ管理者に必ず提示しなければなりません。

複数ログイン用の Windows クライアントのインストール

一度に複数の Windows 版 Retrospect クライアントのログインが可能であるという Retrospect の機能(自動検出や新規クライアントのログインなどを含む)を活用するには、Retrospect の Single Server (Disk-to-Disk)、Small Business Sever、Single Server、または Multi Server が必要です。また、Microsoft Systems Management Server(SMS)か Group Policy を使用している場合は、これらの技術を使用してクライアントソフトウェアを配備することができます。

マルチクライアントログインでは、個々のクライアントのパスワードに依存する代わりに、Retrospect バックアップコンピュータ上の秘密鍵証明と、各 Windows Retrospect クライアント上の公開鍵証明を使用して、クライアントを Retrospect のバックアップクライアントデータベースに追加します。これらの鍵は Retrospect で作成し、公開鍵は以下に説明する手順のいずれかを使用してクライアントに配布することができます。

マルチログイン用に Windows クライアントをインストールするには

  1. クライアントインストーラファイルをネットワーク上の場所にコピーします。
  2. バックアップコンピュータ上で Retrospect を起動します。
  3. Retrospect のナビゲーションバーで「設定」>「環境設定」を選択します。
  4. 「クライアント」>「追加」を順にクリックします。
  5. 「キーの作成」をクリックします。
  6. 秘密鍵を保護するためにパスワードを入力して確認し、「OK」をクリックします。

    2 つのファイル(privkey.dat と pubkey.dat)が「C:¥ProgramData¥Retrospect」に作成されます。

  7. 最大限のセキュリティを得るため、Retrospect と秘密鍵はパスワードで保護しなければなりません。詳しくは、セキュリティ環境設定を参照してください。
  8. pubkey.dat を、ネットワーク上のクライアントインストーラフォルダにある「public_key」にコピーします。
  9. Windows 版 Retrospect クライアントユーザに連絡し、ネットワーク上のクライアントインストーラフォルダから setup.exe を実行するよう指示します。

    この方法でインストールしたクライアントは、Retrospect のバックアップクライアントデータベースに一度に追加することができます。詳しくは、クライアントの追加を参照してください。この方法でインストールされた新規クライアントを定期的に検出し、それらをバックアップクライアントデータベースに自動的に追加するよう Retrospect を設定することもできます。詳しくは、環境設定の追加を参照してください。

    SMS か Group Policy を使用する Windows クライアントインストーラを配備するには

  1. バックアップコンピュータ上で Retrospect を起動します。
  2. Retrospect のナビゲーションバーで「設定」>「環境設定」を選択します。
  3. 「クライアント」>「追加」を順にクリックします。
  4. 「Create keys」をクリックします。
  5. 秘密鍵を保護するためにパスワードを入力して確認し、「OK」をクリックします。

    2 つのファイル(privkey.dat と pubkey.dat)が「C:¥ProgramData¥Retrospect」に作成されます。

  6. Microsoft SMS か Group Policy を使用して、Retrospect Client 16.5.msi ファイルと pubkey.dat ファイルを複数のクライアントに一度に配備します。
  7. msi ファイルを使用するには、クライアントコンピュータに ISScript 9 と Windows Installer 2.0 がインストールされていることが必要です。これらはいずれも、Retrospect CD のクライアントインストーラフォルダに含まれています。

SMS と Group Policy の詳しい操作手順は、本書では説明していません。インストーラの配備や実行の詳細については、これらの製品のドキュメントを参照してください。

Mac OS コンピュータへのクライアントソフトウェアのインストール

ネットワーク経由でバックアップ対象の各 Macintosh コンピュータにクライアントソフトウェアをインストールするには、次の手順に従います。

ファイルサーバから多数のクライアントをネットワークにインストールしたり、CD-ROM ドライブが付属していないコンピュータにインストールする場合、サーバ上に Retrospect クライアント Installer アプリケーションを格納する共有フォルダを作成できます。インストーラプログラムを CD から実行する代わりに、そのフォルダから実行できます。

Retrospect クライアントソフトウェアを Mac OS コンピュータにインストールするには

  1. 保存していないすべての書類を保存し、実行中の他のアプリケーションプログラムを終了します。
  2. Mac OS X では、クライアントコンピュータに管理者権限でログインします。
  3. Retrospect の CD をクライアントコンピュータの CD-ROM ドライブに挿入します。
  4. インストーラアイコンをダブルクリックして、プログラムを起動します。
  5. インストーラプログラムの指示に従って、クライアントソフトウェアを起動ディスクに配置します。
  6. クライアントへの権限のないアクセスを防止するために、パスワードを作成して入力します。このパスワードを忘れないようにしてください。
  7. Macintosh クライアントのパスワードには、基本的な英数文字(低ビット ASCII)のみを使用します。Macintosh の高ビット文字は Windows の高ビット文字とは対応しません。たとえば、Luf$Luf00 は問題ありませんが、L?f¥L?f?? は問題があります。
  8. コンピュータを再起動します。

コンピュータを起動すると、クライアントソフトウェアが自動的に読み込まれます。この時点で、バックアップコンピュータからクライアントにいつでもアクセスできます。詳細については、クライアントの操作を参照してください。

UNIX コンピュータへのクライアントソフトウェアのインストール

ネットワークを経由してバックアップ対象の UNIX コンピュータにクライアントソフトウェアをインストールするには、次の手順に従います。使用するパッケージの方式(tar)を選択します。手順の中で「version」を使用している箇所には、Retrospect クライアントソフトウェアの特定のバージョン/ビルド番号(7.5.103 など)を指定してください。

Retrospect クライアントソフトウェアを UNIX コンピュータにインストールするには

  1. 実行中の他のアプリケーションプログラムで保存していないすべての文書を保存します。
  2. クライアントコンピュータにログインします。
  3. Retrospect の CD をクライアントコンピュータの CD-ROM ドライブに挿入し、参照でクライアントインストーラファイルの場所を探します。
  4. ご使用のオペレーティングシステムとインストーラに従って次のコマンドを入力します。

    tar $tar -xf retroclient-version.tar, $.Install.sh

  5. クライアントへの権限のないアクセスを防止するために、パスワードを作成して入力します。このパスワードを忘れないようにしてください。

クライアントソフトウェアは、インストールの完了時に自動的に実行します。

この時点で、バックアップコンピュータからクライアントにいつでもアクセスできます。詳細については、クライアントの操作を参照してください。

クライアントの操作

クライアントコンピュータは、Retrospect クライアントソフトウェアによってインストールされた後、バックアップコンピュータからバックアップクライアントデータベースに追加され、基本操作と自動操作で使用を開始できます。

ファイアウォールの設定

ネットワーククライアントを Retrospect でバックアップするには、ファイアウォールで通常遮断されているネットワークアクセスの一部を有効にする必要があります。

Retrospect は TCP と UCP での通信に 497 番ポートを使用します。Retrospect クライアントを検出してアクセスするには、Retrospect バックアップサーバと、すべての Retrospect クライアントによる 497 番ポート経由での TCP/UDP 通信を許可するようにファイアウォールを設定する必要があります。

Windows XP SP2 のファイアウォールを使用している場合は、Retrospect のインストール時にファイアウォールが有効になっていれば、このポートが自動的に解放されます。インストール時にファイアウォールが無効だった場合は、手動でポートを解放する必要があります。ファイアウォールの例外の設定方法について、Windows のマニュアルを参照してください。

クライアントの追加

クライアントコンピュータをバックアップするには、そのクライアントコンピュータを Retrospect のバックアップクライアントデータベースに追加する必要があります。一般的に、一度に追加できるのは 1 つのクライアントだけですが、特定の状況下では複数のクライアントを同時に追加することができます。また、Retrospect を設定すれば、ネットワーク上で新規クライアントを自動的に検出したり追加すこともできます。

複数のクライアントを一度に追加する場合の必要条件

  • Retrospect Single Server (Disk-to-Disk)、Single-Server、または Multi-Server
  • Windows 版 Retrospect クライアント
  • 公開鍵証明書を使用してインストールされたクライアント(複数ログイン用の Windows クライアントのインストールを参照)。
  • マルチキャストまたはサブネットブロードキャスト方式によるクライアントアクセス
  • クライアントを追加すると、Retrospect のライセンスマネージャは、利用可能なクライアントのライセンスが入っているプールからライセンスを 1 つ減らします(該当する場合)。

単独のクライアントを追加するには

  1. ナビゲーションバーから、「設定」>「クライアント」を順にクリックします。

    236

    バックアップクライアントデータベースには、Retrospect で使用するために現在ログインしているすべてのクライアントコンピュータのスクロールリストが表示されます。

  2. 「追加」をクリックすると、「ネットワーク状況」ウィンドウが表示されます。

    237

    このウィンドウには、Retrospect クライアントソフトウェアがインストールされている、特定のネットワーク上のコンピュータがすべて表示されます。デフォルトでは、Retrospect は Piton マルチキャスト方式を使用して、ローカルサブネット内のクライアントを検索します。

  3. サブネットとは、ルータやゲートウェイを使用しないでネットワークを構成するローカルコンピュータのグループのことです。ただし、これらのコンピュータはゲートウェイを使用することにより他のネットワークに接続することができます。
  4. クライアントを選択し、「追加」をクリックします。
  5. クライアントのパスワードを入力したら、「OK」をクリックします。

    クライアントにログインすると、クライアントのプロパティウィンドウが表示されます。クライアントのプロパティについては、クライアントの設定を参照してください。

複数のクライアントを追加するには

  1. ナビゲーションバーから、「設定」>「クライアント」を順にクリックします。

    238

    バックアップクライアントデータベースには、Retrospect で使用するために現在ログインしているすべてのクライアントコンピュータのスクロールリストが表示されます。

  2. 「追加」をクリックすると、「ネットワーク状況」ウィンドウが表示されます。

    239

    このウィンドウには、Retrospect クライアントソフトウェアがインストールされている、特定のネットワーク上のコンピュータがすべて表示されます。デフォルトでは、Retrospect は Piton マルチキャスト方式を使用して、ローカルサブネット内のクライアントを検索します。

  3. サブネットとは、ルータやゲートウェイを使用しないでネットワークを構成するローカルコンピュータのグループのことです。ただし、これらのコンピュータはゲートウェイを使用することにより他のネットワークに接続することができます。
  4. リスト内のすべてのクライアントを選択します。

    Retrospect によって非 Windows クライアントの選択が自動的に解除されます。

  5. 「追加」をクリックします。

Retrospect バックアップコンピュータが作成した公開鍵証明書を有するクライアントが追加されます。パスワードを有するクライアントは追加されません。別の Retrospect バックアップコンピュータが作成した公開鍵証明書を有するクライアントは、追加されません。

公開鍵証明書を有するクライアントを自動的に検出してバックアップクライアントデータベースに追加する手順については、環境設定の追加を参照してください。

ネットワークアドレスのテスト

「ネットワーク状況」ウインドウの「テスト」ボタンを使用すると、既知の IP、DNS、または WINS アドレスで応答中のクライアントをテストできます。

アドレスをテストするには

  1. ナビゲーションバーから、「設定」>「クライアント」を順にクリックします。
  2. 「追加」をクリックすると、「ネットワーク状況」ウィンドウが表示されます。
  3. 「テスト」をクリックします。

    240

  4. IP、DNS、または WINS アドレスを入力し、「OK」をクリックします。

指定されたアドレスで Retrospect クライアントソフトウェアが検出されると、Retrospect はそのクライアントの名前とソフトウェアのバージョンを報告します。

241

指定したアドレスで検出されたコンピュータが、Retrospect クライアントソフトウェアを実行していない場合、Retrospect はエラー –541 を報告します。

指定されたアドレスから TCP/IP の応答がない場合、Retrospect はエラー –530 を報告します。

「高度な設定」ボタンをクリックすると、Retrospect のより高度なネットワーク機能を利用できます。これらの機能については、高度なネットワークで説明しています。

クライアントの設定

クライアントにログインしたら、クライアントを設定する必要があります。クライアントが既にインストールされていて、まだログインしていない場合は、まず「ネットワーク状況」ウィンドウのクライアントから目的のクライアントを選択します。次に「追加」ボタンをクリックしてクライアントにログインし、そのクライアントを設定します。既にわかっているクライアントの設定をし直す必要がある場合は、該当するクライアントを「バックアップ クライアント データベース」ウィンドウから選択し、ツールバーから「プロパティ」をクリックできます。

クライアントのプロパティウィンドウには、次の 4 つのタブがあります。

「全般」タブ

「全般」タブは、バックアップクライアントのさまざまな情報を表示し、ネットワーク経由のデータを保護するためのオプションを持ちます。

242

「名前」は、指定されたクライアントの名前です。

「タイプ」は、クライアントコンピュータが使用するオペレーティングシステムを示します。

「バージョン」は、クライアントコンピュータにインストールされているクライアントソフトウェアのバージョン番号です。

「優先度」は、ユーザがクライアントのコントロールパネルで選択した優先順位設定を示します。20% の優先順位は、ユーザがつまみを「ユーザ」に設定していることを示します。これにより、他のアプリケーションやタスクにいくらかのコンピュータの処理時間が Retrospect タスクの使用よりも優先的に割り当てられます。100% の優先順位は、クライアントの優先順位を示すつまみが「バックアップ」に設定されていることを示します。これにより、クライアントのタスク(つまり、ファイルの転送)に、オペレーティングシステムが割り当てるクライアントソフトウェアの処理時間のすべてが優先的に割り当てられます。

「セキュリティ」は、このクライアントコンピュータに指定されたデータセキュリティを示します。

  • 「なし」は、パスワードが設定されていないため、ネットワーク上で Retrospect を使用しているユーザは誰でもこのクライアントにログインできます。
  • 「パスワード」は、このクライアントにログインするために、パスワードを入力する必要があることを示します。
  • 「秘密鍵/公開鍵を使用」は、クライアントにログインするのにパスワードが不要であることを示します。詳細については、複数ログイン用の Windows クライアントのインストールを参照してください。
  • 「リンク暗号化」は、クライアントにパスワードが設定されており、「ネットワーク接続の暗号化」チェックボックスがオンになっている場合に表示されます。これは、クライアントのデータがネットワーク経由で送信される前に暗号化されることを示します。「リンク暗号化」オプションを選択するには、パスワードか公開鍵/秘密鍵が設定されている必要があります。

「状況」は、バックアップやその他の操作がクライアントで使用可能かどうかを示します。「接続していません」は、Retrospect がクライアントとまだ接続を確立していないことを示します。「使用中」は、クライアントが現在アクセス中であることを示します。「接続されました」は、クライアントは準備完了しており、いつでも使用可能であることを示します。「ロックされています。」は、このクライアントワークステーションにいるユーザがクライアントのコントロールパネルで「読み込み専用」のアクセス環境設定にチェックマークを付けたことを示します。この場合は、クライアントをバックアップできますが、クライアントに復元したり、クライアントのファイルを削除することはできません。「ビジー」は、クライアントが現在ネットワーク上の Retrospect の別のコピーからアクセスされていることを示します。「オフ」は、このクライアントにいるユーザがクライアントのコントロールパネルで「オフ」ラジオボタンをクリックしたことを示します。オフにされたクライアントは、手動でオンに戻すか、クライアントコンピュータを再起動するまで操作ができなくなります。

「エコータイム」は、このクライアントとの通信で生じる秒単位の遅延を示します。通常は、0.0 ~ 0.2 秒です。ネットワークまたはクライアントが混雑している場合、あるいはルータを使用している場合は、問題が発生していないのにエコー時間が長くなることがあります。

「速度」は、バックアップコンピュータとクライアントコンピュータ間でのネットワーク接続の転送率を示します。「更表示」ボタンをクリックすると、速度情報が更新されます。

「時計の誤差」は、クライアントコンピュータとバックアップコンピュータの内部クロックの時間差を時間 : 分 : 秒で示します。

「ネットワーク接続の暗号化」は、デフォルトではオフであり、このクライアントがパスワードを使用する場合にのみ使用可能になります。チェックボックスが選択されている場合、Retrospect は、ネットワーク経由で転送されるデータを暗号化し、データがバックアップセットに書き込まれる前に暗号解除することで、ネットワークでの盗聴を防止します。クライアントのリンク暗号化は、バックアップセットの暗号化とは明確に異なります。

「アクセス」タブ

「アクセス」タブは、このクライアントへのネットワークアクセス方式の概要を示します。

243

「変更」ボタンをクリックすると、特別な「ネットワーク状況」ウィンドウからクライアントにアクセスできます。この操作は、クライアントがネットワークを移動した場合や、クライアントが再インストールされた場合に必要になることがあります。

「ツール」タブ

「ツール」タブでは、クライアント名、パスワードを持つかどうか、クロックオフセット(クライアントコンピュータのクロックとバックアップコンピュータのクロックとの時間差)、およびクライアントソフトウェアのバージョン番号を表示します。

244

  • クライアント名を変更するには、「リネーム.. 」をクリックします。新しい名前の入力と確認を求めるダイアログボックスが表示されます。
  • パスワードを追加または変更するには、「パスワードの設定」をクリックします。新しいパスワードの入力と確認を求めるダイアログボックスが表示されます。
  • クライアントコンピュータの時刻をバックアップコンピュータの時刻と一致させるには、「時計を合わせる」をクリックします。ただし、クライアントへのアクセスが読み込み専用である場合は、このボタンは使用できません(アクセス制御環境設定参照)。
  • クライアントのソフトウェアバージョンを更新するには、「更新..」をクリックします。更新元に使用する Retrospect クライアントソフトウェアの場所を求めるファイル選択ダイアログボックスが表示されます。操作手順の詳細については、個々のクライアントコンピュータを更新するにはを参照してください。

「ボリューム」タブ

「ボリューム」タブでは、ネットワーク経由でアクセス可能なクライアントコンピュータのボリュームを表示します。

245

「元ボリューム」リストボックスの設定は、操作中に Retrospect がクライアントのコンテナを解決する方法に影響を与えます。通常は、「クライアントデスクトップ」のデフォルト設定を変更する必要はありません。

  • 「クライアントデスクトップ」は、クライアントコンピュータに対してローカルなすべてのボリュームに解決します。ただし、フロッピーディスク、共有ボリューム(ファイルサーバなど)、読み出し専用ボリューム(CD-ROM など)、空のボリュームは除きます。
  • 「起動ボリューム」は、クライアントコンピュータのブート元ボリュームに解決します。
  • 「選択したボリューム」は、「記憶されたボリューム」のリストで選択したすべてのボリュームに解決します。

「記憶されたボリューム」:クライアントのボリューム一覧を表示します。操作中の Retrospect は、選択したボリュームのみを使用できます。この選択により、Retrospect の「ボリュームデータベース」ウィンドウに表示されるボリュームが決まります。また、「元ボリューム」リストボックスに「選択したボリューム」が設定されている場合は、選択により、クライアントコンテナが解決されるボリュームも決まります。

以下の表では、マウントされたいくつかのボリュームを持つクライアントコンピュータの例を使用します。この例では、異なる「アクセスするボリューム」設定のそれぞれについて、クライアントコンテナが解消されるボリュームを示します。

クライアントコンピュータ上の
ボリューム

「元ボリューム」設定の内容

ボリュームの内訳

246

「クライアントデスクトップ」

Alyosha
Beowulf
Cynics

「起動ボリューム」

Alyosha

「記憶されたボリューム」のリストから Beowulf のみを選択した「選択したボリューム」

Beowulf

クライアントの削除

ログインしていたクライアントとそのボリュームが不要になることがあります。たとえば、コンピュータがすでにネットワーク上に存在しない場合があります。このような場合、該当するクライアントを削除するように Retrospect に指示することができます。これは、クライアントにログインする操作の反対になります。

「バックアップ クライアント データベース」ウィンドウで、削除するクライアントを選択し、ツールバーの「削除...」ボタン247 をクリックします。Retrospect から削除を確認するメッセージが表示されます。「OK」をクリックすると、Retrospect のスクリプトとその他のリストからクライアントボリュームが削除されます。この操作では、削除中にバックアップコンピュータで使用中であった Retrospect だけが影響を受けます。この操作では、ネットワーク上の他のコンピュータで実行していた Retrospect のコピーは影響を受けないので、削除されたクライアントへのログインはそのまま維持されます。クライアントを削除しても、そのクライアントの既存のバックアップは影響を受けません。

Shift キーか Ctrl キーを押しながらクリックしてクライアントを選択し、複数のクライアントを一度に削除することができます。

1 台クライアントを削除すると、ライセンスマネージャで利用できるクライアントのライセンスが 1 つ増えます(クライアントライセンスを参照)。

クライアントの更新

古いクライアントソフトウェアを更新して新規バージョンで改善された機能を利用する必要に迫られるときがあります。そのようなとき、クライアントをバックアップコンピュータから更新したり、クライアントを個別に更新したりできます。

バックアップコンピュータからのクライアントの更新

必要なだけ個別にクライアントを更新するか、または指定したタイプのすべてのクライアントを更新することができます。クライアントの更新時には、そのクライアントの最新の設定がすべて保持されます。

一部のクライアントが停止している場合でも、すべてのクライアントを更新しておくことをお勧めします。未更新のクライアントのために後でこの操作を繰り返しても、すでに更新されているクライアントには何ら影響することはありません。

指定したタイプのすべてのクライアントを更新するには

Retrospect のナビゲーションバーから、「設定」をクリックし、「クライアント」をクリックします。「バックアップ クライアント データベース」ウィンドウが表示されます。このウィンドウには、Retrospect で使用するために現在ログインしているすべてのクライアントコンピュータが表示されます。

248

ツールバーから「クライアントのアップデート」 249 をクリックします。Retrospect クライアントの更新(.rcu)ファイルの場所を指定するように求めてきます。クライアント更新ファイルには、それぞれのオペレーティングシステム用があります(Windows、Linux、、Mac OS X)。クライアント更新ファイルの種類によって、取得できる場所も異なる場合があります(Retrospect CD や Retrospect Web サイトなど)。

適切な場所から該当するクライアント更新ファイルを選択し、「開く」をクリックします。確認後、Retrospect は、選択した .rcu ファイルと同じタイプのすべてのクライアントコンピュータで(Windows など)、クライアントソフトウェアの更新を開始します。複数のタイプのクライアントがある場合は、各タイプに対してこれらの手順を繰り返します。

クライアントコンピュータにウィルスチェックソフトウェアがインストールされている場合は、更新を続ける前にウィルスチェックソフトウェアが実行していないことをクライアントコンピュータで確認する必要があります。

更新が完了したら、Retrospect はダイアログボックスに結果を表示し、操作ログを作成したことを報告します。「OK」をクリックします。

それぞれのクライアントの更新状況を確認するには、操作ログを開きます。操作ログを開くには、ナビゲーションバーから「レポート」をクリックして「操作ログ」をクリックするか、あるいは「ウィンドウ」メニューから「操作ログ」を選択します。

個々のクライアントコンピュータを更新するには

Retrospect ナビゲーションバーで、「設定」>「クライアント」の順にクリックします。「バックアップ クライアント データベース」ウィンドウが表示されます。このウィンドウには、Retrospect で使用するために現在ログインしているすべてのクライアントコンピュータが表示されます。

更新するクライアントを選択し「プロパティ」ボタンをクリックするか、あるいはクライアントをダブルクリックします。表示されたクライアントのプロパティウィンドウから、「ツール」タブをクリックします。

250

「更新..」ボタンをクリックします。ダイアログボックスが表示され、Retrospect クライアント更新(.rcu)ファイルの場所を指定するように求めてきます。

該当するクライアント更新ファイルを選択し、「開く」をクリックします。更新が完了したら、別のダイアログボックスが表示され、更新の完了が報告されます。「OK」をクリックします。

クライアントコンピュータからのクライアントの更新

前述のようにバックアップコンピュータからクライアントを更新する代わりに、個々のクライアントコンピュータから直接クライアントを更新できます。この操作には、クライアントの更新も兼ねた Setup アプリケーション(Windows)、Client Installer アプリケーション(Mac OS)、 か tar インストーラ (Linux)、または )を使用します。

コンピュータのオペレーティングシステムに対応するインストール手順(クライアントのインストールを参照)に従ってください。

クライアントとそのソフトウェアのアンインストール

コンピュータからクライアントソフトウェアを削除する場合は、クライアントの削除の記述に従ってクライアントを削除し、クライアントのタイプごとに以下の項を参照してください。

Windows

  1. 「スタート」メニューから、「設定」>「コントロールパネル」を選択します。
  2. 「アプリケーションの追加と削除」をダブルクリックします。
  3. 表示されるウィンドウで、Retrospect クライアントソフトウェアを選択し、「追加と削除」をクリックします。
  4. 「OK」をクリックしてウィンドウを閉じます。
  5. では、管理者権限でログインする必要があるかもしれません。

UNIX

UNIX クライアントをアンインストールするためのプロセスは、クライアントソフトウェアのインストール方法によって異なります。

tar の場合、tar を使用してインストールしたクライアントソフトウェアファイルを手動で削除します。

Mac OS X

  1. クライアントインストーラアプリケーションを開きます。
  2. ポップアップメニューから「アンインストール」を選択し、Retrospect クライアントソフトウェアをアンインストールするボリュームを選択します。
  3. 「アンインストール」ボタンをクリックして、コンピュータからクライアントソフトウェアを削除し、削除が完了したらこのアプリケーションを終了します。

高度なネットワーク

Retrospect は一般にマルチキャストアクセス方式を使用して、ローカルネットワークセグメントまたはローカルサブネットに直接接続されたバックアップクライアントを検出し、それを「ライブネットワーク」ウィンドウに表示します。バックアップコンピュータとそのクライアントの間にルータが存在するネットワークの場合や、バックアップコンピュータが異なる物理ネットワークと接続する複数のネットワークカードを持つ場合は、クライアントにアクセスするために Retrospect のより高度な技術が必要になります。

Retrospect には、クライアントにアクセスするためのさまざまな方式に対応する機能が用意されています。また、Retrospect によってユーザは、バックアップコンピュータ内のアダプタカードの使用を制御できます。

アクセス方式

Retrospect は、標準的な DNS および WINS ディレクトリサービスや、TCP/IP に基づく独自の Piton Name Service のいずれも使用できます。

Retrospect クライアントデータベースにクライアントを追加すると、そのクライアントのアクセス情報も保存されるため、後で使用するのに便利です。Retrospect がバックアップのためにクライアントに接続を試みるとき、オリジナルのアクセス方式を使用して、アクセス情報をクライアントの現在の IP アドレスに解決します。

それぞれのクライアントコンピュータ上で、Retrospect クライアントソフトウェアはバックアップコンピュータの Retrospect からのクエリを待ちます。Retrospect がクライアントと交信する方法は、Retrospect が使用しているアクセス方式によって異なります。

マルチキャスト

最初にネットワーク状況ウィンドウを開くと、デフォルトのアクセス方式はマルチキャストになります。この方式では、Retrospect は受信中のクライアントコンピュータにマルチキャスト要求を送信し、クライアントコンピュータからの識別子による応答を待ちます。マルチキャスト方式を持つクライアントを追加し、後で Retrospect がバックアップのためにそのクライアントに接続を試みるとき、そのクライアントデータベースを更新して該当するクライアントと接続するために別の要求を送信することで IP アドレスの変更を自動的に処理します。

ネットワークアナライザを使用して、マルチキャスト方式で送信するパケットを監視する場合、Retrospect は通信用に既知のポート 497 を使用します。パケットのフォーマットは、Retrospect 独自のプロトコル Piton(PIpelined TransactiONs に対応)に準拠します。このプロトコルによって、Retrospect はネットワーク速度と信頼性が保証されます。Multicast Piton Name Service が、割り当てられたアドレス 224.1.0.38 を使用することで、Piton は Retrospect クライアントソフトウェアが動作するコンピュータにだけクエリを送信することができます。

マルチキャストアクセスは設定の必要がなく単純ですが、ルータを横断して動作することはありません。マルチキャストアクセスはローカルサブネットでのみ動作します。

サブネットブロードキャスト

サブネットブロードキャストアクセス方式では、インターネットなど任意のネットワークトポロジを仮想的に使用してクライアントにアクセスすることができます。

TCP/IP 標準に準拠するすべてのサブネットは、ネットワークアドレス(192.168.1.0 など)とサブネットマスク(255.255.255.0 など)の両方を持ちます。ルータはこれらのアドレスとマスクを使用して、コンピュータが接続している物理ネットワークを特定します。ルータは、特定サブネット上のすべてのコンピュータに対するクエリもサポートします。Retrospect は、マルチキャストアクセスの場合と同一の Piton プロトコルを使用して、そのサブネットブロードキャストアクセス方式にこの機能を利用します。

Retrospect のサブネットアクセス方式では、利用するサブネットのアドレスとマスクを定義し、ネットワークの変更に応じてこれらの設定を更新する必要があります。

ダイレクトアクセス

ダイレクトクライアントアクセス方式を使用して、特定のバックアップクライアントを Retrospect のクライアントデータベースに追加することができます。この方式では、ユーザは各バックアップクライアントの IP アドレス、または DNS 名か WINS 名を知っておく必要があります。DHCP サーバから動的 IP アドレスを取得するコンピュータには、数値の IP アドレスを使用しないでください。これは、アドレスが変更されたときに Retrospect は変更を知る手段がないためです。

ダイレクトアクセスによるクライアントの追加は、数クライアントを追加する場合に有効です。この方式で多くのクライアントを追加するには無駄が多すぎます。多くのクライアントを追加する場合は、他の方式の使用をお勧めします。

アクセス方式の設定

最初に「ネットワーク状況」ウィンドウを開くと、Retrospect は、マルチキャストアクセス方式を使用してローカルサブネット内のクライアントを検索します。「高度な機能」をクリックして、高度なネットワーク機能にアクセスします。ウィンドウでは、ネットワークインターフェイスとアクセス方式用のコントロールが表示されるようになります。

251

サブネットブロードキャストアクセス方式

ユーザは、別のサブネットを定義し、そのサブネットで Retrospect がクライアントを検索するようにできます。

高度な機能が表示された「ライブネットワーク」ウィンドウの「サブネットブロードキャスト」をクリックして、検索する新しいサブネットを設定します。この機能を最初に使用するときにはサブネットは設定されていないので、クライアントは表示されていません。「サブネット」ボタンをクリックします。同様に、この機能を最初に使用するときにはサブネットは設定されていないので、設定ウィンドウには何も表示されていません。

252

「追加..」をクリックして表示されるダイアログボックスに、サブネット内の IP アドレスとそのサブネットマスクを入力します。「OK」をクリックします。

定義した IP サブネットは、サブネット設定ウィンドウに表示されます。

253

後で必要に応じてサブネットを追加、変更、削除できます。

「OK」をクリックして「ネットワーク状況」ウィンドウに戻り、サブネットブロードキャストアクセス方式を使用して Retrospect により検出されたバックアップクライアントを表示します。

254

サブネットブロードキャストアクセス方式でクライアントを追加すると、Retrospect は定義したサブネットからそのクライアントを検索します。

Retrospect がクライアントを検索するときは、設定したすべてのサブネットにアクセスします。このようなアクセスは、このウィンドウを開いているときだけでなく、ある操作で Retrospect がクライアントを検索するときにも同様です。

インターフェイスを定義して使用する(インターフェイスを参照)ことにより、各クライアントの検索対象になるサブネット数を制限することができます。

ダイレクトアクセス方式

高度な機能が表示された「ネットワーク状況」ウィンドウで、アクセス方式ボタン「ダイレクト」をクリックします。クライアントの既知の IP アドレス、または DNS 名か WINS 名を入力するために、表示がクライアントリストからエントリボックスに切り替わります。

255

名前またはアドレスを入力して、「追加」をクリックします。指定したアドレスでクライアントが見つかると、そのクライアントをクライアントデータベースにログインさせる前にパスワード入力を求めるメッセージが表示されます。

指定した IP アドレスでクライアントに接続できなかった場合は、クライアント設定のトラブルを参照してください。

正しいパスワードを入力すると、クライアントのプロパティウィンドウが表示されます(クライアントの設定を参照)。

インターフェイス

Retrospect のインターフェイス機能では、アダプタカードを複数の選択肢から選択し、バックアップクライアントのグループ向けにネットワークオプションを制御することができます。たとえば、カスタムインターフェイスでは、異なるサブネット上のクライアントをバックアップするためにバックアップデータがルータを経由する必要がないため、ネットワークの帯域幅が節約されます。

Retrospect は、クライアントデータベースへのクライアントの追加に使用したインターフェイスを記憶しているので、そのクライアントへのすべてのアクセスにはインターフェイスの設定を使用します。クライアントに使用したインターフェイスを変更するには、クライアントプロパティウィンドウの「アクセス」タブを使用します。

複数同時操作を実行するときに複数の NIC を持つバックアップコンピュータの利点をいかすには、NIC #1 を使用しているクライアントと NIC #2 を使用しているクライアントが別々のバックアップセットにバックアップされるようにしてください。

Web ブラウザなどの TCP/IP ベースのプログラムが TCP/IP 接続を開始する場合は、コンピュータの「デフォルト」の IP アドレスを使用して自身を識別します。コンピュータが複数のアドレスを持つ場合、Retrospect のインターフェイスでは使用するアドレスを選択することができます。

インターフェイスでは、「高度な設定」オプションをグループ化することもできます。たとえば、クライアントの 1 つのグループに別のグループとは異なるタイムアウト値を持たせたい場合は、2 つの個別の Retrospect インターフェイスを作成して、両方に同じアダプタを指定し、互いのタイムアウト設定を別にすることで実現できます。

インターフェイスの設定

Retrospect ナビゲーションバーから、「設定」>「クライアント」を順にクリックすると、「バックアップ クライアント データベース」ウィンドウが表示されます。ウィンドウのツールバーにある「インターフェイス」ボタン256 をクリックし、インターフェイスウィンドウを開きます。

257

インターフェイスウィンドウには、デフォルトのインターフェイスと追加したすべてのインターフェイスが表示されます。

「インターフェイス新規」:「新規」ボタンをクリックし、新規インターフェイスの名前を入力して「新規」をクリックします。この時点から、以下に説明するようにインターフェイスを編集します。

「インターフェイス編集」:リストからインターフェイスを選択し、「編集」ボタンをクリックします。

オプションやオプションに付随するさまざまな問題に完全に慣れるまでは、デフォルトのインターフェイスを編集しないでください。

258

最初に TCP/IP インターフェイス(通常はネットワークアダプタカード)を選択する必要があります。静的 IP アドレスや DHCP サーバが動的に割り当てる IP アドレスを使用することもできます。デフォルトのインターフェイスは常にコンピュータのデフォルトの TCP/IP アドレスを使用し、変更することはできません。

最適なパフォーマンスを得るためにも、Windows のデフォルトネットワークとして、もっとも高速なネットワーク接続を使用していることを確認してください。

「高度な設定」オプションの設定

「インターフェイス」ウィンドウから、「高度な設定」ボタンをクリックして、「高度なインターフェイスの設定」ウィンドウを開きます。

259

一般オプションの分類項目に Retrospect のタイムアウトがあります。

260

「ネットワーク再実行の警告」:指定した時間内にクライアントが応答しない場合、Retrospect は「ネットワーク再実行」ダイアログボックスを表示します。

「接続タイムアウト」指定した時間内にクライアントが応答しない場合、Retrospect は確立したクライアントとのネットワーク接続を終了します。Retrospect は接続を終了し、エラー –519(ネットワーク通信に失敗しました)を報告します。オペレーティングシステムの TCP/IP 自身は、通常の接続タイムアウトで指定した時間の前にエラー –519 でタイムアウトになります。この値には、Retrospect がクライアントによる通信の再開を待機できる最大時間を設定するようにしてください。

TCP/IP 分類項目には、クライアントに対する接続、表示、マルチキャストの各オプションがあります。

261

「検索ポーリング間隔」クライアントが最新のアドレスで利用できない場合、Retrospect はこの間隔でクエリを送信します。

「検索タイムアウト」指定した時間内にクライアントを見つけることができない場合、Retrospect はそのクライアントの検索を終了します。

このタイムアウトは、Proactive Backup スクリプトのポーリングオプション(Proactive Backup のポーリングオプションを参照)でさらに制限される場合があります。

262

「ライブポーリング間隔」ネットワーク状況ウィンドウでクライアントをポーリングする場合、この時間間隔でクライアントにブロードキャストします。インターフェイスに複数のサブネットを設定した場合、Retrospect は、定義されたサブネットの数でポーリング間隔を除算し、それぞれに間隔を等しく分け与えます。

「コンテナを削除」指定したシーケンシャルなポーリング回数でクライアントが応答しない場合、Retrospect はクライアントをライブネットワークウインドウから削除します。このオプションは、すでにバックアップクライアントデータベースに追加されているクライアントには影響しません。

263

「マルチキャスト実行時間」Retrospect は、この「実行時間」の値をマルチキャストの UDP パケットに割り当てます。この値は、パケットが破棄されるまでに実行できるルータの最大ホップ数です。「実行時間」の値を増やすことにより、Retrospect は、IGMP ケーブルルータで接続されたより多くのサブネット上でクライアントを検索することができます。IGMP をサポートしていないルータは、マルチキャストの UDP パケットを転送しません。

新 Retrospect クライアント ソフトウェア

Retrospect クライアント ソフトウェアを使用すれば、個人のユーザーでもコンピュータ上で実行するバックアップおよび復元操作をコントロールすることができます。 同ソフトウェアは Windows と Mac OS 向けに新デザインが登場しました。 新しい特長は以下の通りです:

  • Windows タスクバーと Mac メニューバーを統合した最新のユーザーインターフェイス
  • ユーザー始動によるバックアップと復元
  • オプションを改善し、使いやすく整理した環境設定パネル
  • リンク内暗号化に強力な AES-256 暗号を採用

注記 : Retrospect ではシステム管理者がこれらの機能へのアクセス制限を管理できます。 詳細は、クライアント機能と環境設定のロック

ユーザー始動によるバックアップと復元

ユーザーは、デスクトップから直接ファイルを復元したり、バックアップを要求できるようになりました。 Retrospect クライアント ソフトウェアをインストールすると、Retrospect アイコンが Windows タスクバーまたは Mac OS メニューバーに追加されます。 このアイコンをクリックするとメニューが開き、バックアップまたは復元操作を開始することができます。

addendum_rug-2.jpg
addendum_rug-3.jpg

ユーザー始動によるバックアップ

このバックアップ方法は、特定のファイルやフォルダを迅速に保護したい場合に適しています。 この方法は定期的なバックアップの代替方法ではなく、コンピュータのフルシステムバックアップを実行する場合には使用できません。

ユーザー始動によるバックアップを実行するには:

  1. Windows タスクバーまたは Mac OS メニューバーの Retrospect アイコンをクリックします。
  2. 今すぐバックアップ を選択します。
  3. [バックアップファイルとフォルダを使用] ダイアログボックスで、バックアップ対象の項目を選択します。
  4. バックアップ をクリックします。

ユーザー始動によるバックアップに関する注意事項:

  • [今すぐバックアップ] および [ファイルを復元] メニュー項目は、クライアントコンピュータが Retrospect サーバ(これらのオプションが有効になる)にログインするまで、非アクティブです。
  • Mac: デフォルトでは、バックアップされたファイルとフォルダは Retrospect クライアント環境設定 でシステム管理者が選択したメディアセットに保存されます。メディアセットは、バックアッ プオンデマンドポップリストを使って選択します。
  • Windows: デフォルトでは、バックアップされたファイルとフォルダは Retrospect クライアント環境設定内でシステム管理者が選択したバックアップセットに格納されています。 バックアップセットは、バックアップオンデマンドポップリストを使って選択します。

ユーザー始動による復元

復元を実行するには、クライアントのコンピュータにあるタスクバーまたはメニューバー上で復元 ボタンをクリックします。これは Retrospect クライアント環境設定ウィンドウの履歴 タブにあります。

ユーザー始動による復元を実行するには:

  1. クライアントのコンピュータでタスクバーまたはメニューバーにある Retrospect アイコンを
    クリックします。
  2. ファイルを復元 を選択します。
  3. [ファイルとフォルダを復元] ウィンドウで、メニューから復元したいファイルを含むバックアップを選択します。
  4. Retrospect 指定のバックアップに含まれるファイルの一覧を検索します。 リストの表示に時間がかかることがあります。

  5. 復元するファイルを選択します。
  6. 復元 をクリックします。
  7. すでにある場所にファイルを復元する場合、確認ダイアログが表示されます。

  8. 別の場所を選択するには、参照 をクリックします。 続行するには、復元 をクリックします。

クライアント環境設定の改善

Retrospect クライアント環境設定ウィンドウを Mac で開くには :

  • メニューバーの Retrospect メニューアイコンをクリックします。Retrospect クライアント環境 設定を選択します。
  • ドックでシステム環境設定をクリックします。Retrospect クライアントアイコンをクリックし ます。
  • Apple メニューからシステム環境設定を選択します。Retrospect クライアントアイコンを クリックします。

Retrospect クライアント コントロールパネルを Windows で開くには:

  • スタート > プログラム (またはすべてのプログラム)> Retrospect > Retrospect クライアントをクリックします。
  • Windows のタスクバーで Retrospect クライアント アイコンをクリックし、Retrospect クライアント環境設定を開くを選択します。

クライアント環境設定の設定

環境設定は、 ステータス、履歴、通知、プライバシー、スケジュールのカテゴリに分類されています。 カテゴリボタンのいずれかをクリックして、各設定にアクセスします。

addendum_rug-4.jpg
addendum_rug-5.jpg

ステータス環境設定

  • Retrospectサーバ による保護: バックアップコンピュータによるクライアントへのアクセスを拒否にしたい場合に、このオプションを使用します。
  • クライアント名 : Retrospect が使用するクライアント名とクライアント IP アドレスがここに表示されます。
  • ステータス領域 : 最新バックアップと次のバックアップに関する情報が表示されます。 バックアップが実行中の場合は、進捗バーが表示されます。

履歴環境設定

  • 履歴領域 : ディスクベースのバックアップが一覧表示されます。 各行ごとにバックアップ情報と復元 ボタンが表示されます。 緑のアイコンはバックアップが正常に完了したことを示します。 黄色のアイコンは、バックアップの1つ以上のファイルで問題が発生したことを示します。 赤のアイコンはバックアップに失敗したことを示します。 いずれかのバックアップから作業の復元を開始するには、該当する復元 ボタンをクリックします。

通知環境設定

  • バックアップ後に通知 : バックアップやその他の操作が完了すると、メッセージを表示します。
  • N 間バックアップがない場合に通知: 入力ボックスで指定した日数、クライアントがバックアップされていない場合、メッセージを表示します。
  • SMART エラーを報告 : Retrospect がクライアントの SMART ハードドライブのボリュームで
    エラーを検出すると、"プロアクティブバックアップ"(使用可能な場合)からのバックアップを要求します。 この設定のデフォルトはオフです。

プライバシー環境設定

  • プライバシー領域 : この領域には "プライベート" として指定されたファイルやフォルダを表示します。 "プライベート" ファイルは、Retrospect サーバで非表示で、バックアップされません。 ボリュームやファイル、フォルダを "プライベート" に指定する場合は、ここへドラッグします。
  • 追加/削除ボタン : プライバシーリストにファイルやフォルダを追加するには、追加 ボタンを
    クリックして追加するファイルやフォルダまで移動します。リストから項目を削除する場合は、[除外] 領域で項目を選択し削除 ボタンをクリックします。
  • システム上でのファイル変更を Retrospect に許可(復元に必須): このオプションを選択解除すると、クライアントをバックアップすることはできますが、クライアントのファイルをバックアップコンピュータによって復元、修正、または削除することはできません。 この設定は、デフォルトではオンになっています。

スケジュール環境設定

  • プロアクティブバックアップは以下の日付まで延期 [日付 & 時刻] : 指定した時刻または日付まで、クライアントコンピュータのバックアップが実行されません。最大で現在の時刻から1週間後まで設定できます (時刻および日付をクリックして、数字を入力するか、矢印をクリックして変更します)。

クライアント機能と環境設定のロック

Retrospect システム管理者には、ユーザーによる特定のクライアント設定変更を阻止する権利があります。 例えばユーザーがコンピュータをバックアップしないように設定した場合、管理者としてはこれは好ましくありません。

システム管理者にとって最も効率的なワークフローは、標準のロックアウト環境設定を確立し、
クライアントごとに必要なカスタム化を適用していく方法です。 以下にその手順を説明します。

デフォルトのロックアウト環境設定を設定するには:

  1. ロックアウトコントロールは Retrospect コンソールにあります。 Mac: Retrospect > 環境設定を選択 し、クライアントタブをクリックします。で、構成 > 環境設定 > クライアントに許可 を選択し ます。。 Windows: Retrospectコンソールサイドバーで、構成 > 環境設定 > クライアントに許可 を選択します。
  2. クライアントに許可セクションで、以下のような1つ以上の設定を修正します:
    • Retrospectクライアント ソフトウェア を終了: これをチェックすると、Retrospect サーバでクライアントが非表示になります。 サーバとクライアントの通信はすべて切断されます。 クライアントがオフの間、すべての実行予定のバックアップ スケジュールは実行されません。
    • バックアップの実行を中止 : これをチェックすると、進行中の操作を停止することができます。
    • バックアップから項目を削除 : これをチェックすると、ファイル、フォルダー、
      ボリュームをプライベートとしてマークし、Retrospect で非表示になります。
    • 読み取りアクセス専用 : これをチェックすると、Retrospect はユーザーのコンピュータ上でファイルの書き込みや削除が実行不可になります。
    • バックアップオンデマンド : これをチェックすると、ユーザーは指定のバックアップセットへ必要に応じてバックアップを開始できます。 バックアップセットの選択...をクリック [バックアップセット] を選択します。
    • オンデマンドで復元 : これをチェックすると、ユーザーは利用可能なバックアップセットから、必要に応じて復元を開始できます。

各クライアントのデフォルト環境設定をカスタマイズするには:

  1. Mac: Retrospect コンソールバーでソースを選択します。 Windows: でソースを選択します。Retrospect サイドバーで構成 > クライアントを選択します。
  2. リストからクライアントを選択します。
  3. をクリックします。プロパティをクリックします。
  4. このクライアントにあわせて環境設定を修正します。

クライアントのバックアップ

バックアップコンピュータに直接接続されたボリュームをバックアップするのと同じ方法で、クライアントボリュームをバックアップします。

基本バックアップまたはスクリプトによるバックアップを設定すると、元ボリュームのボリューム選択ウィンドウには、バックアップクライアントコンテナの下に利用可能な各クライアントが、個々のクライアントコンテナの下には利用可能な各クライアントボリュームが、それぞれ表示されます(コンテナを参照)。

275

基本バックアップを設定するか、バックアップスクリプトを作成すると、元ボリュームのボリューム選択ウィンドウからクライアントやクライアントボリュームを、いくつかの異なる方法で選択することができます。クライアントコンテナ、特定ボリューム、またはバックアップクライアントコンテナを選択できます。クライアントコンテナまたはバックアップクライアントコンテナの使用をお勧めします。以下に各方法の特長を説明します。

バックアップクライアントコンテナを選択すると、後で追加する新規クライアントなど、バックアップ時にログインする個々のクライアントコンテナ(以下に説明)がすべて選択されます。

クライアントコンテナを選択すると、クライアントの一般的な設定で特定されるボリュームが選択されます。クライアントの一般的な設定については、「ボリューム」タブを参照してください。クライアントコンテナを使用すると、名前が変更されているボリューム、置換されているボリューム、またはパーティション分割されているボリュームのバックアップを管理者の介入なしに続行できるので、簡単でメンテナンスが不要になります。

個々のボリュームを選択すると、コンテナとは異なり、特定のボリュームだけが選択されます。Retrospect は、名前が変更されているボリュームの選択を続行しますが、新規の置換されたボリュームやパーティション分割されたボリュームに合うように自動的に調整することはありません。クライアント設定を変更した場合、調整のために介入する必要があります。この方法でボリュームを選択すると、特定クライアントの一部のボリュームをバックアップする場合などに役立ちます。ボリューム選択の詳細については、ボリュームの操作を参照してください。

スクリプトでフォルダまたはグループを選択する場合は、フォルダまたはグループに置かれているすべてのボリュームとクライアントコンテナが選択されます。この方法は、元ボリュームを 1 つの場所(「設定」>「ボリューム」で利用できるボリュームデータベースウィンドウ)で管理できるのでスクリプト管理が簡単になります。フォルダをバックアップクライアントコンテナで使用することで、多くのクライアントをより適切に構成することができます。グループを使用することで、同時にバックアップする必要があるボリュームとクライアントのリストを作成することができます。

公開鍵/秘密鍵方式でバックアップクライアントデータベースに自動的に追加された Windows 用 Retrospect クライアントコンピュータは、バックアップクライアントコンテナのフォルダ「Automatically Added Clients」にグループ分けされます。Retrospect の「クライアントを自動で追加」設定を有効にし、スクリプトで記述されたバックアップ元として 「Automatically Added Clients」 フォルダを選択すると、Retrospect によって新規クライアントがこのフォルダに自動的に追加され、バックアップされます。バックアップ管理者の操作はいっさい不要です。この機能の制限を含む詳細については、クライアントの追加を参照してください。

Windows クライアントの操作

この項には、Windows クライアントの使用方法に関するヒント、および Windows クライアントの制限についての情報があります。

Windows システム状態のバックアップ

Windows システム状態をバックアップするオプションがオン(Windows システムオプションを参照)で、Windows フォルダがファイルの選択基準に含まれている場合、Retrospect は Windows システム状態をバックアップします。

システム状態はクラッシュまたは破損した Windows コンピュータ全体を復元するために必要であるため、バックアップではこのオプションの検証を必ず行ってください。

除外されるファイル

Retrospect は特定ファイルをバックアップまたは復元から除外するため、これらのファイルをブラウザで表示しません。特定のファイルとは、アクティブな仮想メモリスワップファイル(Swp または .Par および Pagefile.Sys)および一部のクライアントソフトウェアファイルです。

オープンファイル

オープンファイルバックアップのライセンスコードを持つ場合、Windows クライアントコンピュータ上にあるオープンファイルをバックアップすることができます。

Windows コンピュータ上の開いているファイルをバックアップするには、NTFS ボリュームがなければなりません。

オープンファイルバックアップを持たない場合は、開いていた書類やアプリケーションが閉じていることを確認してからバックアップしてください。

スクリーンセーバー

バックアップ時に最適なパフォーマンスを維持するには、Windows クライアントコンピュータで処理の激しいスクリーンセーバーを使用しないことが必要です。

Mac OS クライアントでの作業

この項には、Mac OS クライアントの使用方法に関するヒントと、Mac OS クライアントの制限についての情報があります。Retrospect には、Mac OS クライアント専用に設計された複数の実行オプションがあります。詳しくは、Macintosh クライアントオプションを参照してください。

FileVault

Mac OS X 10.3 には、FileVault と呼ばれる新機能があります。FileVault を有効にすると、「ホーム」フォルダの内容全体が実行中に sparseimage ファイルに暗号化され、このファイルから復号化されます。

sparseimage ファイルは頻繁に変更されるため、Progressive バックアップで常にバックアップされます。これに加えて、このファイルはかなり大きくなり、ほとんどの場合適切に復元できないため、Retrospect, Inc. では Mac OS X クライアントコンピュータの FileVault を無効にすることを推奨します。

FileVault を有効にしなければならない場合は、すべてのユーザデータがバックアップされ、復元できるように、次の手順を実行してください。

  • すべての FileVault ユーザがログインしていることを確認する
  • 各ユーザのボリュームをバックアップの元ボリュームとして選択する

クライアントコンピュータに、FileVault を有効にしたユーザのアカウントが複数ある場合は、すれらのユーザをすべてログインさせる必要があります。

276

上記の例では、名前の横にチェックマークの付いたユーザがログインしています。

これらのユーザがログインすると、Retrospect の「ボリュームデータベース」ウィンドウに、これらの各ユーザのフォルダが、それぞれ個別のクライアントボリュームとして表示されます。たとえば、FileVault のユーザである Chester がログインすると、「Chester」という名前の新しいボリュームが Retrospect の「ボリュームデータベース」ウィンドウに表示されます。

277

上記の例では、benc と chester がローカルコンピュータの FileVault ユーザです。

ユーザのデータを確実にバックアップするには、FileVault ユーザのボリュームを元ボリュームとして選択する必要があります。起動ディスクボリュームを選択しても、ユーザのデータは正しくバックアップされません。バックアップクライアントコンテナまたは特定のクライアントを選択すると、その中にある FileVault ボリュームも選択されます。

スリープ環境設定

スリープ状態にある Mac OS クライアントコンピュータを、Retrospect から復帰させてバックアップすることはできません。各 Mac OS クライアントコンピュータの環境設定で、スリープしないように設定していることを確認してください。

UNIX クライアントの操作

この項には、UNIX クライアントの使用方法に関するヒント、および UNIX クライアントの制限についての情報があります。UNIX クライアントをバックアップする場合は、その制限に留意する必要があります。Retrospect には、UNIX クライアント専用に設計された複数の実行オプションがあります。詳しくは、UNIX クライアントオプションを参照してください。

除外されるファイル

Retrospect は特定の UNIX クライアントファイルをバックアップまたは復元から除外するため、これらのファイルをブラウザで表示しません。

次のタイプのファイルはバックアップから除外されます。

  • character device crw-------
  • block device brw-------
  • socket files srw-------
  • fifos prw-------
  • doors drw-------

ファイルの命名

Linux には大文字と小文字を区別したファイル名があります。これは、「myfile」と「Myfile」が別のファイルであることを意味します。一方、Windows、Mac OS、および には大文字と小文字を区別したファイル名はありません。そのため、「myfile」と「Myfile」は同じファイル名と見なされます。

これらの 2 つのファイルが UNIX クライアントから Windows、Mac OS、または システムにコピーされると、「myfile」と「Myfile-1」という名前になります。ファイルがコピーされて UNIX コンピュータに戻されると、それらの名前は「myfile」と「Myfile-1」になります。

  • 一部の Mac OS システムでは、ファイル名の大文字と小文字の使い分けがサポートされており、これらのファイルを UNIX コンピュータとやり取りしてもファイル名が変化しません。

ファイルシステム変換

Retrospect では、異なるオペレーティングシステムとファイルシステムを使用するコンピュータ間でデータを復元および複製することができます。2 つのファイルシステムが完全に同じ属性やファイル形式をサポートすることはないので、1 つのファイルシステムから別のファイルシステムにコピーすると、情報が消失する場合があります。

Retrospect はデータを消失しない次のファイルシステム変換をサポートします。

  • FAT(Windows)から HFS(Macintosh)へ
  • FAT から NTFS(Windows)へ
  • HFS から NTFS へ
  • FAT から UNIX ファイルシステムへ
  • UNIX から HFS(Mac OS X のみ)へ

Retrospect は、次のファイルシステム変換をサポートしますが、拡張情報またはデータは消失します。

  • HFS から FAT へ:HFS ファイルのデータフォークはコピーされますが、属性、権限、リソースのフォークはコピーされません。
  • NTFS から FAT へ:最初のデータストリームはコピーされますが、すべての許可と残りの NTFS データはコピーされません。
  • NTFS から HFS へ:NTFS ボリューム上の Services for Macintosh のデータは、消失しないで Macintosh HFS ボリュームに復元または複製されます。Windows NTFS データを HFS にコピーすると、最初のデータはコピーされますが、すべての許可と残りの NTFS データはコピーされません。
  • NTFS から UNIX へ:許可と残りの NTFS データは消失します。
  • UNIX から HFS(Mac OS 9.x)へ:UNIX ファイルの許可、所有者、グループの各属性、特別なファイルの属性(ハードリンクなど)が消失します。
  • UNIX から FAT へ:UNIX ファイルの許可、所有者、グループの各属性、特別なファイルの属性(ハードリンクなど)が消失します。
  • Mac OS のファイル名は、Windows のファイル名で禁止されている文字を含むことができます。これらの不正文字は、「/」、「¥」、「:」、「*」、「"」、「<」、および「>」です。Macintosh ファイルを Windows ボリュームに復元または複製する場合、Retrospect では、これらの不正文字をすべてハイフン(-)に置き換えます。

Microsoft ネットワークボリューム

Retrospect クライアントソフトウェアの代わりに Microsoft ネットワークを使用して無人バックアップを設定する場合は、ボリュームに対して権限を持つユーザとして Retrospect を実行する必要があります。詳しくはセキュリティ環境設定を参照してください。

ボリュームデータベースにネットワークボリュームを追加する方法は、マイネットワークを参照してください。

この方法で Microsoft ネットワークのボリュームをバックアップする場合には、Retrospect によるレジストリとシステム状態のバックアップは行われません。レジストリとシステム状態をバックアップするには、対象のコンピュータに Retrospect クライアントソフトウェアをインストールし、そのコンピュータを Retrospect のクライアントとして使用します。

ネットワークバックアップのガイドライン

この項では、Retrospect を使用してワークグループのバックアップを設定するための情報、アドバイス、ワークシートについて説明します。

一般に、個々のバックアップに適用されるのと同一の原則が、クライアントコンピュータのネットワークバックアップにも適用されます。個々のバックアップとネットワークバックアップとの主な相違は、ストレージ容量の制限を圧倒するデータ量にあります。データの実質量や頻繁に発生するネットワークバックアップの速度低下の結果、時間も制限される場合があります。ネットワーク全体を一晩でバックアップできない場合は、バックアップを何日かの夜間に分割したり、書類だけをバックアップしたり、Proactive Backup スクリプトを使用したりすることを検討する必要があります。

この項で扱う情報は、すべてのローカルエリアネットワークに適用できますが、例では、基本的な Ethernet ネットワークのインストールを想定しています。ネットワークがルータやゲートウェイなどのネットワーク間デバイスを含む場合、バックアップワークグループの一部のメンバーがネットワーク間デバイスによって分割されない限り、ほとんどの計算を適用できます。ルータやゲートウェイ経由でバックアップを実行すると、バックアップを完了するための時間が増加します。

バックアップデバイスの選択

バックアップデバイスの容量は、一般に自動実行のワークグループバックアップでは最も重要な検討事項です。ネットワークのバックアップほど、容量を消費するものは他にありません。容量が大きければ、多くのクライアントコンピュータから多くのファイルをバックアップしたり、バックアップするファイルの選択基準を広げたり、メディア交換にかかる合計時間を増やしたり、1 メディア当たりのバックアップセッション数を増やしたりすることが可能になります。

バックアップデバイスに十分な容量がなければ、バックアップの完了前にメディアを交換する必要があるため、自動実行のバックアップは完了できません。

バックアップコンピュータの選択

この項では、正しいバックアップデバイスを選択するための方法や、計画したネットワークバックアップに適するバックアップコンピュータを選択するための方法についてアドバイスします。

ファイルサーバをバックアップコンピュータとして使用する必要はありません。デスクトップコンピュータやサーバをバックアップコンピュータに使用する利点 に、デスクトップコンピュータやサーバをバックアップコンピュータに使用する利点を示します

バックアップコンピュータには、Windows と互換性を持つモデルならどれでも使用できますが、ネットワークバックアップの実行に対応できるかどうかを考慮して選択する必要があります。たとえば、中小規模のハードディスク容量を搭載する少数のクライアントコンピュータをバックアップする場合は、400 MHz Pentium の使用をお勧めします。これに対し、大容量のファイルサーバや数千ものファイルを持つクライアントコンピュータ群をバックアップする場合は、Pentium IV の使用をお勧めします。以下に、選択する際の検討事項を示します。

バックアップコンピュータのパフォーマンスが、システム全体のパフォーマンスに影響することはよくあることです。一般に、高性能のコンピュータほど、より多数のクライアントコンピュータからより多くのデータをネットワーク経由でバックアップできます。

M = J / L

ソフトウェアの圧縮と暗号化で CPU の使用量が著しく増加します。これらの機能の使用を考えているなら、Pentium IV などのより強力な CPU を搭載するモデルを選択する必要があります。

バックアップコンピュータが、ほとんどのファイルを格納するネットワークボリュームを処理するのに十分な RAM を持つことを確認します。所有するファイルが多くなれば、多くの RAM が必要になります。

バックアップコンピュータが予定時間内にバックアップを完了しない場合、またはボリュームのバックアップ回数を増やしたい場合は、高速のバックアップコンピュータや高速のバックアップデバイス、またはその両方が必要になることがあります。

詳しくは、リソースの管理を参照してください。

暗号化と圧縮

Retrospect は暗号化機能を提供して、バックアップ時に権限のないアクセスからデータを保護します。また、圧縮機能を提供して、保存されるデータを圧縮することでバックアップデバイスの容量を節約します。これらの機能のいずれか 1 つを使用するか両方を使用するかにより、選択するバックアップデバイスのタイプが影響を受けることがあります。Retrospect による暗号化と圧縮は、バックアップ速度を低下させることに注意してください。特に、コンピュータの CPU が強力でない場合は、速度への影響が顕著になります。圧縮をサポートするテープドライブを持つ場合、テープドライブは、Retrospect よりも高速にデータを圧縮するので圧縮タスクも実行します。以下の表を参照して、圧縮や暗号化を使用する必要があるか、バックアップ機器として圧縮テープドライブが適しているかなどを判断してください。

機能

説明

手続き

実行内容

圧縮

バックアップデバイスはメディア上により多くのファイルを保存できます。

データ内のパターンを検出します。検出するパターンが多くなると、圧縮率が高くなります。

圧縮ドライブがある場合、データの圧縮が Retrospect よりも速いので、Retrospect は圧縮のタスクをハードウェアに任せます。

暗号化

バックアップにセキュリティを追加します。

権限のないアクセスを防止するためにデータの出現をランダムにします。

Retrospect は常時暗号化を管理します。

暗号化の伴う圧縮

バックアップデバイスはメディア上により多くのファイルを保存できるだけでなく、バックアップにセキュリティを追加します。

圧縮は暗号化の前に実行する必要があります。

Retrospect では両方の機能を実行する必要があります。圧縮ドライブがある場合は、両方を使用できないので、暗号化を使用するかハードウェア圧縮を使用するかを選択する必要があります。暗号化を使用すると、Retrospect は自動的にハードウェア圧縮を無効にします。

デバイス容量ワークシート

このワークシートを使用して、ワークグループ用バックアップデバイスに必要な最小容量を概算します。G で算出された値は、メディアを交換しないで自動実行のバックアップを完了するためにバックアップデバイスメディアが必要とする最小容量です。

項目

説明

A. 合計ディスク容量


ユーザ定義

別のページに、ワークグループのコンピュータと個々のディスクサイズ(MB)を示します。

合計を計算し、結果を A に代入します。

B. データ重複量の概算


ユーザ定義

Retrospect がバックアップを一度だけ実行する場合に、どれくらいのデータが重複するかを概算します。ワークグループのすべてのメンバーが同一のアプリケーション、ディクショナリ、フォントなどを使用する場合は、60%(0.6)のデータ重複があると考えられます。平均的なネットワークの場合、30%(0.3)を代入します。

重複パーセントの概算を小数点形式で B に代入します。

C. 縮小要素


C
= 1 - B

1 から値 B を減算して、データ縮小要素を取得します。たとえば、B が 0.3 の場合、縮小要素は 0.7( 1 - 0.3 = 0.7 になるため)になります。

差を計算し、結果を C に代入します。

D. 縮小データ


D
= AC

バックアップに必要な圧縮前のデータの実容量を概算するには、合計ディスク容量(A)と縮小要素(C)を乗算します。

積を計算し、結果を D に代入します。

E. 圧縮の概算


ユーザ定義

圧縮率はファイルにより異なります。テキストファイルの圧縮率は高く、アプリケーションファイルの圧縮率は低くなります。予測できる通常の圧縮率は 50%(0.5)です。ネットワークのバックアップで予測できる平均的な圧縮率は 30%(0.3)です。圧縮を使用しなければ、0 を代入します。

圧縮パーセントの概算を小数点形式で E に代入します。

F. 圧縮要素


F
= 1 - E

1 から圧縮の概算(E)を減算します。たとえば、E が 0.30 (30%)の場合、F は 0.70( 1 – 0.30 = 0.70)になります。

差を計算し、結果を F に代入します。

G. 必要なバックアップ容量


G
= DF

必要最小限のバックアップデバイス容量を計算するには、縮小データ量(D)と圧縮要素(F)を乗算します。

積を計算し、結果を G に代入します。

バックアップ所要時間ワークシート

バックアップデバイスのサイズが決定したら、以下のワークシートを使用して、ネットワークバックアップで必要な時間数を決定します。合計時間が 12 時間よりも少ない場合は、一晩で書き替えバックアップを完了できます。合計時間が 12 時間を超える場合は、書き替えバックアップを週末だけ実行することや、書類や環境設定だけをバックアップすることなど別の計画を検討する必要があります。

別の計画については、バックアップ計画を参照してください。

項目

説明

H. バックアップ
容量の必要条件


H
= D

H には、デバイス容量ワークシートの項目 D の合計縮小データを代入します。

I. 検証乗数


ユーザ定義

検証を使用しない場合は、1 を代入します。完全検証では 1 .7 で開始します。メディア検証では 1.2 で開始します。ソフトウェアの圧縮または暗号化を使用する場合は、0. 1 ~ 0.5 だけ増やします。バックアップコンピュータが遅い場合は、値を増やします。

検証乗数を I に代入します。

J. 合計転送量


J
= H I

ネットワーク経由で転送されるデータの合計量を求めるには、バックアップ容量の必要条件(H)と検証乗数(I)を乗算します。

積を計算し、結果を J に代入します。

K. ネットワークのスループット


ユーザ定義

スループット率は、ネットワークのケーブル方式で変動します。10BaseT の場合は 2400 MB/時を使用し、100BaseT の場合は 9600 MB/時を使用します。

1 時間当たりの MB の値を K に代入します。

L. 調整後のネットワークのスループット


L = K ( 1 - .05n)

ルータを使用するバックアップでは、一般に各ルータに対してパフォーマンスを 5% 減算します(n はルータ数)。

差を計算し、結果を L に代入します。ルータまたはブリッジを使用していない場合は、LK の値を代入します。

M. 所要時間

バックアップに必要な合計時間数を決定するには、合計転送量(J)を調整後のネットワークのスループット(L)で除算します。

商を計算し、結果を M に代入します。