Microsoft Exchange Mailbox Backup Requirements

Microsoft Exchange and SQL


Part 1

You must create a Retrospect Backup User account (RBU) that is a member of:

  1. Domain Users

  2. Domain Administrators

  3. Backup Operators

  4. Local Admins if Retrospect is running local to the Exchange Server

  5. Some 2010 users have needed to add the RBU user to Organization Management and Exchange Trusted Subsystems.

  6. Do NOT include any other groups

    • The account must have a mailbox.

    • The account can NOT be hidden from the Global Address List or GAL.

    • You must send at least one email to the mailbox to initialize the mailbox.

.NET 4: Retrospect 8 for Windows or later requires Microsoft .NET 4.0 or later in order to access Exchange and Exchange mailboxes. In some cases you will be unable to even open Retrospect if you do not have .NET 4 installed on your exchange server. .NET 4 is found at: http://www.microsoft.com/en-us/download/details.aspx?id=24872.

PowerShell: Some users with Exchange 2010 on Windows 2008 and 2008 r2 have reported authentication problems connecting to Exchange if they have installed PowerShell 3.0. We recommend uninstalling PowerShell 3.0. Contact Microsoft for specific uninstall directions.

Exchange 2010 on Windows 2012 Server: Exchange 2010 with SP 3 on Windows 2012 is supported in Retrospect 8.2 or later.

Part 2

  1. Go to Configure>Preferences>Security in Retrospect and configure Retrospect to Run as a specific user.

  2. Enter the RBU info into the Security settings.

  3. Go to Configure>Volumes. Right Click on the Exchange Server and select "Login As"

  4. Configure Retrospect to login to the exchange server using the Retrospect User account. Running Retrospect as the "domain administrator" is not good enough and you must use the steps in Part 1 above.

Mailbox Backup Requires MAPI

Exchange 2007 and later requires the install of Messaging API (MAPI) client libraries or Collaboration Data Objects (CDO) 1.2.1 as a part of the base product installation in order to see mailboxes inside Retrospect. You can download the MAPI 1.2.1 installer directly from Microsoft.

This MAPI Installer will not install on a system on which any version of Microsoft Outlook or Microsoft Exchange Server 2003 or earlier is installed. When you install Exchange 2007 & 2010 (SP1), you must check the option to allow Outlook 2003 support.

Exchange 2007 Required Components: You must be using a 64 bit version of Exchange 2007. Retrospect requires components in the Microsoft Visual C++ 2005 Redistributable Package (x64) be installed on the machine running Exchange Server 2007 on Windows 2003 Server in order to successfully back up the server. To install these components select the "Install Exchange Server 2007 Support" button in the Retrospect application installer. For more information, please see the Microsoft web site.

Additional Exchange 2007 & 2010 Troubleshooting

If Retrospect is backing up the Exchange 2007 & 2010 Server as a client and you are unable to see mailboxes, you can try the RPC Ping utility from Microsoft to confirm connectivity.

This utility is found at: http://support.microsoft.com/kb/831051. 

If the client access server (CAS) role is not on the same server as the mailbox databases, Retrospect can not access Exchange 2010 mailboxes.

Exchange 2013 support

Exchange 2013 is supported in Retrospect 8.5 and later. Retrospect may report an error -3420 and -3422 during mailbox backups. This error should have no direct impact the actual back of individual mailbox data and can be ignored.

Exchange 2016 support

Retrospect 11 for Windows is required for Exchange 2016 database backup. Mailbox backups are not supported.


Last Update: 01 mars 2016