HP Q1511A Utrium Gen 2

April 28, 2016

Hewlett Packard Enterprise

SCSI

LTO

-

200GB native

No

Mac Windows
Status Qualified Qualified
Minimum Product Required Desktop Professional
Minimum Version Required 5.0 6.0
Minimum Driver Update 3.2.104 3.5.103
Minimum Firmware
Notes Retrospect supports only the SCSI version of this device. -

Qualified - Passed extensive in-house certification. Storage device is fully supported.

Description

-

NewWhat's New in Retrospect – Retrospect 15 with Email Protection, BackupBot AI, Remote Backup, and more

Data Protection for Every Environment.

Personal

Business