Gestalt Warning in OS X 10.10 Console

Resources


You may see this message in the Console application (/Applications/Utilities/Console.app) when running the Retrospect Client for Mac on Apple OS X 10.10 and higher.

WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.1 instead of 10.11.1.
This is not a bug in Gestalt -- it is a documented limitation. Use NSProcessInfo's
operatingSystemVersion property to get correct system version number.

It is cosmetic and does not affect Retrospect. We will address this in a future release.


Last Update: 28. Januar 2016