第7章: Retrospectの管理

この章では、Retrospectのいくつかの機能(環境設定など)について
詳細に説明し、メディア セットの管理、レポートの表示、スクリプト
の維持など、さまざまなタスクの実行方法について説明します。
Retrospectを使用した、より効果的なバックアップを実行する方法についても説明します。

Retrospectの環境設定

Retrospectの環境設定を調整することにより、プログラムの動作をユーザーのニーズに応じて変更できます。Retrospectの環境設定は、Retrospectで実行するすべての操作に影響します。

[プリファレンス]ウィンドウを開くには、Retrospectのメニューで[プリファレンス]を選択します。[プリファレンス]ウィンドウを開くとツールバーが表示されます。このツールバーを使用して、アプリケーションの環境設定の各セクションを表示できます。ツールバーのアイコンをクリックすると、該当する環境設定が表示されます。Retrospectでは、最後に作業した環境設定パネルが記憶されるため、ウィンドウを表示するとそのパネルが表示されます。

07fig01.tiff

コンソール環境設定

[コンソール]環境設定は、RetrospectコンソールおよびログインしたすべてのRetrospectエンジンに適用されます。

Retrospectの更新を自動チェック]を選択すると、コンソールの起動時にプログラムへの更新がチェックされます。

[スケジュールされた最大nのアクティビティを表示]では、コン
ソールの[アクティビティ]カテゴリーに表示される、スケジュールされたアクティビティの数を制御します。表示するアクティビティの数は、ポップアップ メニューで、10、20、50、または100から選択できます。バックアップを毎日実行するよう設定されたスクリプトでは、スケジュールされたアクティビティが1年だけで365個あるため、表示件数を制限する必要があります。

行表示n操作ログを最大]では、操作ログの行数を制御できます。設定した行数に達すると、最も古いエントリーが表示されなくなります。表示されなくなったエントリーは、/Library/Application Support/Retrospect/に保存されたoperations_log.utxファイルに、[全般]環境設定で指定した最大ログ サイズまで保持されます(下の『ログ サイズの制限』を参照)。操作ログを表示するには、[表示]>[ログ]を選択するか、Cmd-Lを押します。入力フィールドに、必要なログの長さを入力します。

全般環境設定

[全般]環境設定では、ログインした各Retrospectサーバについての環境設定を設定します。ログインした各サーバは、ウィンドウ左のリストに表示されます。リスト内のサーバのうち制御するものをクリックします。

07fig02.tiff

[サーバ名]には任意の名前を指定できます。変更する場合はフィールドに名前を入力します。デフォルトでは、[システム環境設定]の[共有]パネルに示されたサーバ マシンのコンピュータ名がサーバ名として使用されますが、ユーザーにとって内容が分かりやすい名前に変更できます。サーバ名は、Retrospectクライアントの[履歴]セク
ションなどで、ユーザーに対して表示されます。

[サーバ アドレス]は、サーバ コンピュータのIPアドレスです。サーバにログインした後は、このフィールドは変更できません。

サーバのパスワードの変更]では、選択したサーバにアクセスする際に使用するパスワードを指定できます。ボタンをクリックするとダイアログが表示されます。そのダイアログに古いパスワード(ある場合)と新しいパスワードを入力し、確認のために新しいパスワードをもう一度入力します。[パスワードを変更]ボタンをクリックして、変更を確定します。

[許可するアクティビティ スレッドの数:nアクティビティ スレッド]では、1~8の数字を選択できるポップアップ メニューが表示されます。アクティビティ スレッドの数を設定することにより、複数の
バックアップ操作や復元操作など、同時に実行できるアクティビティの数を指定できます。デフォルトでは、Retrospectエンジンの並行アクティビティ スレッドは4に設定されています。効果的に同時実行できるアクティビティ スレッドの数は、Retrospectサーバ コンピュータのハードウェア性能やスレッドで処理するタスクの種類によって異なります。コンピュータのプロセッサ速度やインストールされたRAMの量だけでなく、転送されるファイル数によっても異なります。通常は、実行するアクティビティ1つにつき、1 GBの空きRAM容量が必要となります。

[ログ サイズの制限]では、操作ログのサイズ(MB)を設定できます。デフォルトでは、10 MBに設定されています。ログが制限に達すると、最も古い部分を削除することにより、サイズを制限内に抑えます。ログのサイズが大きいほど、開くのに時間がかかります。操作ログの最大サイズを入力フィールドに入力します。

[インターネット接続にプロキシ サーバを使用]では、メール通知の送信時に、Retrospectサーバとインターネットの間に別のコンピュータを媒介として設定できます。Retrospectサーバはプロキシ サーバに接続し、プロキシ サーバはRetrospectサーバの要求を解釈して、プロキシ サーバに設定されたフィルタリング ルールに従って要求をイン
ターネットに渡します。チェックボックスをクリックしてこの機能をアクティブ化し、プロキシ サーバの入力フィールドにIPアドレスまたはDNS名を入力し、必要に応じてプロキシ サーバが使用するポート番号も入力します。

クライアント環境設定

パブリック/プライベート キー認証は、Retrospectクライアントが、一致する暗号化キーセットを使用してRetrospectサーバに自動的にログインできる1つの方法です。[クライアント]パネルでは、Retrospectクライアント用に、これらのAES-256で暗号化されたプライベート/パブリック キーの証明書ファイルを作成できます。

この認証を設定するには、Retrospectサーバの/Library/Application Support/Retrospect/に2つのファイルを作成します。プライベート
キーとパブリック キーのファイル名は、それぞれprivkey.datpubkey.datとなります 。privkey.datファイルはRetrospectサーバで保持され、pubkey.datファイルは各Retrospectクライアントにコピーされ
ます。

Preferences clients.ja

キーペアを作成してRetrospectクライアントにインストールするには、次の手順に従います。

  1. [プリファレンス]>[クライアント]で、[キーの作成...]をクリックし、キー作成用の8文字以上のパスワードを入力して[作成]をクリックします。コンピュータの速度によっては、Retrospectのキー生成に1分ほどかかることがあります。
  2. 適切なパブリック キーを持つクライアントを自動的にログインするようにする場合は、[クライアントを自動的に追加]を
    チェックします。このオプションをチェックすることを推奨します。
  3. Retrospectインストーラのディスク イメージまたはCDから、Client Installersフォルダを開き、Mac Client Installerフォルダをハード ドライブにコピーします。
  4. Finderで/Library/Application Support/Retrospect/にあるpubkey.datファイルを検索し、それをハード ディスク ドライブのMacクライアント インストーラ フォルダにある「public_key」という名前のフォルダにコピーします。
  5. pubkey.datファイルを含むこのpublic_keyフォルダをRetrospectクライアント インストーラとともに配布またはコピーします。
  6. 各コンピュータにRetrospectクライアント ソフトウェアをインストールした後、RetrospectクライアントはRetrospect サーバにログインできます(または、Retrospectサーバでオプションが設定されている場合、自動的にログインされます)。

キーペア ファイルがRetrospectサーバにすでにある場合は、[参照]ボタンをクリックし、2つのキーペアがあるフォルダに移動し、[選択]をクリックして読み込みます。これにより、複数のRetrospectバックアップ エンジンで同じキーペア ファイルを共有できます。

メディア環境設定

[メディア]環境設定では、Retrospectによるテープやハード ディスクなどのメディアの扱い方法を制御できます。

[指定のメディアを自動的に再使用]では、データを含むメディアと同じ名前のメディアを消去する際に、ユーザーに確認しないよう設定できます。たとえば、「Tape Backup A」という名前のメディア セットの一部のテープが1つまたは複数あり、メディア セットのメンバーを定期的な間隔で自動的にリサイクルするようスクリプトで設定されている場合、このボックスをオフにすると、メディア セットの各メンバーを消去する前に確認が必要となります。

[消去確認を最小限に抑える]をオンにすると、バックアップ操作を進める際にRetrospectがメディアを消去する必要がある場合に通常は表示される確認メッセージが表示されません。デフォルトでは、このオプションはオフになっています。

07fig04.tiff

たとえば、「1-Media Set A」という名前のメディア セットのテープ メンバーに通常のバックアップを実行したとします。しかし、テープ ドライブに読み込まれたメンバーが1つだけ名前が異なっているとします。この場合、メディアの要求ウィンドウが表示されます。このウィンドウで、現在読み込まれているテープを選択できます。[消去確認を最小限に抑える]オプションがオンになっている場合は、テープを選択して[進む]をクリックすると、そのテープが消去されて使用されます。[消去確認を最小限に抑える]オプションがオフになっている場合は、本当にテープを消去するかを確認する警告ダイアログが表示されます。

[書き込み失敗後には新しいメディアを自動的に使用]では、メディアへの書き込みに失敗した場合に、失敗を報告してアクティビティをキャンセルするのではなく、書き込み先を空のメディアに移すように設定できます。

[テープの緩みを取る]は、Travan、OnStream、DC 6000ドライブなどの古いテープ ドライブで使用します。このオプションにより、スクリプトが終了したら自動的にテープを最後まで早送りしてから巻き戻すことで、テープの張りと位置を均等にできます。

[リムーバブル ディスクを取り出さない]。デフォルトでは、リムーバブル ディスクは、スクリプトが終了すると自動的に取り出されます。このオプションをオンにすると、自動的に取り出されなくなり
ます。

[メディア要求のタイムアウト: n分]では、実行中にRetrospectがメ
ディアを待つ時間を設定します。たとえば、テープ オートローダを使用している場合は、メディア セット内の特定のテープを検索して読み込むまで数分かかる場合があります。この環境設定はデフォルトではオフになっているため、メディア要求がタイムアウトになることはありません。

[空のメディアへ自動的にスキップ]では、メディア セットの最後のメンバーが使用できない場合(その最後のメンバーに空き領域がある場合でも)に、空のテープまたはディスクが使用されます。

[バックアップ操作中にMD5ダイジェストを生成]は、デフォルトでオンになっています。このオプションにより、バックアップ操作の一環としてMD5ハッシュ ダイジェストが生成されます。Retrospectでは、これらのダイジェストを使用することで、メディアの検証を高速化します。

ネットワーク環境設定

Retrospectでは、追加設定を行うことなく、クライアントのバックアップを実行できます。バックアップ コンピュータに複数のネットワーク インタフェースがある場合、またはクライアントが複数のサブネットに存在する場合、[ネットワーク]環境設定により、Retrospectがこれらのバックアップ クライアントにアクセスする方法を管理できます。たとえば、カスタム ネットワーク インタフェースにより、バックアップ データをルータに通すことなく、それぞれのサブネット上のクライアントをバックアップできるため、ネットワーク帯域幅を節約でき
ます。

Retrospectの環境設定で、さまざまなネットワーク インタフェースに名前を付け、特定のネットワーク アドレスに割り当てることができます。アドレスは順に使用されます。そのためには、次の手順を実行します。

  1. [Retrospect]>[プリファレンス]>[ネットワーク]を選択します。[サーバ]列に複数のRetrospectサーバが表示される場合は、制御するサーバを選択します。ウィンドウの右側の接続リストには、Macのデフォルトのネットワーク接続が表示され
    ます。
  2. ネットワーク インタフェースを追加するには、接続リストの下のプラス(+)ボタンをクリックします。開いたダイアログの[接続]ポップアップ メニューから、使用するネットワーク インタフェースのIPアドレスを選択し、接続の名前を入力し、
    [追加]をクリックします。
  3. 07fig06.tiff

  4. 接続リストに新しい接続が表示されます。クライアントやネットワーク共有を検索する際にRetrospectが使用するサブネットを制限することもできます。これを実行するには、接続リストで接続を1つ選択してから、[説明]ボックスの下のプラス(+)ボタンをクリックします。表示されるダイアログで、サブネット アドレスおよびサブネット マスクを入力し、[追加]をク
    リックします。サブネットの制限が[説明]ボックスに表示されます。

詳細設定

上級ユーザーは、Retrospectのネットワーク動作をさらに詳細に制御する必要があるかもしれません。[ネットワーク]環境設定パネルで
[詳細設定]ボタンをクリックすると、次の設定が表示されたダイアログが表示されます。

07fig07.tiff

[接続タイムアウト]:Retrospectがクライアントを待つ最大時間。
この最大時間を過ぎると、Retrospectはエラーを記録して、次のアク
ティビティに進みます。遅いネットワークを使用しており、519エラー
(ネットワーク通信エラー)が発生する場合は設定値を大きくします。

[検索ポーリング間隔]:クライアントが最後に認識されたアドレスに見つからない場合は、この間隔でクエリを送信します。

[検索タイムアウト]:指定した時間内にクライアントが見つからなかった場合は、既知のクライアントの検索を終了します。

[ライブ ポーリング間隔]:ライブ ネットワーク ウィンドウにあるクライアントにポーリングする場合は、この間隔でクライアントにブロードキャストします。インタフェースに複数のサブネットを構成した場合、ポーリング間隔は定義されたサブネットの数で割った値になります。

[カウント漏れ]:指定した数の連続したポーリングに応答がない場合は、ライブ ネットワーク ウィンドウからクライアントを削除します。これはすでにバックアップ クライアント データベースに追加されたクライアントには影響しません。

[マルチキャスト有効期限]:有効期限の数をマルチキャストUDPパケットの数に割り当てます。これは、ルータのホップ数の最大値で、これを超えるとパケットが破棄されます。有効期限の数を増やすと、検索対象となるIGMP対応ルータで接続されているサブネットの数が増えます。IGMPをサポートしていないルータでは、マルチキャストUDPパケットは転送されません。

変更する設定の横に値を入力して、[完了]をクリックします。

警告: このダイアログは、変更による影響を理解している場合、またはRetrospectのテクニカル サポートの指示があった場合にのみ変更してください。状況によっては、このダイアログでの変更により、Retrospectのパフォーマンスに悪影響がある場合があります。注意してください! 誤って変更してしまい、どの変更が問題の原因となっているのかを特定できない場合は、[デフォルトを使用]ボタンをクリックすることにより、選択したサーバについて、Retrospectのすべての環境設定を元に戻すことができます。

メール環境設定

Retrospectでは、正常に実行された場合および問題が発生した場合に
メール通知を送信できます。[メール]環境設定パネルでは、
Retrospectが使用する送信メール サーバ、および警告を送信する際にRetrospectが使用するメール アドレスを設定できます。デフォルトでは、Retrospectは警告メールを送信しません。

Email mac preferences

[送信メール サーバ]は、送信メール サーバのコンピュータ名(推奨)またはIPアドレスを入力するためのフィールドです。[サーバIPアドレス]:[ポート番号]のように、アドレスにポート番号を加えることにより、Retrospectがメール サーバと通信する際に使用するTCP/IPポートも指定できます。たとえば「smtp.servername.com:26」のように指定します。

[送信サーバ(SMTP)は認証が必要]は、送信メール サーバでログインを必要とする場合にオンにします。

ユーザー名: 送信メール サーバでログインが必要な場合は、メール管理者によってRetrospectに割り当てられたユーザー名を入力します。

パスワード: 送信メール サーバでログインが必要な場合は、関連するユーザー名に割り当てられたパスワードを入力します。

[完了したイベントのメールを送信]は、正常に実行が完了するたびにRetrospectからの通知を希望する場合にオンにします。ただし、多くのスクリプトを実行している場合は、大量のメールを受信する可能性があることに留意してください。

[失敗およびメディア要求の際メールを送信]は、実行中に問題が発生した場合にRetrospectからの通知を希望する場合にオンにします。このオプションをオンにする場合は、差出人および宛先の入力フィールドに有効なメール アドレスを入力する必要があります。宛先フィールドには複数の受信者を指定できます。各メール アドレスをカンマで区切ります。

[テスト メールを送信]:このボタンをクリックすると、宛先フィールドに入力されたアドレスにテスト メールが送信されます。

プロアクティブスクリプトとその他のスクリプトの比較 – プロアクティブバックアップではバックアップソースの優先度が賢く調整されるので、電子メールはバックアップソース毎に送信されます。その他のスクリプトについては、スクリプトのソースが全て完了すると電子メールが1通送信されます。一方、イベントにアクション (バックアップメディアのリクエストなど) が要求される場合、電子メールはスクリプト実行の終了時ではなく直ちに送信されることになります。

電子メール報告の改善 – 改善された電子メール報告により各バックアップに関する膨大な情報が伝えられます。オペレーションログが追加され各バックアップが漏れなく伝えられるようになりました。これらの詳細ログにより、どんなデバイスからもバックアップを監視でき、問題が起きれば直ちにエラーや警告に基づいて電子メールをフィルタリングして問題にフォーカスします。様々な電子メールクライアントを用いたフィルタリングを単純化するため、ログは添付ファイルとしてではなく電子メール本文の一部としてフォーマットの中に含まれます。ログのフォーマットとコンテンツは Retrospect ユーザーインターフェースに表示されるログと一致します。

Email summaries

ルール環境設定

[ルール]環境設定パネルでは、スクリプトに条件を適用するために使用するルールを作成および管理できます。詳細については、次の
ページの『ルールの使い方』セクションを参照してください。

ライセンス環境設定

[ライセンス]環境設定パネルには、購入したライセンス コードを入力できます。サーバ クライアント ライセンスやWindowsクライアント向けのオープン ファイル バックアップ アドオンなどのように、特定のライセンス コードによって、製品の特定の機能を解除できます。
ローカルまたはリモートのRetrospectエンジンに初めて接続すると、
[ライセンス]環境設定パネルが開き、そのエンジンのライセンス
コードを入力するよう要求されます。この情報を入力し、[追加]をクリックします。

07fig09.tiff

その他のライセンス コードを入力するには、ウィンドウ下部付近にあるプラス(+)ボタンをクリックします。購入したライセンス コードを入力して、[追加]ボタンをクリックします。新しいライセンス
コードがウィンドウに表示されます。

Retrospect製品をオンラインで登録するには、[登録]ボタンをクリックします。登録のためのWebページにアクセスします。

その他のRetrospectライセンス コードの購入方法に関する情報を取得するには、[購入]ボタンをクリックします。情報を記載したダイアログが表示されます。

ルールの使い方

ルールにより、任意の操作の対象にするファイルやフォルダの種類を指定できます。ルールを使用して、ファイル、フォルダごとに選択または無視するように設定できるため、操作に必要となる時間とメディアの量を制限できます。

ルールを使用すると、名前、データ、種類、サイズなど、あらゆる基準に基づいてファイルを選択できます。Retrospectには、いくつかのルールが組み込まれています。また、カスタム ルールを作成することもできます。たとえば、2009年8月25日以降に変更されたすべてのMicrosoft Word文書を選択するルールを作成できます。

ルールよって「マークされた」ファイル(ルールの基準を満たすファ
イルなど)は、必ずしもコピー先にコピーされるとは限りません。Retrospectはファイルの照合機能を備えているため、ルールを使用するコピー操作(バックアップなど)はすべて「無駄」が省かれます。各ルールには、ファイルを選択するものの、そのファイルがコ
ピー先にすでに存在する場合はコピーしないという暗黙の決まりがあります。

ルールの作成および変更は、[ルール]環境設定パネルで行います。[Retrospect]>[プリファレンス]を選択して、[ルール]タブをクリックします。

Retrospectでは、すでにいくつかのルールが設定されています。ルールは、各サーバに個別に関連づけられるため、Retrospectサーバが複数ある場合は、サーバごとに異なるルールのセットを作成できます。環境設定パネルのサイドバーでサーバをクリックすると、そのサーバの
ルールが表示されます。

ヒント: Retrospectの以前のバージョンでは、ルールはセレクタと呼ばれていましたが、作成の際に使用するインタフェースはかなり異
なっていました。

組み込みルールの使用

Retrospectには、ファイルを選択するための条件が定義されたいくつかのルールが組み込まれています。

一部のルールおよびルール条件の機能は、Mac OS、Windows、Linuxボリュームで異なっています。詳細についてはルールの詳細を確認してください。

Preferences rules.ja

Retrospectには次のルールが組み込まれています。

[すべてのファイル]は、オペレーティング システム ファイルを含む、ソース上のすべてのファイルをマークします。これはデフォルトのルールです。

キャッシュ以外の全ファイル]は、Webブラウザなどの特定のアプリケーションで使用されるキャッシュ ファイルを除く、ソース上のすべてのファイルをマークします。これらのキャッシュ ファイルは数が多く、サイズが大きく、通常、復元する実用性はありません。

Block Level Filter controls how a file is backed up, i.e. whether it is backed up in full or incrementally

[ファイルなし]は、バックアップのためのファイルをマークしません。ただしRetrospectでは、各ソースについて、ファイルおよびフォルダの完全なリスト、および関連付けられたメタデータが保存されます。テスト目的でファイルをコピーしたくない場合、またはWindowsクライアントのシステム状態のみをバックアップしたい場合には、
[ファイルなし]ルールを使用します。

[Retrospectファイルは、Retrospectバックアップ ファミリで使用される特定のファイル名およびファイル拡張子を持つファイルをマークします。

ドキュメントおよび設定は、ユーザーのデータや設定が保存されたMac OS X Users、Windows Documents and Settings(Windows XP、Server 2003)、Windows Users(Windows Vista、7、Server 2008)、
Linux /usr/ foldersにあるファイルとフォルダをマークします。

ルールの適用

ルールは、スクリプトの作成時に適用します。スクリプトの作成手順の1つに、[ルール]タブでの作業があります。サイドバーで[スクリプト]をクリックして、作業するスクリプトをリストから選択し、下の[ルール]タブをクリックします。スクリプトに適用するルールのラジオ ボタンを選択します。

07fig11.tiff

ルールの追加または編集

[ルール]環境設定パネルでは、ルールを追加、表示、または変更できます。ルールを追加するには、ルールのリストの下にあるプラス(+)記号の形をした[ルールの追加]ボタンをクリックします。
ルールを表示または編集するには、リストでルールを選択して、鉛筆の形をした[ルールの編集]ボタンをクリックします。3つの部分で構成される[ルール]ダイアログが表示されます。

ルール名]には、任意の名前を指定できます。ルール名は、[プリファレンス]および[スクリプト]の[ルール]タブ、ならびにRetrospect内のその他の場所で表示されます。

含める条件セクションでは、作業の際にルールを適用するファイルやフォルダを指定します。

除外する条件セクションでは、実行中にスキップするファイルとフォルダを指定します。

各ルールにはルール名を付ける必要があります。必要に応じて、含める基準または除外する基準を追加します。デフォルトのルールである[すべてのファイル]には、特定の含める基準または除外する基準はありません。つまり、除外されるファイルはなく、すべてのファイルが対象になります。

スコープ メニューを使用すると、含める条件のセクションまたは除外する条件のセクションのいずれかで、条件の範囲を定義できます。スコープ メニューでは、[すべて]、[なし]、または[いずれか]を選択できます。上のスクリーンショットの例では、含める条件のス
コープ メニューで[いずれか]が選択されているため、リストされた条件のいずれかを満たす場合にルールが適用されます。このルールの対象になるものは、Mac、Windows、Linuxクライアントのユーザー
ファイルと設定です。このように、[いずれか]は論理式のor条件として機能します。

07fig12callout.ai

[すべて]は論理式のand条件として機能します。たとえば、クライアントWidgetcoの特定のプロジェクトの一部であるQuickTime動画ファイルをすべてバックアップするとします。それまですべての動画ファイルを1つのフォルダに保存したとします。[すべて]条件を追加するには、キーボードのOptionキーを押し続けます。[以下の条件のいずれかを満たす]スコープ バーにある[条件の追加]のプラス記号
(+)が省略記号(...)に変わります。このボタンをクリックすると、[すべて]条件を追加できます ([なし]条件も同じようにして作成します。ただし、[なし]条件に変更できるのは[すべて]条件だけです)。次の2つの条件を作成します。

  • Widgetcoという語を含むフォルダ名
  • .movで終わるファイル名

含める条件のセクションおよび除外する条件のセクションでは、ルールに1つまたは複数の条件を追加できます。条件を追加するには、[条件の追加]ボタンをクリックします。同様に、条件を削除するには、既存の条件の横にある[条件の削除]ボタンをクリックします。また、条件を画面上でドラッグすることで並べ替えることもできます
(ただし、含める選択条件のセクションと除外する選択条件のセク
ション間で条件をドラッグすることはできません)。ルールには、任意の数の条件を含めることができます。

条件を追加したら、 ポップアップ メニューおよび条件の入力フィールド(任意指定)を使用して条件を構築する必要があります。

07fig13.tiffポップアップ メニューと入力フィールドは、状況に応じて変わる項目です。つまり、メニューやフィールドが表示されるかどうか、およびその内容は、条件内のその他の要素の値によって決まります。たとえば、1つ目と2つ目のポップアップ メニューは、次のページで示す方法で互いに影響し合います。

3つ目のポップアップ メニューは、最初の2つのメニューでの選択に
よって変わります。 入力フィールドへの入力にも必要となる条件があり、3つ目のメニューでの選択により、入力の範囲が絞り込まれます。たとえば、最初のメニューで[ファイル]を選択し、2つ目のメニューで[名]を選択した場合は、3つ目のメニューの選択肢は、に次のものを含む]、[は次のもので開始します]、[は次のもので終了します]、[である]、[でない]、および[と似ている]になります。この例では、入力フィールドも表示されます。

別の例として、最初のメニューで[ファイル]を選択して、2つ目のメニューで[日付]条件の1つを選択すると、行が変更され、日付関連のメニューが2つ表示されます。1つ目のメニューには、[は次以前]、[は次以後]、[厳密に]、[ない]、[は当日またはそれ以前]、は当日またはそれ以降]、および[は次の範囲内]の選択肢が表示されます。2つ目の日付関連のメニューには、今日]、[のバック
アップの日付]、および[の特定の日付](これを選択すると、入力フィールドが表示され、日付を入力できます)の選択肢が表示され
ます。

ご覧のとおり、各条件には数多くの組み合わせがあります。メニューのさまざまな選択肢を試し、ルールに含める項目を選択してください。

1つ目のポップアップ メニューの
選択肢

2つ目のポップアップ メニューの
選択肢

ファイル

フォルダ

Macパス

Windowsのパス

UNIXのパス

属性

Kin

アクセス日

作成 日

変更日

バックアップの日付

使用サイズ

ディスク上のサイズ

ラベル

権限

ボリューム

ドライブ名

接続タイプ

ファイル システム

ソース ホスト

ログイン名

保存されたルール

構成要素

次を除外

[保存されたルール]条件を使用すると、ルール内にルールを含めることができます。たとえば、カスタム ルールの基礎条件として
[キャッシュ以外の全ファイル] を含めるには、[以下の条件のいずれかを満たす]条件の下にある、含める選択条件のセクションで、
[保存されたルール]の中に[キャッシュ ファイルを除いたすべてのファイルを含める]条件を追加します。

ルールの編集が終了したら、[保存]ボタンをクリックします。

Retrospectがルールを適用する際は、必ず含める条件よりも除外する条件が優先されます。たとえば、ルールの中に、ユーザーのドキュメント フォルダを対象に含めるステートメントと、そのフォルダの上にあるユーザー フォルダを対象から外すステートメントがある場合には、ドキュメント フォルダ内のファイルは選択されません。

既存ルールの複製

ルールを新しく作成するよりも、既存のルールを変更したほうが簡単な場合もあります。既存のルールを複製するには、リストでルールを選択して、リストの下にある[ルールの複製]ボタンをクリックします。[古いルール名のコピー]という名前の新しいルールが作成されます。複製されたルールを変更するには、[ルールの編集]ボタンをクリックします。ルール名を変更してから、ルールの条件を変更します。変更が終了したら、[保存]をクリックします。

ルールの削除

ルールを削除するには、[環境設定]のリストでルールを選択して、リストの下にあるマイナス記号(-)の形をした[デリート ルール]ボタンをクリックします。削除するかどうかを確認するメッセージが表示されます。[削除]ボタンをクリックして、ルールを削除します。

バックアップ戦略

このセクションでは、コンピュータまたはネットワーク全体をバックアップするためのいくつかの戦略を紹介します。各戦略を検討して、それぞれの状況に最適なものを選択してください。ユーザーの状況はそれぞれ異なるため、ニーズに応じて戦略を修正することもあるかもしれません。または、ここで紹介するものとはまったく異なる独自の戦略を考案することもあるかもしれません。ここで紹介する戦略は例に過ぎません。Retrospectでは数多くの戦略を採用できます。独自の
バックアップ戦略を考案する際には、基本的なバックアップ規則だけは念頭に置くようにしてください。

基本的なバックアップ規則

Retrospectはデータを保護するための強力なツールです。次の基本的なバックアップ規則に従うことにより最大の効果が得られます。

頻繁にバックアップする。バックアップされていないものは復元できません。たとえば、今日ハード ディスクが故障したとします。最後にバックアップしたのが1週間前だと、この1週間の間に蓄積されたデータは失われてしまいます。Retrospectが最大限の効果を発揮するためには、すべてを頻繁にバックアップする必要があります。スクリプトやスケジュールを設定することにより、バックアップを自動化でき
ます。

データのバックアップを複数保存します。メディア セットを定期的に交換しながら使用します。複数のメディア セットを使用することにより、(特にテープなどのリムーバブル メディアを使用している場合に)メディアがなくなったり故障したりしたときにデータを失う危険性を軽減できます。Retrospectでは、高機能な増分バックアップにより、自動的に各メディア セットが完全かつ独立して保存されるため、フル バックアップ、増分バックアップ、差分バックアップなどの従来のバックアップ手法のことを考える必要がありません。

[詳細な検証]オプションあるいは[メディアの検証]オプションを使用したバックアップ中に、または検証スクリプトあるいはメディア セットの下にある[検証]ボタンを使用してバックアップを完了した後に、バックアップを検証する必要があります

古いメディアは定期的なスケジュールで交換します。すべてのバックアップを1つのメディア セットで実行すると非常に脆弱になるため、新しいメディア セットのバックアップを使用して新しいメディアを定期的に導入します“xe media rotation;rotating media” (セット内のテープが損傷しただけでも、完全なバックアップを実行することはできなくなります)。新しいメディアを導入するバックアップ戦略の利点としては、メンバーやバックアップ セッションの多いセットから復元するよりも、少ないメディア メンバーから復元するほうが早いことが挙げられます。

内容やローテーション頻度に基づいて、メディア セットに意味のある名前を付け、メディアに適切なラベルを付けます

必ず最低でも1つのメディア セットをオフサイトで保管するようにして、火災、盗難、天災などから保護します。このメディア セットは定期的に更新するようにします。

バックアップ メディアは慎重に扱ってください。環境によって損傷を受けやすいためです。テープ メディアも、数百回使用しただけで磨耗する場合があります。

バックアップ コンピュータをバックアップします。Retrospectの構成に、考えていたよりも多くの時間と労力を要したことでしょう。

カタログ ファイルをバックアップまたはコピーします。コピー先は、同じメディア セットまたはネットワーク上の別の場所です。この章の後半の『カタログおよび構成のバックアップ』を参照してください。

スクリプトによるバックアップとプロアクティブ バックアップの比較

クライアント コンピュータのネットワークをバックアップする際には、使用するバックアップ スクリプトの種類を決定する必要があります。下の表は、プロアクティブ バックアップ スクリプトと通常のバックアップ スクリプトに適した状況を示したものです。

プロアクティブ バックアップが最適となる場合

バックアップ スクリプトが最適となる場合

バックアップの目的に特化した
バックアップ専用のコンピュータがある。

バックアップ コンピュータが、バックアップ時以外は他の処理を実行している。

多くのクライアントが多くのデータを格納しているため、一晩ですべてをバックアップすることができない。

朝になってクライアント コン
ピュータが使用される前に、スケジュールされたバックアップが完了する。

通常のバックアップ スクリプトでは完全にバックアップされない特定のクライアントのために、
バックアップ作業を何とかこなし、特別なスクリプトの作成、手動バックアップを行っている。

朝になってクライアント コン
ピュータが使用される前に、スケジュールされたバックアップが完了し、バックアップが正常に完了しないことは稀である。

モバイル クライアントやポータブル ドライブがネットワーク上に不定期に加わる。

ネットワークにはデスクトップ コンピュータしかなく、ノートパソコンやリムーバブル ディスクは
ない。

Retrospectにより、バックアップ デバイスにある任意のメディアにバックアップしたい。

自動バックアップの際に常に適切なメディアが存在している。

多くの場合、通常のバックアップ スクリプトとプロアクティブ バックアップ スクリプトの両方を組み合わせたバックアップ戦略を採用します。たとえば、ノートパソコン用にはプロアクティブ バックアップ スクリプトを作成し、ネットワーク上のサーバやデスクトップ コン
ピュータ用には通常のバックアップ スクリプトを使用するという方法があります。

推奨するバックアップ戦略

バックアップ戦略には、想像力とハードウェアが許す限り、さまざまなものがあります。ここでは、いくつかの戦略を例として紹介します。

定期的にリサイクルを実行する通常のバックアップ

2つのローテーション メディア セットにバックアップするバックアップ スクリプトを作成します。スクリプトの[スケジュール]タブに、隔週の同じ時刻に繰り返されるスケジュールを追加し、月曜日~木曜日を選択します。このスケジュールでは、最初のメディア セットのメディア アクションとして[メディア アクションなし]を設定し、通常のバックアップを実行します。隔週(金曜日など)または月単位(各月の1日など)で繰り返される2つ目のスケジュールを追加し、最初のメディア セットのメディア アクションとして[メディア アクションのリサイクル]を設定します。2つ目のスケジュールにより、メディア セットはリセットされ、実行時に新しいバックアップが開始されるため、メディア セットの全体的なサイズが抑えられます。次に、上述のものと同じスケジュールをさらに2つ作成し、それを2つ目のメディア セットに対して隔週で実行するようスケジュールします。この戦略により、1つのメディア セットには過去のデータの一部(少なくとも1週間分のデータ)がバックアップされ、もう1つのメディア セットはリサイクルおよび上書きされるようになります。

5日ごとのバックアップ ローテーション

この戦略では、複数のメディア セット(平日あたり1つのコピー先)を使用します。5日間分のソースが常に定期的かつ個別にバックアップされます。バックアップは、1週間のうち5日間実行されます。次の手順を実行します。

  1. コンソールの[メディア セット]カテゴリーで、コピー先のメディア セットを5つ作成し、それぞれ月曜日、火曜日、水曜日、木曜日、金曜日と名前を付けます。メディア セットの種類は問いませんが、ディスクが最も便利です。
  2. [スクリプト]カテゴリーで、新しいバックアップ スクリプトを作成します。
  3. 新しいスクリプトの[ソース]タブで、バックアップするソースを選択します。Retrospectのソースの種類として、 ローカル ボリューム、Retrospectクライアント、ネットワーク ボリューム、タグ、スマート タグのいずれかを選択できます。
  4. スクリプトの[メディア セット]タブで、作成した5つのメ
    ディア セットの横にあるチェックボックスをすべてオンにし
    ます。
  5. スクリプトの[ルール]タブで、バックアップに適用するルールを選択します。
  6. スクリプトの[スケジュール]タブで、スケジュールを作成します。「月曜日」メディア セットをコピー先として選択し、
    [メディア アクションなし]を選択します。これで、このメ
    ディア セットにバックアップされていないファイルおよびフォルダがすべてバックアップされます。開始日時を選択し、[月曜日]ボタンのみを選択することで、スクリプトが毎週1回繰り返されます。これにより、毎週月曜日になるとRetrospectは「月曜日」メディア セットにバックアップを実行します。
  7. 各曜日のメディア セットをコピー先として選択して、[スケ
    ジュール]タブで該当する曜日を選択し、残りの曜日についても前述の手順を4回繰り返します。完了すると、スクリプトで5つのスケジュールができ、それぞれが週に1回ずつ実行されます。
  8. 07fig14.tiff

    ヒント: 5つのバックアップを実行するだけでなく、それらのバックアップを異なるディスクに実行するとさらに良いでしょう。各メディア セットのメンバーを複数のディスクに保存することを検討してください。

基本的なプロアクティブ バックアップ

すべてのクライアントのソースをバックアップするプロアクティブ
バックアップ スクリプトを作成します。平日の午後7時から午前7時
(ユーザーの仕事の妨げとならないよう)および週末のすべての時間で実行するようスケジュールします。Retrospectが1日1回バックアップを実行するよう、バックアップ間隔を設定します。

モバイル コンピュータ用のプロアクティブ バックアップ

ソースの[タグ]タブで、「モバイル コンピュータ」という名前のタグを追加します。[ソース]リストで、モバイル デバイスの各ソースを選択して、「モバイル コンピュータ」タグを適用します。タグを
ハード ディスク全体またはお気に入りフォルダに適用することで、
バックアップするデータ量を制御できます。

次に、プロアクティブ バックアップ スクリプトを作成します。スクリプトの[ソース]タブで、「モバイル コンピュータ」タグを選択します。スクリプトが実行されると、Retrospectにより、タグの付いた
ソースがすべてバックアップされます。各モバイル デバイスを個別に選択する必要がないため、設定に要する時間を大幅に削減できます。新しいスクリプトが1日24時間実行されるようスケジュールし、バックアップ間隔を18時間に設定します (次にいつラップトップがネット
ワークに加わるかが不明で、ラップトップは故障や盗難の危険性もあるため、頻繁にバックアップすることを推奨します)。出張に出る
ユーザーが初期バックアップを要求できるよう、[初期バックアップの許可]オプションをオンにします。

段階的バックアップ戦略

段階的バックアップとは、1種類のメディア セットに対して1つまたは複数のバックアップを実行して、そのバックアップを(通常はアーカイブ目的で)他のメディア セットにコピーするバックアップのことです。コピー先のメディア セットの種類は同一でも異なっていてもかまいません。たとえば、一連の通常バックアップをディスク メディア
セットに対して実行し、週に1回(または月に1回など任意の間隔で)ディスク メディア セットの内容をテープ メディア セットにコピーします。その後に、そのテープを保管庫などのオフサイト施設で保管できます。

ディスクは、ネットワーク コンピュータからの高速なデータ転送にも対応できるため、直接テープにバックアップするよりも高速にバックアップできます。ディスクにバックアップされたデータは、簡単に
テープに転送することができます。ディスクからテープへのデータ転送は、速度が一貫しているため(ネットワークのボトルネックなし)、テープ ドライブは最大速度でストリームします。データをテープに転送したら、テープをオフサイトに安全に保管し、オンサイトに保管されたディスク バックアップを使用して迅速に復元を実行できます。

このようなシナリオの段階的バックアップを構築するには、次の2つのスクリプトを作成する必要があります。ディスク メディア セットへの通常のバックアップ スクリプトおよびテープ メディア セットへのコピー バックアップ スクリプト。

まず、2つのメディア セットを準備します。グルーミングを有効にしたディスク メディア セットをバックアップ スクリプトのコピー先として使用します。各ソースにつき、最低でも直近の10個のバックアップがRetrospectで保存されるように、グルーミング オプションを設定します。これにより、迅速な復元を実行する対象が、一定の世代を
持ったクライアント データになります。

バックアップ スクリプトを作成します。ここで、既存のスクリプトを使用することもできます。バックアップの日単位のスケジュールを設定します。

ディスク メディア セットのデータをテープ メディア セットに1週間に1回転送するためのコピー バックアップ スクリプトを作成します。コピー バックアップ スクリプトの[ソース]タブで、 [各ソースの直近のバックアップをコピー]を選択します。[デスティネーション]タブでテープ メディア セットを選択します。スクリプトに適用する
ルールを設定します。たとえば、オフサイトのアーカイブ セットにオペレーティング システムやアプリケーションのバックアップが収録されているかどうか注意する必要がない場合は、「ユーザー ファイルと設定」というルールを選択します。次に週単位のスケジュールを追加します。コピー バックアップ スクリプトが実行されると、ディスク メディア セットに収録されている直近のバックアップから、新しい
ファイルと変更されたファイルのみがテープ メディア セットにコピーされます。ディスク メディア セット内のデータをテープ メディア
セットにコピーしたら、テープをオフサイトで安全に保管できます。ただし、定期的にオンサイトに戻して更新することを忘れないでください。

カタログおよび構成のバックアップ

カタログ ファイルはメディア セットのインデックスであり、メディア セットに関連するすべての操作で必要となります。カタログ ファイルはデフォルトでは、Retrospectバックアップ サーバのハード ディスクに保存されています。ハード ディスクに保存されているため、他の
ファイルと同様のリスクに直面します。Retrospectサーバのハード
ディスクが故障してカタログ ファイルが失われると、カタログを再作成するまでRetrospectではいかなるファイルも復元できません。カタログの再作成には長時間かかる場合があります。カタログ ファイルの古いバージョンを復元してから、メディア セットに基づいて更新したほうが短時間で済みます。つまり、メディアに基づいてカタログを完全に再作成するということになります。そのため、通常のファイルだけでなく、カタログ ファイルもバックアップするようにしてください。

カタログ ファイルはデフォルトでは、Retrospectサーバの/Library/Application Support/Retrospect/Catalogs/に保存されています。

同様に、Retrospectの構成ファイルには、クライアント データベース、スクリプト、スケジュール、環境設定、カスタム ルールなどの重要情報が含まれています。Retrospectでは、Config80.datという名前の構成
ファイルが使用されます。この構成ファイルは次の場所に保存されています。/Library/Application Support/Retrospect/

Retrospectは定期的に、Config80.datのバックアップ コピーをConfig80.bakという名前のファイルに自動的に保存します。これら2つのファイルを定期的にバックアップする必要があります。アクティブな構成ファイル(Config80.dat)が紛失または破損した場合は、ファイルを削除してからRetrospectを開くと、Config80.bakから新しいConfig80.datが作成されます。

07fig15.tiff

カタログ ファイルと構成ファイルを定期的にバックアップすることが重要です。次の手順を実行します。

  1. サイドバーで、[ソース]をクリックします。
  2. [ソース]リストで、Retrospectバックアップ サーバのハード ディスクをクリックして選択します。
  3. [参照]ボタンをクリックします。Retrospectバックアップ
    サーバのハード ディスクの内容を示す[参照]ダイアログが表示されます。
  4. /Library/Application Support/Retrospect/に移動し、クリックして選択します。
  5. [参照]ダイアログの下部で[お気に入りフォルダに追加]をクリックして、[完了]をクリックします。
  6. サイドバーで[メディア セット]をクリックして、メディア
    セット リストの上にある[追加]ボタンをクリックします。
    [メディア セット]ダイアログが表示されます。
  7. メディア セットのタイプを選択し、メディア セットの名前を追加し、任意のセキュリティを設定し、[追加]ボタンをクリックします。
  8. サイドバーで[スクリプト]をクリックして、スクリプト リストの上にある[追加]ボタンをクリックします。[スクリプト]ダイアログが表示されます。
  9. スクリプト名(「カタログ バックアップ」など)を入力して、カテゴリー リストで[すべて]を選択し、スクリプト タイプのリストで[バックアップ]をクリックします。[追加]ボタンをクリックします。スクリプト リストに戻ります。
  10. 詳細エリアで[ソース]タブをクリックして、作成したRetrospectお気に入りフォルダの横にあるチェックボックスをオンにします。
  11. [メディア セット]タブをクリックして、作成したメディア
    セットの名前の横にあるチェックボックスをオンにします。
  12. ほとんどの場合、すべてのファイルのルールはデフォルトの状態でユーザーの希望するものとなっています。そのため、
    [ルール]タブはクリックせずに[スケジュール]タブをク
    リックします。カタログ ファイルと構成ファイルをバックアップするための1つまたは複数のスケジュールを追加します。たとえば、毎日特定の時間に実行されるメディア アクションのないスケジュール(通常のバックアップ)を1つ作成し、月に1回実行される[メディア アクションのリサイクル]を設定した2つ目のスケジュール(以前のバックアップを消去して、新しい
    バックアップを作成)を追加できます。

レポートと操作ログの使い方

Retrospectはレポート機能を備えているため、ログやレポートを確認することで、バックアップの実行履歴やエラー メッセージを監視できます。操作が正常に完了しなかった場合は、レポートや操作ログを調べて問題を診断する必要がある場合もあります。

Retrospectにはいくつかのレポートが組み込まれています。また、レ
ポートを独自に作成することもできます。レポートを表示するには、サイドバーで、[レポート]の横の三角ボタンをクリックします。

07fig16.tiff

各レポートの内容を表示するには、サイドバーで各レポート名をク
リックします。Retrospectウィンドウのメインの部分にレポートが表示されます。

07fig17.tiff

レポート ビューのカスタマイズ

レポート ビューをカスタマイズすることができます。ほとんどの列は、列見出しをクリックすることで、昇順または降順にソートできます。選択した列がハイライト表示され、列見出しに上または下向きのソート失印が表示されます。列の順番は、列見出しをドラッグすることで変更できます。2つの列見出し間の線をクリックしてドラッグすることで、列の幅を変更できます。

列のデフォルトの状態は、レポートのタイプによって異なります。列の見出し内を右クリックすると、コンテキスト メニューが表示されます。このメニューを使用して、デフォルトの列だけでなく、他の列をリストに追加したり、既存の列を削除したりできます。

07fig18.tiff

ダッシュボードの使用

Retrospectコンソールを起動すると、ダッシュボードが表示されます。ダッシュボードには、プログラムに組み込まれたいくつかのレポート、および独自に作成してダッシュボードに表示するように選択したレポートの概要が表示されます。

07fig19.tiff

サイドバーでバックアップ サーバ名をクリックすることで、いつでもダッシュボードを表示できます。デフォルトでダッシュボードに表示されるレポートは、[最近のアクティビティ]、[24時間スケジュール]、[7日間バックアップなし]です。ダッシュボードにその他のレポートを追加するには、サイドバーでレポート名を選択して右クリックし、表示されるコンテキスト メニューで[ダッシュボードで表示]を選択します。

注: サイドバーで[レポート]カテゴリーをクリックすると、ダッ
シュボードと同じようなビューが表示されますが、そこにはすべてのレポートが含まれます。

レポートの作成と保存

Retrospectのサイドバーの[操作]、[過去のバックアップ]、[スクリプト]、[ソース]、および[メディア セット]の各カテゴリーで、カスタム レポートを作成できます。まず、カテゴリーの1つをクリックして選択します。ここでは例として、操作に10を超えるエラーが発生した際に警告するレポートを新しく作成します。

[操作]カテゴリーをクリックし、スコープ バーにあるプラス(+)ボタンをクリックして、レポートを追加し、レポート基準バーを表示します。各カテゴリーには適切なレポート基準があります。

レポート基準バーで、希望する基準を選択し、必要に応じて、テキストや数字を入力して基準の範囲を絞り込みます。最下部の基準にあるプラス(+)ボタンをクリックすることで、その他の基準を追加できます。Optionキーを押し続けるとプラス(+)ボタンが省略記号(...)に変わります。Optionキーを押したまま省略記号(...)をクリックすると、レポート基準に[いずれか]、[すべて]、[なし]条件を追加できます。

07fig20callout.ai

レポート基準の設定が完了したら、[レポートの保存]をクリックします。表示されるダイアログにレポート名を入力して、[OK]をク
リックします。サイドバーの[レポート]カテゴリーに新しいレポートが表示されます。

レポートの編集

レポートを編集するには、サイドバーでレポート名をクリックして、レポート上部にある[レポートの編集]ボタンをクリックします。既存の基準を表示したレポート基準バーが表示されます。必要に応じて基準を変更して、[レポートの保存]をクリックします。サイドバーでレポート名を右クリックして、表示されるコンテキスト メニューで[レポートの編集]を選択することでレポートを編集することもできます。このコンテキスト メニューと同じものが、歯車のアイコンを含んだツール メニューとして、サイドバーの下部にも表示されます。

新しいレポートのベースとして使用するためにレポートを複製するには、サイドバーでレポート名を右クリックして、表示されるコンテキスト メニューで[レポートの複製]を選択します。新しいレポートの名前を入力するように要求するダイアログが表示されます。レポート名を入力し、[OK]をクリックします。必要に応じて、複製したレ
ポートを編集します。

レポートを削除するには、サイドバーでレポートを選択し、右クリックして、コンテキスト メニューで[削除]を選択するか、Retrospect
ウィンドウ下部のツール メニューで[削除]を選択します。

ログの表示

操作ログには、Retrospectの各操作、トランザクション、および発生したエラーなどを含むイベントの記録が表示されます。ログには、操作中に生成されたメッセージが保存されます。操作が正常に完了しな
かった場合は、ログを調べて問題を診断する必要がある場合もあり
ます。

ログを表示するには、[表示]>[ログ]を選択するか、Cmd-Lを押します。

07fig21.tif

ログには、正常に完了した操作に関する次の情報が表示されます。

[完了]には、コピーされたファイルの数とサイズが示されます。Retrospectのデータ圧縮機能を使用した場合は、セッションでの圧縮率もログに表示されます。

[パフォーマンス]には、1分あたりにコピーされる情報量がメガバイトで示されます。[確認]オプションがオンになっている場合は、比較目的のために他のパフォーマンス数値も表示されます。

[期間]には、操作を完了するために必要となる合計時間が示されます。操作中に[一時停止]をクリックした場合、またはメディアの挿入中に遅延が発生した場合は、待機時間が個別に表示されます。待機時間には、テープ ドライブの場所を特定するためなどに要した時間も含まれます。

ログ内で項目を見つけるには、ログ ウィンドウが開いている状態で
[編集]>[検索]を選択するか、Cmd-Fを押します。ログ ウィンドウ上部に検索フィールドが表示されます。検索フィールドの横には進むボタンと戻るボタンもあります。検索するテキストを検索フィールドに入力します。入力すると、検索した語句のログ内での一致件数が表示されます。

注: 操作ログで表示する行数は、Retrospectの[プリファレンス]の
[コンソール]タブで選択できます。

ログを印刷するには、ログを表示して、[ファイル]メニューで[印刷]を選択します。

メディア セットの管理

Retrospectには、メディア セットを効果的に管理するためのツールがいくつかあります。サイドバーで[メディア セット]を選択してメディア セットのリストを表示し、[メディア セット]ツールバーを表示します。

07fig22.tif

新しいメディア セットの作成

新しいメディア セットを作成するには、[新規作成]をクリックし
ます。メディア セットの新規作成プロセスについては、第5章の
『メディア セットを追加する』で説明しています。

メディア セットの削除

メディア セットのリストからメディア セットを削除するには、メディア セットを選択して、[削除]ボタンをクリックします。メディア
セットの削除を確認するメッセージが表示されたら、[OK]をクリックします。メディア セットを削除してもメディア セットの内容には影響ありません。また、メディア セット内のカタログ ファイルも削除されません。ただし、メディア セットを使用するスクリプトからは削除されます。

カタログ ファイルを削除して、メディア セットが保存されたメディアを消去しない限り、いつでもメディア セットをリストに戻すことができます。このプロセスについては、この章の後半の『メディア セットの再構築』で説明しています。

メディア セットのカタログの追加

すべてのメディア セットにはカタログ ファイルがあります。カタログ ファイルは、メディア セットのインデックスとして機能します。これによりRetrospectでは、メディア セット全体を検索することなくデータを検索および復元できます。カタログ ファイルは、Retrospectサーバ マシンの/Library/Application Support/Retrospect/Catalogs/に保存されます。

メディア セットをRetrospectサーバ間で移動する場合は、メディア
セットのカタログ ファイルも追加する必要があります。そうすれば、メディア セットを処理できるようになります。そのためには、カタログ ファイルをRetrospectサーバにコピーします。できるだけ、デフォルトの場所(管理者レベルの認証が必要)にコピーするようにしてください。これで、すべてのカタログ ファイルが同じ場所に保存されます。次に、Retrospectコンソールの[メディア セット]ツールバーで
[検出]ボタンをクリックします。表示されるダイアログで、追加するカタログの場所に移動し、[OK]をクリックします。メディア
セットにパスワードが設定されている場合は、パスワードの入力を要求されます。パスワードを入力し、[OK]をクリックして、パスワードの入力画面と移動用のダイアログを終了します。カタログ ファイルの場所が読み込まれ、保存されます。

注: Retrospectサーバを新しいマシンに移動する場合は、他にもいくつかのことを実行する必要があります。この章の後半の『Retrospectの移動』を参照してください。

オプションとして、メディア セットの検証操作を実行して、メディア セット内の実際のメディアへのアクセス方法を確認できます。この章の後半の『メディア セットの検証』を参照してください。

コピー メディア セット スクリプトの作成

コピー メディア セット スクリプトにより、メディア セット全体を別のメディアにコピーできます。[メディア セット]ツールバーを使用して、簡単にコピー メディア セット スクリプトを開始できます。リストでメディア セットを選択し、[メディア セット]ツールバーの
[コピー]ボタンをクリックします。新しいコピー メディア セット スクリプトの名前の入力を要求するダイアログが表示されます。
フィールドには、「コピー メディア セット -- メディア セット名」というデフォルトの名前が入力されています。デフォルトの名前をそのまま使用するか、希望するスクリプト名を入力して、[作成]をク
リックします。

サイドバーで[スクリプト]をクリックすると、スクリプト リストに新しいコピー メディア セット スクリプトが表示されます。スクリプトのソースはすでに選択されています。スクリプトのデスティネー
ション、ルール、スケジュール、オプションを追加して、スクリプトの設定を完了します。詳細については、第5章の『Creating a Copy Media Set Script(コピー メディア セット スクリプトの作成)』を参照してください。

メディア セットの検証

メディア セットを手動で検証する場合は、リストでメディア セットを選択して、[メディア セット]ツールバーの[検証]ボタンをク
リックします。検証アクティビティが開始されます。サイドバーで
[操作]カテゴリーをクリックすることにより、検証アクティビティを監視できます。このアクティビティの実行中、Retrospectはメディア
セットが読み取り可能であることを検証し、カタログ ファイルの照合を行います。検証機能は、検証なしでバックアップまたはアーカイブを行った後に、メディア セットのメディアのオフライン検証を実行する場合に便利です。

ヒント: スクリプトによる検証なしのバックアップ(またはアーカイブ)を実行することで、バックアップ ウィンドウを最大化したい場合は、オフライン検証をスケジュールする検証スクリプトを使用する必要があります。

検証アクティビティは、可能な限り、選択されたメディア セット内のファイルとバックアップ中に生成されたMD5ダイジェストを比較することにより、メディア セットのメディアのデータを検証します。このため、バックアップされたソース ボリュームにRetrospectがアクセスする必要がなくなり、ボリュームでの速度低下が発生せず、操作全体の速度が向上します。

特定の状況では、バックアップ中に生成された MD5 ダイジェストにアクセスできない場合があります。Retrospectの[バックアップ操作中にMD5ダイジェストを生成]環境設定を無効にした状態でバックアップを作成した場合はアクセスできなくなります。この場合、メディア セットのメディアにあるすべてのファイルが読み込み可能であることは確認されますが、ファイルの完全性は保証されません。

注: 検証アクティビティを実行する際、複数のメディアにまたがるバックアップを検証する場合は、メディアを再挿入する必要があります。

メディアの完全性を検証するには、次の手順に従います。

  1. 検証するメディア セットを選択して、[メディア セット]ツールバーで[検証]ボタンをクリックします。
  2. メディア セットのメディアが検証され、進行状況がアクティビティ リストに表示されます。

    メディア セットがテープ、光ディスク、またはリムーバブル
    ディスクが使用している場合は、サイドバーの[操作]カテゴリーの横にある[メディアが必要]アイコンが点滅し、必要となる各メディア セット メンバーを挿入するよう要求されます。ディスク メディア セットを検証する際に、メディア セットのメンバーが見つからない場合は、メディアの場所を選択するよう要求されます。

    07fig23callout.ai

    アクティビティ リストの[詳細]セクションのメディアが要求されます。[メディアを選択]ボタンをクリックすると、ダイアログが表示されます。このダイアログで目的のメディアまで移動できます。

    07fig24.tiff

    表示されるダイアログは、検証するメディア セットのタイプによって異なります。

    07fig25.tiff

    テープなどのリムーバブル メディアの場合、要求されたメディア セット メンバーがなく、メディア セットの他のメンバーを検証する場合は、[マークが失われました]をクリックして、次に要求されるメディアを挿入します。メディアを紛失していなくても、すぐには利用できない場合は、[スキップ]をク
    リックします。

    注: メディア セットのメンバーが紛失としてマークされると、その後のバックアップ中に、そのメンバーに保存されたすべてのファイルの再取得が自動的に試みられます。

  3. 検証が完了したら、アクティビティ リストのスコープ バーで
    [過去]ボタンをクリックすると、検証が正常に完了したかどうかについての詳細が表示されます。操作が正常に完了しな
    かった場合、またはエラーが報告された場合は、[ログ]タブをクリックして詳細情報を表示してください。

メディア セットの修復

バックアップ操作中に停電が発生した場合など、カタログ ファイルがメディア セットの内容と同期できない場合が時折あります。この場合、「カタログの非同期」エラーが報告されます。これは、ディスク障害によりカタログを失ったものの、カタログ ファイルの1日前のコピーが他のディスクに保存されている状態と同じです。この場合は、バックアップ カタログをRetrospectサーバにコピーし、[修復]機能を実行し、バックアップ カタログをメディアと同期します。カタログを修復すると、メディア セットがスキャンされ、メディアと一致するようにカタログ ファイルが更新されます。

カタログを更新してメディアと同期しない限り、メディア セットは使用できません。「カタログの非同期」エラーは、最後にデータをメ
ディア セットにコピーした際に、(クラッシュや電源障害などにより)カタログを更新できなかったことを示しています。このエラーは、ディスクに空き容量がない場合やメモリが不足している場合にも発生することがあります。

メディア セットを修復するには、次の手順に従います。

  1. 修復するメディア セットをメディア セット リストで選択し
    ます。
  2. [メディア セット]ツールバーの[修復]ボタンをクリックします。[修復]ダイアログが表示され、メディア セットの最初のメンバーを選択するよう要求されます。
  3. 07fig26.tiff

  4. [メンバーの追加]ボタンをクリックします。ダイアログが表示され、メディア セットの最初のメンバーに移動できます。この例では、ディスク メディア セットを使用して、バックアップ ディスク上のRetrospectフォルダに移動し、修復するメディア
    セットを含むフォルダに移動し、メディア セットの最初のメンバーを選択しています。名前は必ず「1-メディア セット名」となります。
  5. 07fig27.tiff

  6. [次へ]をクリックします。選択したメディア セット メンバーがRetrospectで認識され、メディア セット メンバーの日付、名前、ステータス(暗号化されているかどうか)を示すダイアログが表示されます。
  7. 07fig28.tiff

  8. ダイアログ内でメディア セット メンバーをクリックして選択し、[次へ]をクリックします。メディア セット メンバーが
    [修復]ダイアログに表示されます。
  9. 追加するメディア セットのメンバーが他にもある場合は、手順3~5を、すべてのメンバーが追加されるまで繰り返します。
  10. [修復]をクリックします。再カタログ化操作が開始されます。アクティビティ リストで進行状況を監視できます。操作が完了したら、アクティビティ リストのスコープ バーで[過去]ボタンをクリックすると、再カタログが正常に完了したかどうかについての詳細が表示されます。操作が正常に完了しなかった場合は、[ログ]タブをクリックして詳細情報を表示してください。

メディア セットの再構築

カタログを再構築すると、カタログの新しいコピーが再作成されます。ディスク障害によりオリジナルが失われた場合などに再構築を実行します。再構築を実行すると、バックアップ メディアがスキャンされ、カタログ全体が再作成されます。

注: Retrospectには「カタログの高速再構築」という機能がメディア セットの[オプション]タブにあります。メディア セット内の2回目以降のテープを書き込む際に、毎回、現在のカタログがそのテープの最初に書き込まれます。テープ メディア セットの最後のメディアだけをスキャンすればよいため、カタログの再構築が高速化されます。
[カタログの高速再構築]オプションは、グルーミングがオフになっているディスク メディア セットでも使用できます。

メディア セットを再構築するには、次の手順に従います。

  1. 再構築するメディア セットをメディア セット リストで選択します。
  2. [メディア セット]ツールバーの[再構築]ボタンをクリックします。ダイアログが表示され、再構築するメディア セットのタイプを要求されます。メディア セットのタイプを選択して、[次へ]をクリックします。
  3. 07fig29.tiff

  4. [再構築]ダイアログが表示され、メディア セットの最初のメンバーを選択するよう要求されます。[再構築]ダイアログは、選択したメディア セットのタイプによって多少変わる場合があります。
  5. 07fig30.tiff

  6. [メンバーの追加]ボタンをクリックします。ダイアログが表示され、メディア セットの最初のメンバーに移動できます。この例では、ディスク メディア セットを使用して、バックアップ ディスク上のRetrospectフォルダに移動し、再構築するメディア セットを含むフォルダに移動し、メディア セットの最初のメンバーを選択しています。名前は必ず「1-メディア セット名」となります。
  7. 07fig31.tiff

  8. [次へ]をクリックします。選択したメディア セット メンバーがRetrospectで認識され、メディア セット メンバーの日付、名前、ステータス(暗号化されているかどうか)を示すダイアログが表示されます。
  9. ダイアログ内でメディア セット メンバーをクリックして選択し、[次へ]をクリックします。メディア セット メンバーが
    [再構築]ダイアログに表示されます。
  10. 追加するメディア セットのメンバーが他にもある場合は、手順4~6を、すべてのメンバーが追加されるまで繰り返します。
  11. [再構築]をクリックします。ダイアログが表示され、再構築したカタログを保存するフォルダを指定するよう要求されます。目的の場所に移動して、フォルダを選択し、[再構築]をクリックします。再カタログの操作が開始され、メディア セットの内容から新しいカタログ ファイルが構築されます。アク
    ティビティ リストで進行状況を監視できます。操作が完了したら、アクティビティ リストのスコープ バーで[過去]ボタンをクリックすると、再構築が正常に完了したかどうかについての詳細が表示されます。操作が正常に完了しなかった場合は、
    [ログ]タブをクリックして詳細情報を表示してください。

メディア セットのグルーミング

デフォルトでは、ディスク メディア セットのメンバーであるディスクが一杯になる(または割り当てたディスク領域がすべて使用されている)と、ファイルやフォルダのコピーを続行するための新しいディスクを要求されます。

既存のディスクを使用し続ける場合は、ディスク領域を空けるためのグルーミング オプションを使用すれば、古いファイルやフォルダが削除されるため、新しいディスク用の領域を確保できます。

ディスクのグルーミングを有効にし、グルーミング ポリシーを指定
(またはRetrospectのポリシーを使用)すると、領域が必要になった場合に(ポリシーに基づいて)古いファイルやフォルダが自動的に削除されます。

警告: 前述のとおり、グルーミングでは、ディスク領域を確保するためにファイルやフォルダが削除されます。削除されたファイルやフォルダはリカバリできません。グルーミングを有効にする前に、重要な
ファイルとフォルダを保護するバックアップ ポリシーが設定されていることを確認してください。

ディスク メディア セットのためのグルーミング オプション

このオプションはディスク メディア セットでしか使用できません。ここでの選択により、バックアップ先のメディア セットが一杯になった(または割り当てたディスク領域がすべて使用された)場合の処理が決定します。ディスク グルーミングのオプションは、メディア セットの[オプション]タブで選択できます。

07fig32.tiff

グルーミングのオプションは次のとおりです。

  • グルーミングなし: バックアップ ドライブが一杯になると、追加のバックアップを保存するための別のハード ディスク ドライブが要求されます。そのハード ディスク ドライブに元からあったバックアップはすべて残ります。
  • このバックアップ数を維持するようグルーミングする: バックアップ ドライブが一杯になった場合、またはスクリプトされたグルーム操作や手動グルーム操作を実行する場合に残すバックアップ数をソースごとに指定します。ハード ディスク ドライブ上にあるそれ以外の古いバックアップが自動的に「グルーミング」(削除)され、新しいデータのための領域が確保され
    ます。
  • Retrospectの定義するポリシーにグルーミング: バックアップ ドライブが一杯になった場合、またはスクリプトされたグルーム操作や手動グルーム操作を実行する場合、Retrospectのグ
    ルーミング ポリシーに基づいて古いバックアップが削除されます。Retrospectのポリシーでは、ソースごとに最低でも2つの
    バックアップが保持されます。各ソースがバックアップされた直近の2日間の中から、その日最後にバックアップされたものが保存されます。メディア セットに十分な空き容量がある場合は、最後の週の毎日のソースのバックアップ、最後の月の週ごとのバックアップ、前の月ごとのバックアップが保存され
    ます。

通常は、グルーミング オプションを設定するだけで、それ以上のことをする必要はありません。しかし、特定のディスク メディア セットのグルーミングをいつでもオンまたはオフに切り替えることができるため、一杯に近いメディア セットがあっても、そのメディア セットのグルーミングをオンにして、すぐにグルーミングを実行することもできます。

注: メディア セットのグルーミングがアクティブになっている場合、グルーミング オプションで設定したバックアップの維持数の範囲に収まるようにするために、各ソースのポイント イン タイムのファイルとフォルダのリストがメディア セットから取得され、メディア セットのカタログに追加されます。グルーミング ポリシーがアクティブになっているメディア セットのカタログには、これらの追加データを保存する必要があるため、グルーミングがオフのメディア セットに属するカタログよりもサイズが大きくなります。

ディスク メディア セットを手動でグルーミングするには、メディア セットをリストで選択して、[メディア セット]ツールバーの[グ
ルーミング]をクリックします。グルーミング操作を確認するダイアログが表示されます。[グルーミング]をクリックします。グルーミング操作が開始され、グルーミング オプションに従って余分なバックアップがメディア セットから削除されます。アクティビティ リストで進行状況を監視できます。操作が完了したら、アクティビティ リストのスコープ バーで[過去]ボタンをクリックすると、グルーミングが正常に完了したかどうかについての詳細が表示されます。操作が正常に完了しなかった場合は、[ログ]タブをクリックして詳細情報を表示してください。

メディア セットのリサイクル

リサイクルを実行すると、メディア セットのカタログ ファイルの内容(ある場合)が消去され、ファイルのバックアップが存在しないのと同じ状態になります。次に、メディア セットの最初のメディア メン
バーが検出され、使用可能な場合は消去されます。最初のメンバーが使用可能でない場合は、適切な形式の新しいメディアまたは消去済みのメディアが使用されます。ソースで選択したすべての内容がメディア セットにバックアップされます。

メディア セットのリサイクルを設定するには、スクリプト スケジュールを使用するか、メディア セット リストで手動で設定します。メディア セットをリサイクルするには、次の手順に従います。

  1. リサイクルするメディア セットをメディア セット リストで選択します。
  2. [メディア セット]ツールバーの[リサイクル]ボタンをク
    リックします。選択を確認するダイアログが表示されます。
    [リサイクル]をクリックします。
  3. リサイクルを実行するとデータが失われるため、操作をもう一度確認するよう要求されます。[キャンセル]または[リサイクル]をクリックします。
  4. 07fig33.tiff

  5. [リサイクル]をクリックすると、カタログ ファイルの内容が削除されます。

Retrospectの移動

バックアップ コンピュータを変更する際に必要となるのは、Retrospectとバックアップ デバイスを新しいマシンにインストールすることだけではありません。他にもいくつかのファイルを新しいバックアップ コンピュータに移動して、Retrospectの環境設定、クライアント、カタログ、スクリプト、スケジュールをそのまま維持する必要があります。

Retrospectを新しいバックアップ コンピュータに移動するには、次の手順に従います。

  1. Retrospectエンジンおよびコンソールを新しいコンピュータにインストールします。
  2. 古いRetrospectサーバの/Library/Application Support/Retrospect/フォルダから次のファイルとフォルダを収集し、新しいRetrospectサーバのデスクトップにコピーします。
  3. /Catalogs/(フォルダ全体とその中のもの)

    Config80.bak

    Config80.dat

    operations_log.utx(オプション)

    privkey.dat(ある場合)

    pubkey.dat(ある場合)

  4. 新しいRetrospectサーバで、Retrospectのシステム環境設定パネルを使用して、Retrospectエンジンを停止します。
  5. 手順2で収集したファイルとフォルダを、新しいRetrospectサーバの/Library/Application Support/Retrospect/フォルダにコ
    ピーして、既存のファイルを置き換えます。この操作を行ううえで、管理者パスワードによる認証が必要になる場合があり
    ます。
  6. Terminalアプリケーションを開いて、次のコマンドを間違えないように気を付けて入力し、管理者パスワードを使用して認証し、移動したファイルの所有権を変更します。
  7. cd /Library/Application\ Support/Retrospect/

    sudo chown -R root:admin *

    警告: cdコマンドで正しいディレクトリに移動したことを確認してからchownコマンドを実行してください。cdコマンドを入力すると、Terminalのプロンプトはマシン名:Retrospectユーザー名$となります。別のプロンプトが表示された場合は、cdコマンドをもう一度入力します。

  8. Retrospectのシステム環境設定パネルを使用して、新しいRetrospectサーバでRetrospectエンジンを起動します。
  9. 次に、移動したカタログ ファイルを新しいRetrospectサーバで認識させる必要があります。Retrospectコンソールの[メディア セット]カテゴリーで、ステータス列に赤色のXアイコンが表示されたメディア セットをすべてハイライト表示し、[削除]ボタンをクリックします。次に、[検出]ボタンをクリックして、この章の『メディア セットのカタログの追加』に記載された手順を、新しいRetrospectサーバにコピーしたすべてのカタログ ファイルに対して実行します。
  10. 古いコンピュータまたは新しいバックアップ コンピュータ(あるいはその両方)をバックアップするには、次の手順も実行する必要があります。

新しいバックアップ コンピュータが以前にクライアントとしてバックアップされたことがある場合、現時点ではボリュームがローカルになるため、そのクライアントは必要なくなります。このクライアントを削除してください。クライアント ボリュームを使用したすべてのRetrospectスクリプトのソースを新しいコンピュータで編集し、現在
ローカルとなっているボリュームを追加します。

古いバックアップ コンピュータをバックアップする場合は、古いマシンにRetrospectクライアント ソフトウェアをインストールして、新しいバックアップ コンピュータのRetrospectからボリュームにアクセスする必要があります。クライアントをインストールおよび構成したら、
ボリュームをスクリプトに追加します。[ソース]で、以前ローカルだったボリュームを削除します。ボリュームを削除すると、ボリューム データベースおよびそのボリュームを使用するスクリプトからも削除されます。

Mac 用 Retrospect のアンインストール

Mac 用 Retrospect を削除するには、次のステップを実行します。

  1. アンインストーラは Config ファイル(ログインしたクライアント、スクリプト、スケジュール、エンジン全般の環境設定を含む)、Retrospect コンソールの環境設定、すべてのメディアセットカタログファイル(各メディアセットにどのファイルがバックアップされたかを記録するファイル)を保持します。これら設定とカタログすべてを完全に削除したい場合は、次のファイルとフォルダーを削除します。
    • /Library/Application Support/Retrospect/Catalogs/
    • /Library/Application Support/Retrospect/Config80.bak
    • /Library/Application Support/Retrospect/Config80.dat
    • /Library/Application Support/Retrospect/ConfigISA.bak
    • /Library/Application Support/Retrospect/ConfigISA.dat
    • /Library/Application Support/Retrospect/retro_isa.ini
    • /Library/Application Support/Retrospect/retro.ini
    • ~/Library/Preferences/com.Retrospect.plist
  2. Retrospect アプリケーションフォルダを開き、[Retrospect のアンインストール]アイコンをダブルクリックしてアンインストーラを実行します。