高度な機能

Retrospect には、バックアップや復元に必要となる基本的な機能を、さらに発展させた高度な機能があります。Retrospect を操作する上で必須ではありませんが、高度な機能を知っていれば、より快適な操作環境と高い効率を得ることができます。

ボリュームの操作

ボリュームとは、ハードディスクドライブやパーティション、リムーバブルディスク、CD/DVD など、ランダムアクセスス式のトレージデバイスを表すオペレーティングシステムの用語です。ネットワークのファイルサーバを指すこともあります。また、ボリュームは、ファイルやフォルダを内包する基本的な保存単位でもあります。Retrospect では、これらをバックアップ操作などにおける元ボリュームとして使用し、ファイルをボリュームのスナップショットによって管理しています。

バックアップコンピュータまたはログインクライアントに Microsoft SQL Server または Exchange Server がインストールされている場合は、それも Retrospect のボリュームリストウインドウに表示されます。Exchange Server で追加コンテナの Exchange Mailboxes がインストールされている場合には、それも表示されます。

SQL データベースや Exchange データベースとメールボックスをバックアップしたり復元したりするには、Retrospect の SQL Server Agent や Exchange Agent が必要です。SQL サーバの操作方法について詳しくは、「SQL Server Agent」を参照してください。Exchange サーバとメールボックスの操作方法について詳しくは、「Exchange Server Agent」を参照してください。

ボリュームリストウィンドウ

Retrospect には、2 つのボリュームリストウィンドウがあります。操作対象とするボリュームを選択するため、多くの操作で、「ソース選択」ウィンドウを使用します。

399

基本バックアップの「ソース選択」ウィンドウ

これに似たウィンドウの「ボリュームデータベース」ウィンドウは、ボリュームを管理するのに使用できます。「ボリュームデータベース」ウィンドウには、「ソース選択」ウィンドウからは利用できない追加機能がいくつかあります。たとえば、「ボリュームデータベース」ウインドウのリストは、ボリュームの複雑な切り換えや選択が可能なように編成されており、そのためのコントロール機能を備えています。

400

「ボリュームデータベース」ウィンドウ

これらのウィンドウは、どちらも使い方は簡単です。目的のボリュームをクリックし、そのボリュームに対する動作をボタンかツールバーアイコンで選択します。(右クリックして、コンテキストメニューを使用することもできます。)

ここで説明した方法を試すには、「設定」>「ボリューム」の順にクリックして、「ボリュームデータベース」ウィンドウを開きます。

スクロールボックスにリストされるボリュームは、Windows のエクスプローラと同様のアウトライン形式で表示されます。

ボリュームの表示

「ソース選択」ウィンドウの左側にある + と – のアイコンは、Windows のエクスプローラのアイコンと同様の働きをします。+ アイコンをクリックすると、コンテナ(コンテナ)またはフォルダ(フォルダ)の内容が表示されます。– アイコンをクリックすると、コンテナまたはフォルダの内容が非表示になります。サブボリュームが定義されている場合にのみ、このコントロールは表示されます。

ボリュームの選択

ボリュームリストウィンドウで、ボリュームをクリックして選択します。選択は、別のボリュームをクリックすると解除されます。

前の選択を解除せずにボリュームを選択するには、Ctrl キーを押しながらボリュームをクリックします。複数のボリュームを選択するには、この方法を使用します。

Shift キーを押しながらボリュームをクリックすると、最初に選択したボリュームからそのボリュームまでの全ボリュームが選択されます。この方法は、連続した複数ボリュームの選択といいます。

複数を選択できない操作もあります。(たとえば、複数のボリュームを復元することはできません。)

次に、これらの選択方法の例を挙げます。

(1)最初の選択

402

(2) Iago のクリックの後

403

(3) Ctrl キーを押しながら Iago をクリックした後

404

(4) Shift キーを押しながら Iago をクリックした後

405

個別または複数の選択を行う方法は、ボリュームリストだけではなく、Retrospect 全体を通じて動作します。

コンテナ

ボリュームリストでは、ボリューム、クライアント、およびグループはマイコンピュータ、マイネットワーク、バックアップクライアント、元ボリュームグループというコンテナで編成されます。

405

このトップレベルのコンテナのいずれかを選択すると、そのコンテナ内のすべてが選択されます。たとえば、バックアップコンピュータに付属するすべてのハードディスクおよびリムーバブルディスク、それに Retrospect にログインしたすべてのクライアントは、マイコンピュータおよびバックアップクライアントのコンテナを元ボリュームとして選択するだけで、簡単にバックアップすることができます。

マイコンピュータ

「マイコンピュータ」コンテナには、ローカルドライブボリュームが含まれています。内蔵ハードディスク、メディアをマウントしたリムーバブルディスク、外部ドライブなどが含まれます。マップされたネットワークドライブやネットワークボリュームは含まれません。「マイコンピュータ」コンテナには、ローカルな SQL データベース、Exchange データベース、および Exchange メールボックスも含まれています。

「マイコンピュータ」コンテナ自体を選択すると、バックアップコンピュータのそのコンテナ内のすべてのボリュームを選択したことになります。ただし、フロッピーディスク、CD-ROM ディスクは除外されます。

次の「マイコンピュータ」コンテナの選択例は、解決されるボリュームを示しています。たとえば、バックアップ操作で、あるコンテナを選択すると、そのコンテナに含まれているボリュームがバックアップされます。

この選択例の使用

ボリュームの
内訳

406

Capulet
Montague

マイネットワーク

「マイネットワーク」コンテナには、追加した共有ボリュームだけが含まれます。

「マイネットワーク」コンテナ自体を選択すると、含まれるすべての共有ボリュームを選択したことになります。

ボリュームデータベースにネットワークボリュームを追加するには

  1. ナビゲーションバーで「設定」>「ボリューム」をクリックします。
  2. 「マイネットワーク」ボタンをクリックします。
  3. 追加するボリュームまたはフォルダまで、ネットワークをたどります。
  4. 「高度な機能」をクリックして、追加するボリュームの UNC パスを直接入力することもできます。
  5. そのボリュームまたはフォルダを選択し、「追加」ボタンをクリックします。

サーバから要求された場合には、ログイン名とパスワードを入力し、「OK」をクリックします。

407

ネットワークボリュームへのアクセス権を持つユーザとしてログインするように Retrospect を設定した場合、再びログインを要求されることはありません。詳しくは、セキュリティ環境設定を参照してください。

バックアップクライアント

バックアップクライアントコンテナには、Retrospect で使用するためにログインによって追加したクライアントコンピュータが含まれています。また、クライアント自体には 1 つ以上のボリュームが含まれており、クライアントのプロパティウィンドウの「ボリューム」タブ中の設定に従って、そのボリュームを利用できます。詳細については、「ネットワーク接続クライアント」を参照してください。

公開/秘密キー方式を使用してバックアップクライアントデータベースに自動的に追加されたWindows 版 Retrospect クライアントは、デフォルトでバックアップクライアントコンテナ内の「Automatically Added Clients」フォルダにグループ分けされます。詳しくは、環境設定の追加を参照してください。

「バックアップクライアント」コンテナ自体を選択すると、含まれるすべてのクライアントを選択したことになります。

SQL サーバや Exchange サーバをクライアントとして追加していた場合、「バックアップクライアント」コンテナ内にそれらのサーバが表示されます。Exchange サーバクライアントがある場合には、「Exchange メールボックス」コンテナも表示されます。

元ボリュームグループ

元ボリュームグループコンテナには、適正にグループ化されたボリュームが含まれています。グループの定義には、実際のボリュームは含まれていません。ここには、実際のボリューム(マイコンピュータ、マイネットワークやバックアップクライアント内に存在する)のショートカットである別名が記述されます。

たとえば、会計部門のボリュームを含む、会計(Accounting)グループを作成することができます。後でバックアップスクリプトを作成するときは、個々の会計ボリュームを選択しなくても、会計グループを選択するだけでグループ内のすべてのボリュームが認識されます。

元ボリュームグループは、複製や復元操作におけるボリュームリストでは使用できません。

グループの作成:新しいグループを作成するには、ナビゲーションバーで「設定」>「グループ」をクリックします。「ボリュームデータベース」ウィンドウで、ツールバーの「新規グループ」をクリックします。ダイアログボックスにグループ名を入力すると、元ボリュームグループコンテナに新規グループが表示されます。グループ作成時にハイライト表示される項目は、すべて新規グループに属します。

グループへのボリューム追加:「マイコンピュータ」、「マイネットワーク」、「バックアップクライアント」コンテナからグループに任意の項目をドラッグできます。

元ボリュームグループに含まれているのはボリューム自体ではなく、ボリュームへのショートカットであるため、同じボリュームを複数の元ボリュームグループに追加できます。

グループ項目の整理:グループ内の項目は、必要に応じて別のグループにドラッグします。また、グループ内の項目を整理するために、項目をグループ内の別の位置に移動することもできます。

グループの削除:不要なグループ(または、項目)を削除するには、そのグループを選択してツールバーの「削除」をクリックするか、または Delete キーを押します。

フォルダ

フォルダを作成して、ボリュームリストウィンドウに表示される情報を整理することができます。たとえば、バックアップを設定するときにフォルダをバックアップ元として選択すると、そのフォルダ内のすべてのボリュームがバックアップされます。

これらのフォルダは Retrospect 専用のもので、プログラム外では表示されません。

公開/秘密キー方式を使用してバックアップクライアントデータベースに自動的に追加されたWindows 版 Retrospect クライアントは、バックアップクライアントコンテナ内の「Automatically Added Clients」フォルダにグループ分けされます。詳しくは、環境設定の追加を参照してください。

フォルダの作成

新規フォルダを作成するには、ツールバーの「新規フォルダ」をクリックします。希望のフォルダタイプを選択するよう要求されます。この選択によって、新規フォルダが作成されるのが「マイコンピュータ」コンテナであるか、「マイネットワーク」コンテナであるか、「バックアップクライアント」コンテナであるかが決まります。タイプを選択して名前を付けると、408 アイコンで表されたフォルダがリスト中にボリュームとともに表示されます。ドラッグしてリスト内の順序を変更できます。

フォルダの整理

任意のボリュームをフォルダ内またはフォルダ外に移動してボリュームのリストを整理できます。

409

フォルダは、ハードディスク上のフォルダと同様、多くの項目を非表示にすることで作業域を整理することができます。たとえば、多くのクライアントを管理している場合は、個々のボリュームを会計フォルダ、技術フォルダ、製造フォルダなど、個別の部門フォルダに分類、格納することで、それらを論理的な順序で整理することができます。次に、ボリューム選択ウィンドウでフォルダを選択できます。Retrospect は、そのフォルダ内のすべてのボリュームを選択します。

  • 1 つのボリュームは 1 つのフォルダだけに追加可能です。この点は、元ボリュームグループの場合(同じボリュームを複数のグループに追加可能)と異なっています。

フォルダの削除

不要なフォルダを削除するには、そのフォルダを選択してツールバーの「削除」をクリックするか、または Delete キーを押します。ただし、削除を実行する前にフォルダからその内容を移動する必要があります。

サブボリューム

ボリューム上のフォルダを、Retrospect 内ではボリュームとして扱うように定義することができます。サブボリュームとして定義したフォルダは、Retrospect の元ボリュームや宛先ボリュームなどに指定することができます。サブボリュームは Retrospect 以外では機能せず、他のボリュームファイルやフォルダにはまったく影響しません。

1 つのフォルダのファイルだけをバックアップする場合は、ボリュームを指定してカスタム セレクタを使用する代わりにサブボリュームを利用すると便利です。ファイルをスキャンする時間が短縮され、ブラウザに表示されるファイル数も少なく、必要なメモリも節約できるなどの利点があります。

サブボリュームは、システム上の独立したボリュームと見なされます。サブボリュームとして定義されたフォルダは、削除したり名前を変えたりすることはできません。削除したり名前を変えると、サブボリュームとして利用できなくなります。

複数の実行時には、サブボリュームは親ボリュームの一部と見なされます。たとえば、同じボリュームに属するサブボリュームを同時にバックアップすることはできません。それを行おうとすると、ボリュームは連続してバックアップされます。

サブボリュームの定義

ボリュームリストでボリュームを選択し、ツールバーの「サブボリュームの作成」をクリックするか、「サブボリューム」ボタンをクリックします。選択したボリュームのトップレベルにあるフォルダが、ダイアログボックスに表示されます。

410

選択したボリューム内の任意のフォルダを指定し、サブボリュームとして定義することができます。これにはフォルダ階層内に深く階層化されたフォルダも含まれます。サブボリュームとして定義するフォルダを選択し、「定義」をクリックします。現在サブボリュームとしてリストボックスに表示されているフォルダ名を使用する場合は、「使用」をクリックします。サブボリュームフォルダが、411 アイコンでボリュームリストに追加されます。

412

サブボリュームとその親ボリュームの両方を「元ボリューム」として指定すると、別のオブジェクトと見なされます。ただし、親ボリュームが関与する操作には、サブボリュームとして指定したフォルダの内容も含まれます。

定義したサブボリュームを削除するには

  1. 「ボリュームデータベース」ウィンドウからサブボリュームを選択します。
  2. ツールバーの「削除」をクリックするか、Delete キーを押します。

サブボリュームを削除しても、元のフォルダや、そのフォルダからバックアップしたファイルの内容は変わりません。

ボリュームユーティリティ

「ボリュームデータベース」ウィンドウとボリューム選択ウィンドウでは、ツールバーに、サブボリュームの作成と削除、名前を変える、取り出し、消去、リストされたボリュームの情報の取得などのコマンドがあります。

ボリュームリストで右マウスボタンをクリックすると、ツールバーと同じコマンドのメニューが表示されます。

サブボリュームの作成

フォルダをサブボリュームとして定義するには、親ボリュームを選び、「サブボリュームの定義」アイコンをクリックするか、Ctrl キーを押しながら U キーを押します。サブボリュームの定義で説明したダイアログボックスを使用します。

ライセンス

Retrospect SQL Server Agent または Retrospect Exchange Server Agent のライセンスを購入した場合、バックアップする各サーバにライセンスを適用しなければなりません。ライセンスコードを SQL または Exchange サーバに適用するには、サーバを選択してから、ツールバーの「ライセンス」アイコンをクリックするか、Alt キーを押しながら L キーを押します。

ローカルサーバは、「マイコンピュータ」コンテナ内にリスト表示されます。クライアントサーバは、「バックアッククライアント」コンテナ内にリスト表示されます。

プロパティ

ボリュームのプロパティを表示するには、「プロパティ」アイコンをクリックするか、Alt キーを押しながら Enter キーを押します。プロパティには、タイプ、ファイルシステム、ボリュームの総容量と空き容量、および場所が含まれます。

ログイン資格

ネットワークボリュームや SQL サーバ、Exchange サーバに関係するすべての操作を成功させる最も確実な方法は、これらのリソースへのアクセス権を持ったユーザとして、Retrospect にログインすることです。詳しくはセキュリティ環境設定を参照してください。

SQL サーバと Exchange サーバのログイン情報の設定について詳しくは、「SQL Server Agent」と「Exchange Server Agent」を参照してください。

ネットワークボリュームへのアクセス権を持たないユーザとして Retrospect にログインしている場合に、ネットワークボリュームを使用する基本操作を実行する必要があるときには、「ログイン名」ボタンを使用します。「ボリュームデータベース」リストでボリュームを選択し、ツールバーの「ログイン名」アイコンをクリックし、ユーザ名とパスワードを入力します。

そのボリュームを使った自動操作は機能しません。

名前を変える

ボリュームまたはサブボリュームの名前を変えるには、ボリュームを選び、「名前を変える」アイコンをクリックするか、Ctrl キーを押しながら R キーを押します。表示されるダイアログボックスに新しい名前を入力します。

取り出し

リムーバブルメディアをドライブから取り出すには、ボリューム名を選び、「取り出し」アイコンをクリックするか、Ctrl キーを押しながら J キーを押します。

削除

リストからボリュームまたはサブボリュームを削除するには、ボリュームを選択し、ツールバーの「削除」をクリックするか、「削除」をクリックします。ハードディスクや挿入されたカートリッジなど、現在アクティブなボリュームは削除できません。サーバを削除すると、そのデータベースと定義されたサブボリュームが削除されます。

消去

ボリュームの内容を消去するには、ボリュームを選び、「消去」をクリックするか、Ctrl キーを押しながら E キーを押します。ボリューム内の全ファイルが削除されるので、注意してください。

ブラウザ

「ボリュームデータベース」ウィンドウには、「参照」ボタンがあります。ボリュームの内容を表示して作業するには、そのボリュームを選択し、「参照」ボタンをクリックしてブラウザを開きます。ボリュームの参照については、ブラウザで詳しく説明します。

Windows ボリュームのマウントポイント(NTFS マウントされたドライブ)

Windows では、空のフォルダをボリュームのマウントポイントとして指定できます。ボリュームのマウントポイントは、別のドライブにアクセスするための一種のゲートウェイです。概要と設定の方法については、Windows のヘルプの索引で、「マウントされたドライブの概要」と、「NTFS フォルダとしてボリュームをマウントするには」を参照してください。

外観と構成

Windows エクスプローラでのマウントポイントは、ドライブアイコンで表示され、そのドライブにアクセスできるフォルダ名が名前として表示されます。マウントポイントは、階層としては、ドライブ内のドライブとして表示されます。マイコンピュータの他のドライブと同じレベルには表示されません。

413

親ボリューム C:Windows エクスプローラでの

Retrospect のマウントポイントは、ドライブアイコンで表示され、名前としてドライブラベルが表示されます。Retrospect の「ボリュームデータベース」ウィンドウとボリューム選択ウィンドウでは、マウントされたドライブは「マイコンピュータ」コンテナ内の他のドライブと同じ階層レベルに表示されます。

414

Retrospect で利用可能なマウントされたボリューム

Retrospect のボリュームブラウザウィンドウでは、マウントポイントの親ボリュームをブラウズすると、マウントポイントは実際と同様に単に空のフォルダとして表示されます。

415

Retrospect ブラウザでのマウントポイントの親ボリューム

ロジックと機能

Retrospect では、マウントされたボリュームは識別可能なボリュームと見なされ、親の NTFS ボリュームのフォルダやサブボリュームとしては見なされません。マウントポイントを通じてアクセスするボリュームをバックアップするには、Retrospect でマウントされたドライブを選択しなければなりません。マウントポイントフォルダを含む親ドライブを選択した場合や、そのフォルダ自体を選択した場合には、バックアップされません。

Retrospect でマウントポイントとして使用されるフォルダの親ボリュームをバックアップすると、スナップショット内のマウントポイントフォルダはバックアップに含まれますが、マウントされたボリュームのファイルとフォルダは含まれません。

Retrospect をスナップショットから復元すると、マウントポイントフォルダと、Windows でマウントパスを通じてボリュームにアクセスするために必要な情報が復元されます。(これは、アクセスするドライブが元の状態で存在するかどうかに依存しています。元の状態ではない場合、フォルダは復元されますが、マウントポイントは復元されません。)マウントされたボリュームにファイルとフォルダを復元するには、Retrospect で他のドライブを復元する場合と同様に、別個のドライブとして選択して復元します。

ブラウザ

ブラウザは、元ボリュームや宛先ボリュームのファイルやフォルダを表示、選択、操作できる Retrospect の強力なツールです。ブラウザウィンドウでは、Windows のエクスプローラと同様のファイル管理機能に加え、Retrospect 独自の機能が利用できます。

ブラウザでは、ボリュームの内容を一覧できるので、ボリューム全体を一度に操作することができます。異なるフォルダから、複数のファイルを簡単に選択できます。フォルダ階層ではなく、ブラウザをフラットファイル構造でも表示できます。

ブラウザでは、バックアップ、復元、複製、コピーの対象として選択したファイルを参照することができます。また、ブラウザを "スタンドアロン" 方式で用いてボリュームの内容を表示、管理することができます。バックアップ、復元、複製、およびコピー操作では、指定したセレクタで選択したファイルをブラウザで表示して、マークおよびマーク解除することができます。

ブラウザウィンドウは原則的にいくつでも開くことができるので、同一ボリュームの異なるブラウザを表示できます。ブラウザウィンドウを開いたまま、他の Retrospect 動作を実行し、ブラウザウィンドウと Retrospect ウィンドウを切り替えることも可能です。

それぞれのブラウザウィンドウで、Retrspect にはツールバーがあります。ツールバーには、ブラウザリストのフォルダやファイルを検索、選択、管理するコマンドがあります。(右クリックして、コンテキストメニューを使用することもできます。)

スタンドアロンブラウザの表示

ボリュームのスタンドアロンブラウザを表示するには、「設定」>「ボリューム」の順にクリックします。使用可能なボリュームの名前をリストした「ボリュームデータベース」ウィンドウが表示されます。ボリュームを選択して、「参照」をクリックします。選択したボリュームが検索され、そのボリュームに含まれるすべてのフォルダおよびファイルをリストしたブラウザウィンドウが表示されます。

バックアップセットのスタンドアロンブラウザの表示については、セッションの内容の表示を参照してください。スナップショットのスタンドアロンブラウザの表示については、「スナップショット」タブを参照してください。

操作中にブラウザを表示する

基本バックアップ、復元、複製、コピーなどの操作中にブラウザを表示するには、各サマリウィンドウの「選択したファイル」ボタンか、「プレビュー」ボタンをクリックします。各元ボリュームのブラウザウィンドウが表示されます。

ブラウザとスクリプト

スクリプトはスケジュールされた時刻に自動実行されるので、スクリプト内でブラウザを使用することはできません。スクリプトの編集時と実行時では、ボリュームの内容が変わっていることがあるため、ブラウザの使用は適していません。

ブラウザについて

ブラウザウィンドウには、選択したボリュームのフォルダとファイルが階層化されたファイルリストとして表示されます。

416

リストの先頭、つまり階層のトップレベルには、ボリューム名が表示されます。フォルダの左側には + と – のコントロールがあり、+ をクリックするとフォルダの内容が表示されます。– をクリックすると、フォルダの内容が非表示になります。フォルダを開いているときは、フォルダを閉じているとき417 とは別のアイコン418 になります。

419

フォルダの内容を表示しない場合(左)とフォルダの内容を表示した場合(右)

ウィンドウの左側には、各フォルダの概要をグラフィックで示したスクロールタイプのフォルダインデックスが表示されます。フォルダインデックスをクリックすると、対応するファイルリストがウィンドウの右側に表示されます。インデックスの上には、ファイルリスト内で現在選択されている項目のパス名が表示されます。閉じたフォルダの点線はグレイで表示され、開いたフォルダは黒で表示されます。

ウィンドウの右上には、ハイライト表示またはマーク付けされたファイルの数と総サイズを示す数値が表示されます。

ファイルやフォルダの選択

ブラウザウィンドウでは、操作の対象となるファイルやフォルダを選択します。ファイルリストの項目で、目的のファイルをクリックして選択してください。連続したファイルやフォルダを選択するには、選択する範囲をドラッグするか、Shift キーを押しながらクリックします。連続していない項目を選択または選択解除するには、Ctrl キーを押しながらクリックします。全項目を一括して選択するには、「編集」メニューの「すべてを選択」を選択します。ファイルをダブルクリックすると、ファイルの選択(強調)とマークが同時にできます。マーク付けについては、「ファイルやフォルダのマーク付け」で後述します。

詳細情報の表示

Retrospect には、選択したファイルやフォルダの詳細を参照できる「プロパティ」コマンドがあります。

ファイルやフォルダの情報を見るには

  1. ブラウザから、詳細を知りたいファイルやフォルダを選択します。
  2. ツールバーの「プロパティ」をクリックします。

選択したファイルやフォルダごとに、詳細を示す「プロパティ」ウィンドウが表示されます。

420

ファイルやフォルダのマーク

マークしたファイルやフォルダは、バックアップ、アーカイブ、複製、復元などの操作対象になります。実行時には、セレクタの検索基準に基づいてファイルがマークされますが、どのファイルがマークされたかは、ブラウザを使わないとわかりません。ブラウザでは、ファイルやフォルダのリストを参照できるだけでなく、個別にマークおよびマーク解除することができます。

マークされたファイルは、操作の実行時に Retrospect に評価させるファイルを示します。マークされたファイルすべてが、バックアップや複製や復元されるわけではありません。たとえば、Retrospect の初期設定を使ったバックアップ中、マークしたファイルに関係なく、新しいファイルと修正されたファイルだけがバックアップされます。ブラウザリストの中で、宛先にすでに存在する元ファイルの隣にはひし形のアイコンが表示されます。これらのファイルは、宛先に再びコピーされることはなく、時間とメディア容量が節約されます。

ブラウザでマークを付けるには、ファイルとフォルダを選択してから、左のチェックボックスをクリックします。マークを取り消すには、チェック済みのチェックボックスをクリックします。マークとマーク解除は、ファイルやフォルダをダブルクリックして行うこともできます。

ハイライトされた他の項目に影響を与えないように項目のマーク付けあるいはマーク解除を行うには、Ctrl キーを押したままクリックします。

1 つのフォルダに対するマークやマーク解除は、そのフォルダとフォルダ内の全ファイルに対して実行されます。たとえば、1 つのフォルダをバックアップ対象としてマークするには、ファイルリストの先頭にあるボリューム名をダブルクリックし、いったん、すべてのファイルをマーク解除します。次に、バックアップするフォルダにスクロールし、フォルダアイコンをダブルクリックします。すると、そのフォルダとそのフォルダ内のすべてのファイルがマークされます。

ブラウザウィンドウのツールバーには、ウインドウ内でハイライト表示やマーク付けを行うための次のコマンドがあります。

「マークをハイライトに」は、マークされたファイルをハイライトにします。Ctrl キーを押さずにクリックまたはダブルクリックすると、マークした項目のハイライトが解除されます。このコマンドは、再度ハイライトする場合に役立ちます。

「相互参照」により、指定のファイルに関連するファイルを同じハードディスクまたはセッション内で探すことができます。たとえば、複製ファイルや同じファイルの旧バージョンを検出でき、またオリジナルファイルの名前を変更して作成したファイルを検出することもできます。このコマンドは相互参照ファイルをハイライトしますが、マークはしません。

表示形式の選択

ブラウザウィンドウのツールバーコマンドの「階層/ソート表示」ボタンをクリックすると、ボリュームの内容の表示方法が変わります。

階層形式では、ファイルとフォルダがボリュームに保存されている階層構造と同じ構造で表示されます。ブラウザウィンドウをはじめて表示するときは、このデフォルトレイアウトが使用されます。

整列ファイル形式では、フォルダの指定が破棄されて、選択されたボリューム内のすべてのファイルが単一リスト(フラットファイル構造)で表示されます。

ツールバーのリストボックスでは、どちらのレイアウトの場合も、ブラウザウインドウに表示するファイル情報のタイプを指定できます。フラグ、名前、サイズは常に表示されます。最後の情報として、修正日時または属性を選択できます。

整列されたファイルレイアウトでは、列の見出しをクリックして、リストの整列基準を選択できます。もう一度クリックすると、整列順序が逆になります。ファイルは通常通り昇順に並べ替えられます。たとえば、「サイズで並べ替え」を選択すると、ファイルリストの先頭に最も小さいファイルが表示され、リストの末尾に最も大きなファイルが表示されます。

ファイルの検索

「編集」メニューには、ボリューム上の特定のファイルやフォルダを探す「検索」という項目があります。

「ファイルの検索」による復元では、以下に示すものと同じウィンドウを使用します。

421

「検索」ウィンドウ(基本選択表示)

この基本検索ウィンドウでは、ファイルまたはフォルダ名を第一の検索基準と見なします。「追加選択」をクリックして、他の基準を使用するカスタムセレクタを作成できます。Retrospect セレクタは、セレクタ詳細ウィンドウと同じウィンドウで作成できます。

「検索」ウィンドウでの検索基準の作成については、セレクタの使い方を参照してください。

テキスト入力フィールドに、検索する文字列を入力します。「大文字と小文字を区別する」チェックボックスをクリックしていない限り、大文字と小文字は区別されません。

「ファイル」と「フォルダ」のチェックボックスを使用すると、検索中にファイルとフォルダを対象にしたり無視したりできます。フォルダを対象にするときには、「フォルダ(階層を含む)」をチェックして、他のフォルダ内にあるファイルを含めて、見つかったフォルダに含まれるすべてのフォルダを選択します。

「する/しない」リストボックスを使用して、検索ロジックを制御します。「する」では含め、「しない」では除外します。たとえば、「しない」を選択してファイル名を検索すると、指定文字を含まない名前のファイルとフォルダがすべて検索されます。

他のリストボックスを使用して、名前での検索テキストの位置を指定します。指定文字が名前の先頭にあるものを探す場合は「で始まる」、末尾の場合は「で終わる」、先頭から末尾までを検索する場合は「を含む」と指定します。指定文字と完全に一致し、それ以外の文字が含まれない名前だけを検索する場合は「一致」を選択します。また、検索テキストのパターンに一致する(一致パターン)名前を指定できます。パターン一致の場合、任意の 1 文字と一致させるにはワイルドカード文字 ? を使用します。複数の文字と一致させるには、ワイルドカード文字 * を使用します。

検索ウィンドウの検索基準を編集してから「OK」をクリックすると、検索基準に該当するすべてのファイルとフォルダがハイライトされます。操作で使用するために、ハイライトされたファイルにマークを付けることができます。

ファイルリストの印刷またはエクスポート

ブラウザウィンドウがアクティブなときは、ファイルリストの内容を印刷したり、ファイルにエクスポートしたりすることができます。印刷するには、「ファイル」メニューから「プリント」を選択します。「用紙設定」を使ってサイズを縮小すると、ブラウザが複数の列で印刷されるので、ページ数を少なくすることができます。テキストファイルにエクスポートするには、「ファイル」メニューから「エクスポート」を選択します。Retrospect は表示フォーマットにかかわりなく、ファイル名、サイズ、作成日付、作成時刻、修正日付、修正時刻、バックアップ日付、バックアップ時刻、Mac OSのタイプ、Mac OSのクリエータ、バックアップセット(あれば)、およびパスの順で、フィールドをエクスポートします。

選択対象のコピー、ペースト

選択対象は、ブラウザウィンドウ間でコピーできます。選択対象をコピーすると、ファイルとパス名の情報だけがコピーされ、ファイル自身はコピーされません。この機能は、スタンドアロンブラウザウィンドウから、復元操作中などに表示されるブラウザウィンドウに選択対象をコピーする際に役立ちます。

他のアプリケーションや文書にはペーストできません。

ブラウザウィンドウ間で選択対象をコピーするには

  1. ファイルおよびフォルダを選択し、「編集」メニューから「コピー」を選択します。
  2. 同じボリュームのブラウザウィンドウを開きます(または全面に配置します)。
  3. 「編集」メニューから「ペースト」を選択します。

選択対象が新規ブラウザウィンドウにペーストされ、他のブラウザウィンドウに選択、コピーされたファイルおよびフォルダ(同じフォルダ階層内にある)と同じものだけがハイライトされます。

選択対象をセレクタとして保存

選択したファイルおよびフォルダをセレクタとして保存しておき、同じボリュームでバックアップや復元操作などを行うときにそのセレクタを使ってファイルを再度選択することができます。

選択対象をセレクタとして保存する前に、セレクタの使い方に説明されているカスタムセレクタの作成を検討してください。カスタムセレクタはいつでも簡単にレビューまたは変更することができます。ブラウザの「ハイライトを保存」コマンドで作成するセレクタは、あまり柔軟性がありません。

選択対象をセレクタとして保存するには

  1. セレクタに適用するファイル/フォルダを選択します。
  2. ツールバーから「ハイライトを保存」をクリックします。

    422

    選択しているファイル数と、パス名が適合した場合にこのセレクタによって選択されるファイル数がこのウィンドウに表示されます。

  3. リストボックスを使用して、保存されたセレクタで含めるか除外するかを指定します。

    このウィンドウには、ファイルの検索で説明した検索ウィンドウと同じようなファイルとフォルダのオプションもあります。

  4. 「OK」をクリックしてから、セレクタ名を入力して新しいセレクタを保存します。

ボリュームの再検索

「ファイル」メニューの「更新」を選択して、ブラウザウィンドウの内容を更新することができます。たとえば、ボリュームのブラウザウインドウを開いているときに(Windows のエクスプローラやその他のブラウザウインドウ内で)ボリュームに変更を加える場合は、この機能が役に立ちます。

「更新」は、Retrospect で直接ボリュームを使用しているときだけ「ファイル」メニューに表示されます。たとえば、バックアップセットを参照しているときは、ボリュームを再検索できません。

ファイルの削除

Retrospect ブラウザでは、「削除」コマンドでファイルをボリュームから削除することができます。これは、特定のファイルを Windows のデスクトップのごみ箱に捨てて、ごみ箱を空にする操作です。

Retrospect では、バックアップセットからファイルを削除することはできません。

ファイルを削除するには

  1. ファイルリストから削除したい 1 つまたは複数のファイルを選択します。
  2. ツールバーの「削除」をクリックします。

    ダイアログボックスが表示されたら、指定したファイルだけを削除するか、指定したファイルとファイルの削除によって空になるフォルダも削除するか選択します。

  3. どちらかを選択したら、「OK」をクリックします。

指定されたファイルはボリュームから完全に削除されます。

削除コマンドを実行した場合は、「元に戻す」コマンドでその操作を取り消すことはできません。またごみ箱からファイルを取り出すこともできません。ファイルが削除されると、取り戻すことはできません。

ブラウザウィンドウのツールバーでは、Retrospect でボリュームをダイレクト使用しているときだけ「ディスクから削除」が使用可能です。たとえば、バックアップセットを参照しているときは、ファイルを削除できません。

セレクタの使い方

基本操作と自動操作でセレクタを使用し、操作に組み込むファイルやフォルダの種類を指定できます。セレクタを使用して特定のフォルダやフォルダを選択することで、操作に必要な時間やメディアを制限できます。

セレクタでは、名前、日付、タイプ、またはサイズなど、ほぼどの基準を用いてもファイルを選択できます。Retrospect には組み込みのセレクタがたくさんあり、カスタムセレクタを作成することもできます。たとえば、2004 年の 10 月 15 日以降に変更されたすべてのテキスト文書を選択するセレクタなどを作成できます。

セレクタでマークされたファイルは、必ずしも宛先にコピーされるとは限りません。セレクタを用いたコピー操作(バックアップなど)は、照合機能によりスマートな、すなわちプログレッシブな操作となります。各セレクタは、「このファイルを選択してください。ただし、宛先ボリュームにそのファイルが存在する場合はそれをコピーしないでください」ということを暗に示しています。

Retrospect のセレクタで空のフォルダを選択することはできません。

セレクタウィンドウ

セレクタウインドウで、セレクタを作成または変更することができます。

セレクタウィンドウを表示するには、「設定」>「セレクタ」を順にクリックします。セレクタウィンドウには、すべての組み込みセレクタとカスタムセレクタが一覧されます。

423

セレクタウィンドウには、セレクタを使用するためのボタンが 2 つあります。

「新規」では、新しいセレクタを作成します。

「編集」では、セレクタの新しい条件を追加するか、または既存の条件を変更します。

セレクタの詳細ウィンドウには、次のコマンドを備えたツールバーがあります。

「新規フォルダ」は、セレクタを整理するためのフォルダコンテナを作成します。

「複製」は、現在ハイライトされているセレクタをコピーします。

「名前を変える」は、現在ハイライトされているセレクタの名前を変更します。

「エクスポート」では、セレクタをファイルにエクスポートできます。たとえば、バックアップコンピュータの Retrospect で使用するカスタムセレクタを作成した後、そのセレクタをエクスポートして、第二のバックアップコンピュータ上で動作している別の Retrospect で使用できます。

「インポート」では、セレクタをファイルからインポートできます。

「削除」は、現在ハイライトされているセレクタを削除します。

セレクタリストで右マウスボタンをクリックすると、ツールバーとウィンドウのボタンと同じコマンドのメニューが表示されます。

組み込みセレクタ

Retrospect には、あらかじめファイル選択条件が定義されたいくつもの組み込みセレクタがあります。

一部のセレクタとセレクタ条件の動作は、Windows、Mac OS、Linux の各ボリュームで異なります。以下の説明では、組み込みセレクタによる Windows ボリュームの処理に焦点を当てています。他のオペレーティングシステムへのセレクタの効果については、セレクタをダブルクリックして、表示される詳細情報を閲覧するか、Windows 以外のボリュームにセレクタを適用して、効果をチェックしてください。チェック方法については、「セレクタ」ツールバーを参照してください。

Retrospect には、以下の組み込みセレクタがあります。

「すべてのファイル」は、オペレーティングシステムフォルダを含め、元ボリューム上の全ファイルにマークをつけます。「すべてのファイル」は、デフォルトのセレクタです。

「キャッシュ以外の全ファイル」は、Web ブラウザなどの特定のアプリケーションで使われるキャッシュファイルを除き、元ボリューム上の全ファイルをマークします。キャッシュファイルは大きな場合が多く、復元には必要ありません。

「アプリケーション」は、実行可能アプリケーション(.exe)とコードライブラリ(.dll)だけにマークを付けます。ただし、システムフォルダ内のアプリケーションは除外されます。

Block Level Filter controls how a file is backed up, i.e. whether it is backed up in full or incrementally

「書類」は、実行可能アプリケーション(.exe)、またはコードライブラリ(.dll)ではないファイルで、「Program Files」フォルダまたはオペレーティングシステムのフォルダ内にないファイルにマークを付けます。「デスクトップ」フォルダと「お気に入り」フォルダ内のファイルは除外されます。

「ドキュメントと設定」は、Documents and Settings フォルダ内のファイルにマークを付けます。このフォルダ内には、各ユーザの「マイドキュメント」、「お気に入り」、「Application Data」、「デスクトップ」などのフォルダがあります。

Windows 9x システムの場合、「ドキュメントと設定」セレクタは「Profiles」フォルダにマークを付けます。

Mac OS X では、このセレクタは Users フォルダと Library/Preferences フォルダにマークを付けます。

「動画」は、元ボリュームの各所にある、一般的な動画ファイル拡張子(.mov など)を持つ各ファイルにマークを付けます(「Windows」フォルダと「Program Files」フォルダ内のファイルを除く)。さらに、各ユーザの「マイドキュメント」フォルダ内の、「My Videos」フォルダと「Movies」フォルダにあるすべてのファイルにもマークを付けます。

「音楽」は、各ユーザの「マイドキュメント」フォルダ内の「My Music」フォルダにあるすべてのファイルにマークを付け、元ボリュームの各所にある、一般的な動画ファイル拡張子(.mp3 など)を持つ各ファイルにもマークを付けます(「Windows」フォルダと「Program Files」フォルダ内のファイルを除く)。さらに、各ユーザの Music フォルダが存在する場合は、そのフォルダにもマークを付けます(Mac OS X、Windows 共通)。

「ファイルなし」は、ファイルにマークを付けません。

「Office ドキュメント」は、元ボリュームの各所にある Microsoft Office 文書、Microsoft Outlook データ、および Adobe PDF ファイルにマークを付けます(「Windows」フォルダと「Program Files」フォルダ内のファイルを除く)。

「オペレーティングシステムとアプリケーション」は、Windows フォルダやシステム状態などのシステムファイルにマークを付けます。また、アプリケーションファイル(「Program Files」フォルダ内の項目を含む)、および元ボリュームの各所にある、既知のアプリケーション拡張子(.exe、.dll など)を持つ各ファイルにもマークを付けます。

「OS フォルダ」は、オペレーティングシステムのフォルダ内のファイルにマークを付けます。UNIX では、このセレクタはファイルにマークを付けません。

「写真」は、各ユーザの「マイドキュメント」フォルダ内の、「My Pictures」フォルダにあるすべてのファイルにマークを付け、また、ディスク上の各所にある、一般的な画像ファイル拡張子(.jpg など)を持つ各ファイルにもマークを付けます(「Windows」フォルダと「Program Files」フォルダ内のファイルを除く)。さらに、各ユーザの Pictures フォルダが存在する場合は、そのフォルダにもマークを付けます(Mac OS X、Windows 共通)。

Restore System and Applications marks system and application files.

「Retrospect ファイル」は、カタログ、ログ、設定、および Retrospect に関連する他の書類にマークを付けます。UNIX では、このセレクタはファイルにマークを付けません。

「すべてのファイル」は、基本操作やスクリプトで使用されるデフォルトのセレクタです。完全にバックアップするためにこのセレクタを使用してください。

組み込みセレクタの詳細を表示するには、セレクタ ウィンドウでセレクタをクリックして、「編集」をクリックします(または、セレクタをダブルクリックします)。セレクタの条件を示すウィンドウが表示されます。

424

セレクタを構成する条件を理解するには、セレクタの条件の説明が役立ちます。

セレクタの条件

セレクタは複数の条件の組み合わせから構成されており、これらの条件の基準を満たすファイルやフォルダが選択対象に組み入れられるか、対象から除外されます。Retrospect には多数の詳しい条件が用意されており、それらを組み合わせて複雑なセレクタを作成できます。

セレクタ条件を表示または修正するには、セレクタウィンドウでセレクタを選択してから、「編集」をクリックします。セレクタ詳細ウィンドウが表示されます。このウィンドウには、特定のファイルやフォルダを選択対象に含めるための条件を追加するセクションと、対象から除外するための条件を追加するセクションがあります。

425

見出し部分の「選択」または「除外」の下にある + ボタンをクリックすると、条件ウィンドウが表示されます。

426

条件ウィンドウの左側に沿って、利用可能な条件の分類が次のように一覧されます。

一般的なセレクタ条件

一般的な条件は、サポートしているすべてのファイルシステムで動作します。以下の条件を使用して、自分専用のセレクタを作成できます。

「属性(一般)」では、Retrospect のマークされた属性と一致する属性に加えて、読み取り専用の属性と非表示の属性を使用します。

「クライアント名(一般)」では、Retrospect のクライアントデータベースからの名前を条件として使用します。

「日付(一般)」では、作成日、変更日、またはバックアップ日を条件として使用します。

「ファイルシステム(一般)」では、元ボリュームのファイルシステムを条件として使用します。

「ログイン名(一般)」では、ファイルを共有している所有者の名前、グループ名、またはログイン名を条件として使用します。

「名前(一般)」では、ファイル名またはフォルダ名を条件として使用します。

「セレクタ(一般)」では、他のセレクタを条件として使用します。

「容量(一般)」では、ファイルまたはフォルダのサイズを条件として指定できます。

「ボリューム名(一般)」では、ボリューム名を条件として使用します。Windows のボリュームでは、プロパティに表示されるボリュームラベルです。ドライブ文字ではありません。

Windows のセレクタ条件

Windows の条件は、FAT および NTFS ファイルシステムで動作します。以下の条件を使用して、自分専用のセレクタを作成できます。

「属性(Windows)」では、アーカイブ、システム、暗号化、オフラインフラグを条件として使用します。

「日付(Windows)」では、Windows 固有の日付属性を条件として使用します。

「ドライブ文字(Windows)」では、元ボリュームのドライブ文字を条件として使用します。

「パス(Windows)」では、ファイルまたはフォルダへのパスを条件として使用します。フォルダ階層は、「¥」文字で表されます。

「特別なフォルダ(Windows)」では、Volume Root、Documents and Settings など、システムで定義されている特定のフォルダを条件として使用します。

Mac OS のセレクタ条件

Mac OS の条件は、HFS および HFS+ ファイルシステムで動作します。以下の条件を使用して、自分専用のセレクタを作成できます。

「属性(Mac OS)」では、ファイル属性(ファイルの使用中、別名、ロックされた名前、ひな形、カスタムアイコン)を条件として使用します。

「ファイルの種類(Mac OS)」では、ファイルクリエータとタイプを条件として使用します。

「ラベル、アイコンの色(Mac OS)」では、ファイルまたはフォルダのラベルを条件として使用します。Finder の「ラベル」メニューまたはサブメニューには、7 つのラベル、カラー(モニタにカラーとグレースケールが表示されている場合)、および「なし」オプションがあります。このウィンドウの各チェックボックスは、「ラベル」メニューの各項目の位置に対応しており、実際のカラーまたはラベル名には対応していません。

「パス(Mac OS)」では、ファイルまたはフォルダへのパスを条件として使用します。Mac OS X(およびそれ以前のバージョンの Mac OS)では、パス名の区切り文字としてコロン(:)を使用してください。パス名にはボリュームを含める必要があります。

「許可(Mac OS)」は、ユーザ、グループ、その他に対する読み取り、書き込み、実行パーミッションです。Mac OS X のファイル/フォルダパーミッションは、条件に正確に一致します(* をワイルドカードとして使用)。たとえば、ユーザ、グループ、またはその他が書き込みできるすべてのファイルを選択するには、3 つの別個の 「OR」条件を作成しなければなりません。*w*******、****w****、および *******w* です。

UNIX のセレクタ条件

UNIX OS の条件は、UNIX ファイルシステムで動作します。以下の条件を使用して、自分専用のセレクタを作成できます。

「属性(UNIX OS)」では、ファイル属性(シンボリックリンクフラグ設定)を条件として使用します。

「日付(Unix OS)」:UNIX 固有の日付属性です。

「パス(Unix OS)」は、ファイルまたはフォルダへのパスです。フォルダ階層は、「/」文字で表されます。

「許可(Unix OS)」は、ユーザ、グループ、その他に対する読み取り、書き込み、実行パーミッションです。UNIX のファイル/フォルダパーミッションは、非常に正確に条件に一致します。(* をワイルドカードとして使用できます。)たとえば、ユーザ、グループ、またはその他が書き込みできるすべてのファイルを選択するには、3 つの別個の 「OR」条件を作成しなければなりません。*w*******、****w****、および *******w* です。

メールボックスのセレクタ条件

メールボックスの条件は、Exchange メールボックスをバックアップまたは復元するときに使用できます。

「Sender」では、メッセージの送信者を条件として使用します。

条件の操作

各条件タイプには、条件の詳細を入力または指定できる専用のコントロールがあります。

427

条件を追加または変更すると、それがセレクタ詳細ウィンドウに表示されます。

428

+ 条件ボタンをクリックして、複数の条件をセレクタに追加できます。条件間の関係は + ボタンの場所によって決まり、AND 演算子を使って条件を追加する場合と、OR 演算子を使って条件を追加する場合があります。+ ボタンをクリックして条件ウィンドウを開くと、演算子のタイプが表示され、新規条件の AND をとっているのか、OR をとっているのかがわかります。

429

AND 演算子では、複数の条件を結合して、その条件を満たすファイルまたはフォルダを選択することができます。各条件は、「選択」および「除外」領域のそれぞれの最終条件を除き、AND 演算子を使用します。

430

OR 演算子では、複数の条件を結合して、少なくとも 1 つの条件を満たす(必ずしもすべての条件を満たす必要はない)ファイルまたはフォルダを選択することができます。「選択」および「除外」領域のそれぞれの最終条件は、必ず OR 演算子を使用します。

431

この機能をよく理解するために、カスタムセレクタの作成を参照して各条件を自分で試してみてください。

条件の例

以下の表には、カスタムセレクタの一例と、それを特定のファイルに適用したときの効果が示されています。

432

条件の規則

セレクタの適用時には、常に「除外」文が「選択」文より優先されます。たとえば、セレクタに、プロファイルフォルダを含む文と OS フォルダを除外する文がある場合、プロファイルフォルダ内のファイルはマークされません。

カスタムセレクタの作成

Retrospect では、ファイル/フォルダの最適な選択を実行できるセレクタを簡単に作成することができます。カスタムセレクタを習得するのに最も良い方法は、カスタムセレクタを作成することです。以下の例では、特定のアプリケーションと Games フォルダをバックアップ対象から除外するカスタムセレクタを作成します。

新規セレクタの作成

ナビゲーションバーの「設定」> 「セレクタ」ボタンを順にクリックしてから、「新規」をクリックします。新しいセレクタの名前を入力するよう求められます。この例では「不要なゲームとアプリケーション(Unwanted games and apps)」となっていますが、別の名前を入力することもできます。

433

名前を入力したら、「新規」をクリックします。新規セレクタのセレクタ詳細ウィンドウが表示されます。このウィンドウ名とセレクタ名は同じです。

434

新規セレクタのデフォルトでは、条件をユーザが追加するまで、すべてを含むにし、何も除外しません。

ファイルの除外

「除外」という見出しの下の + ボタンをクリックして、条件を追加します。表示された条件ウィンドウで、Windows の「特別なフォルダ」条件を選択し、除外するフォルダタイプを指定します。

435

「アプリケーションデータ」を選択してから、「OK」をクリックします。セレクタ詳細ウィンドウは、新しい条件を反映した内容になっています。

436

この時点では、セレクタは Windows ボリュームのアプリケーションデータフォルダを除外しています。ここで、2 つ目の条件を追加することができます。

「除外」という見出しの下の 2 番目の + ボタンをクリックします。438 ハンドルアイコンの隣に「OR」という語があります。表示された条件ウィンドウで、Mac OS の「ファイルの種類」条件を選択します。

438

このウィンドウでは、ファイルのタイプとクリエータ、またはそのいずれか一方を条件として指定できます。デフォルトのファイルの種類は、タイプ「APPL.」の一般のアプリケーションです。この例ではこの条件を使用したいので、「OK」をクリックします。セレクタ詳細ウィンドウは、新しい条件を反映した内容になっています。

439

この条件は一番下の + ボタンから追加したので、OR 演算子を使ってセレクタに追加されています。OR および AND 演算子については、条件の操作を参照してください。

ここで、3 つ目の条件を追加することができます。「除外」という見出し下にある一番下の + ボタンをクリックして、条件ウィンドウで一般の「名前」条件を選択します。

440

テキスト一致動作の内容を選択して、テキストボックスに「games」と入力します。他のコントロールは、変更しません。「OK」をクリックして、セレクタ詳細ウィンドウに戻ります。

441

この時点で、セレクタは Windows のアプリケーションデータフォルダの内容と、すべての Mac OS アプリケーションと、Word のゲームを収めたすべてのフォルダを除外します。 ”

このセレクタを保存して、スクリプトや、基本操作や、ブラウザで使用できます。

「セレクタ」ツールバー

セレクタの詳細ウィンドウには、次のコマンドを備えたツールバーがあります。

「保存」:現在の名前でセレクタを保存して、最後に保存されたセレクタを置き換えます。

「別名で保存」:別の名前でセレクタを保存します。新しい名前をダイアログボックスに入力し、「保存」をクリックします。元のセレクタは最後に保存されたままです。

「復帰」:セレクタへの現在の変更を破棄して、最後に保存された状態に戻します。

「名前を変える」:セレクタの名前を変更します。新しい名前をダイアログボックスに入力し、「名前を変える」をクリックします。

「セレクタのチェック」:ボリュームに適用してセレクタをテストします。ここで、参照したいボリュームを選択します。ブラウザウィンドウに、セレクタ基準を満たすファイルがチェックされた状態で表示されます。マークが付けられているファイルが、テストしたセレクタを使用したときに Retrospect によってバックアップされるファイルです。

該当するファイルにマークが付いていれば、セレクタは正しく機能しているので、それを基本操作やスクリプトに使用することができます。

ファイルが適正にマークされていない場合は、セレクタを修正して、それを再チェックする必要があります。その場合には、条件の追加、削除、または変更を行います。セレクタの実行結果に影響を及ぼす AND や OR 演算子は慎重にチェックします。セレクタを修正したら、それを保存して再チェックを行い、ファイルが正しくマークされているか確認します。セレクタが正しく機能するまで、必要なだけこの手順を繰り返してください。

「削除」:選択した条件をセレクタから削除できます。

セレクタの印刷

セレクタ詳細ウィンドウの内容を印刷して、それを参照用に保管しておくことができます。セレクタウィンドウを印刷するには、セレクタを編集し、「ファイル」メニューから「印刷」を選択します。

セレクタの修正

セレクタ詳細ウィンドウに表示される条件はすべて修正できます。条件を修正したら、セレクタの詳細ウィンドウに戻って新規条件を追加したり、既存の条件を修正したりすることができます。

セレクタウィンドウでセレクタを開くには、修正するセレクタをクリックして、「編集」をクリックします(または、単にセレクタをダブルクリックします)。セレクタの詳細ウィンドウが表示されます。

セレクタの既存の条件を編集する場合は、選択して「修正」をクリックするか、条件の行をダブルクリックします。(+ と443 アイコンの行は例外です。)条件ウィンドウで、オプションとコントロールを修正できます。「OK」をクリックして、条件に対する変更を確定します。

新しい条件を追加するには、+ アイコンをクリックします。(「or...」がグレイ表示された444 ハンドルの隣の + は、「OR」条件を追加します。一方他の + アイコンは、「AND」条件を追加します。)条件ウィンドウが表示され、選択した条件のタイプのオプションとコントロールが提供されます。そのウィンドウで必要な選択と設定を行い、「OK」をクリックしてセレクタに追加します。条件ウィンドウが閉じて、セレクタウィンドウに新しい条件が表示されます。

条件の無効化

セレクタ内の条件はいつでも無効にすることができます。無効にした条件は、ファイルの選択には使用されません。その条件は有効になるまで、非アクティブのままです。この機能は、かなり複雑になったセレクタを部分的にテストして問題の解決を図りたい場合などに役立ちます。

条件を無効にするには、まずセレクタを開いて特定の条件を選択します。「無効」をクリックすると、選択した条件は無効になって、非アクティブとすぐにわかるようにテキストがグレイ表示されます。

無効にした条件を元に戻す場合は、その条件を選択して「有効」をクリックします。

条件の移動

セレクタ詳細ウィンドウ内で条件を移動するには、条件記述の隣の445 ハンドルをドラッグし、それをスクロールボックス内の新しい場所にドロップします。

条件は、同じグループまたは別のグループ(見出し)内のほかの場所にドラッグすることができます。たとえば、「選択」という見出しの下に「名前」条件を追加している場合は、同条件を「除外」という見出しの下にドラッグし、その条件を除外条件に変更することができます。

条件を移動すると、そのアウトラインがハンドカーソルの後についてきて、条件の新しい場所を示します。新しいアウトラインが適正な場所に表示されていれば、マウスのボタンを離します。それがドロップされると、条件が新しい場所に移動し、アウトラインされた移動先の条件の前に挿入されます。

条件をコピーするには、Shift キーを押したままドラッグします。「または以下と該当する」という見出しをドラッグすると、グループ全体が移動します。「または以下と該当する」を、Shift キーを押したままドラッグすると、グループがコピーされます。

条件などを移動すると、その演算子のタイプ(AND または OR)が変わることがあるので注意してください。

条件の削除

セレクタ内の条件はいつでも削除することができます。

条件を削除にするには、まずセレクタを開いて特定の条件を選択します。「削除」をクリックして、選択した条件がウィンドウから削除されることを確認します。

セレクタの削除

セレクタが不要になったら、セレクタウィンドウで削除できます。

セレクタを削除するには、セレクタをクリックして選択し、ツールバーの「削除」を選択するか、Delete キーを押します。削除の確認を求めるダイアログボックスが表示されます。「OK」をクリックします。これでセレクタが削除されます。

セレクタの複製

特定のセレクタを複製し、それを調整して自分の要求に合うセレクタを作成できます。たとえば、Retrospect の組み込みセレクタの 1 つをコピーし、そのオリジナルには手を加えずにコピーを変更することができます。複製操作は、セレクタウィンドウで行うことができます。

セレクタを複製するには、セレクタをクリックして選択し、ツールバーの「複製」をクリックします。新しいセレクタ名を入力するためのフィールドが付いたダイアログボックスが表示されます。新しい名前を入力して「新規」をクリックします。Retrospect は、ダイアログボックスで指定された名前を使って、セレクタの正確なコピーを作成します。

セレクタの例

ここでは、セレクタの具体例をいくつか示して、それぞれ詳細な説明を加えています。

ネットワークバックアップセレクタ

このセレクタは、Leslie のクライアントコンピュータに収容された Games フォルダ内のファイルを除き、バックアップ対象の文書をすべてマークします。この例では、バックアップ管理者は、バックアップの不要なゲームを含む大きなフォルダが Leslie に存在することを認識しています。

445

検索復元セレクタ

このセレクタは、日付条件を使用して、2001 年 10 月 17 日 5:04 p.m. 以降に変更された Acrobat PDF 文書を検索します。このセレクタでは、「名前」条件を使用して Windows ボリュームを検索し、「ファイルの種類」条件を使用して Macintosh ボリュームを検索します。このセレクタは、基本復元操作中に名前を忘れたファイルを検索する方法を示す良い例です。正確なファイル名が不明な場合でも、特定の日付以降にファイルを最後に保存したことを覚えている場合があります。

446

クライアント検索復元セレクタ

このセレクタは、特定のクライアントユーザのコンピュータで作成された名前付きファイルを検索します。この場合、ファイル名は Dissertation であり、クライアント名は Neil です。このセレクタは、基本復元操作中に使用できます。

447

メンテナンスと修復

この項では、カタログやメディアのメンテナンスと修復について、以下のような作業の実行手順を説明します。

  • 古いカタログや、ファイルと同期していないカタログを更新する。
  • 消失または破損したカタログを作成し直す。(「カタログファイルのチェックサム」エラーが発生した場合は、カタログが破損しています。)
  • 破損したファイルバックアップセットを修復する。
  • バックアップセットメディアを検証する。

これらのタスクを実行するには、まず、ナビゲーションツールバーの「ツール」をクリックします。

カタログの更新

バックアップセットの処理中に「カタログの更新が必要です」とエラーが表示された場合は、バックアップセットのカタログを更新してください。カタログとメディアを同期化しておかないと、バックアップセットが使用できなくなります。

「カタログの更新が必要です」エラーは、前回そのバックアップセットにデータのコピーを行ったときに、デバイスや電源の障害などにより、カタログの更新ができなかった場合に発生します。このエラーは、ディスク容量が限界に達した場合や、メモリ不足の場合にも表示されます。

カタログの更新後もバックアップセット使用中に「カタログの更新が必要です」エラーメッセージが表示された場合は、カタログの修復を中止して、次のような対策をとってください。スキップして新規メディアを使う、フルバックアップか新規バックアップでリセットする、新規バックアップセットを作成する。エラーメッセージの詳細については、カタログの更新が必要ですを参照してください。

カタログを更新するには

  1. ナビゲーションバーの「ツール」>「カタログの修復」を順にクリックします。

    448

  2. 「既存のカタログファイルを更新」を選択し、「OK」をクリックします。

    449

  3. 更新するバックアップセットを選択し、「OK」をクリックします。
  4. 最新のメンバーを検出できなかった場合、メディア要求ウィンドウが表示されます。

    要求されたメディアを挿入します。

  5. バックアップセットに他のメンバーがあるかどうか尋ねるダイアログボックスが表示されます。

    450

    もうメンバーがない場合には、「いいえ」をクリックしてカタログの再作成を開始します。

    修復すべきメンバーが残っている場合は、「はい」をクリックします。メンバーを要求するメッセージは、「いいえ」か「キャンセル」をクリックするまで表示されます。

  6. バックアップセットのカタログの修復が実行され、アクティビティモニタに進行状況が表示されます。
  7. アクティビティモニタの「履歴」タブをクリックすると、更新が成功したかどうかについて詳細が表示されます。

失敗した場合は、「ログ」ボタンをクリックして詳細を確認してください。

カタログの再作成

カタログファイルがないとバックアップセットを使用できないため、カタログファイルのオリジナルを紛失または破損した場合は、カタログを再作成する必要があります。Retrospect では、バックアップセットメディアを読み出してカタログを再作成することができます。カタログの再作成は、バックアップセットのデータ量によって非常に時間がかかる場合があります。

ディスクバックアップセットのカタログの再作成の手順は、テープ、CD/DVD バックアップセットの手順とは異なります。

CD/DVD またはテープのカタログの再作成

開始する前に、バックアップデバイスに再作成するカタログの最新バックアップセットメンバーを必ずロードするようにしてください。

CD/DVD またはテープのカタログを再作成するには

  1. ナビゲーションバーの「ツール」>「カタログの修復」を順にクリックします。
  2. 「テープから再作成」または「CD/DVD ディスクから再作成」を選択し、「OK」をクリックします。

    「メディア選択」ウィンドウが表示されます。

    451

  3. 「メディア選択」ウィンドウで、「状況」タブをクリックしたら、バックアップセットの最新メンバーを選択します。
  4. Retrospect 5.0 または 5.1 で作成されたバックアップセットでは、セットの最初のメンバーが要求されます。

    最新のメディアがない場合、バックアップセットで利用できるもっとも新しいメンバーを挿入して、カタログを再作成してください。

  5. 「OK」をクリックします。

    Retrospect がまだ認識しているバックアップセットのカタログを再作成する場合は、再作成したバックアップセットを認識させるかどうかを確認するメッセージが表示されます。「OK」をクリックして、既知のバックアップセットと置き換えます。

  6. バックアップセットが暗号化されていると、そのパスワードを入力するよう要求されます。パスワードを入力して「OK」をクリックします。
  7. 再作成したカタログファイルを保存する場所を指定し、「保存」をクリックします。

    バックアップセットのカタログの修復が実行され、アクティビティモニタに進行状況が表示されます。バックアップセットの特定メンバーのカタログ再作成が完了すると、カタログを再作成すべき他のメンバーがあるかどうか尋ねるダイアログボックスが表示されます。

    452

  8. セットしたメンバーが、バックアップセットの最終メディアだった場合は、修復するものがそれ以上ないため、「いいえ」をクリックしてカタログの再作成を完了します。

    紛失または破損したメンバーの数に関わらず、バックアップセットに再作成すべきメンバーが残っている場合は、「はい」をクリックします。

  9. 要求されたバックアップセットのメンバーを挿入するか、そのメンバーがない場合には「選択」をクリックします。

    メンバーが利用できない理由を尋ねるダイアログボックスが表示されます。

    453

    バックアップセットの最終メディアがすでに処理済みの場合は、「完了」をクリックします。必要なメンバーが紛失または破損している場合は、「紛失」をクリックします。

  10. メンバーを要求するメッセージは、「いいえ」か「キャンセル」をクリックするまで表示されます。

アクティビティモニタの「履歴」タブをクリックすると、再作成が成功したかどうかについて詳細が表示されます。失敗した場合は、「ログ」ボタンをクリックして詳細を確認してください。

カタログの再作成が完了したと表示された場合は、そのバックアップセットを使用しているスクリプトを編集し、新たに認識された再作成済みのバックアップセットを各スクリプトに追加してください。

ディスクカタログの再作成

リムーバルディスクからカタログを再作成する場合、開始する前に、バックアップデバイスに再作成するカタログの最新バックアップセットメンバーを必ずロードするようにしてください。

ディスクカタログを再作成するには

  1. ナビゲーションバーの「ツール」>「カタログの修復」を順にクリックします。
  2. 「ディスクから再作成」を選択してから、「OK」をクリックします。

    454

  3. バックアップセットデータの復元に最後に使用されたディスクがわかっている場合、「最新のディスク」をクリックします。不明である場合には、「すべてのディスク」をクリックします。
  4. このバックアップセットの高速カタログファイル再構築オプションがオフだった場合には、「最新のディスク」を選択してはなりません。

    455

  5. ディスクの場所まで移動し、ディスクを選択して「OK」をクリックします。

    ディスク上のバックアップセットのリストが表示されます。

    456

  6. カタログを再作成するバックアップセットを選択し、「OK」をクリックします。

    「すべてのディスク」を選択した場合、バックアップセットにさらにディスクがあるかどうかが尋ねられます。ある場合には、「はい」をクリックして他のディスクを選択します。「いいえ」をクリックするまで、引き続きさらにディスクがあるかどうかが尋ねられます。

  7. Retrospect がまだ認識しているバックアップセットのカタログファイルを再作成する場合は、再作成したバックアップセットを認識させるかどうかを確認するメッセージが表示されます。「OK」をクリックして、既知のバックアップセットを削除します。
  8. バックアップセットが暗号化されていると、そのパスワードを入力するよう要求されます。パスワードを入力して「OK」をクリックします。
  9. 再作成したカタログファイルを保存する場所を指定し、「保存」をクリックします。

バックアップセットのカタログの修復が実行され、アクティビティモニタウィンドウに進行状況が表示されます。終了したとき、アクティビティモニタの「履歴」タブをクリックすると、再作成が成功したかどうかについて詳細が表示されます。失敗した場合は、「ログ」ボタンをクリックして詳細を確認してください。

カタログの再作成が完了したと表示された場合は、古いバックアップセットを使用しているスクリプトを編集し、新たに認識された再作成済みのバックアップセットを各スクリプトに追加してください。

ファイルバックアップセットの修復

ファイルバックアップセットのカタログファイルは、バックアップセットデータと同じファイルに保存されます。ファイルバックアップセットのカタログを修復するには、そのバックアップセットに対するアクセス権が必要です。

ファイルバックアップセットを修復するには

  1. ナビゲーションバーの「ツール」>「カタログの修復」を順にクリックします。

    457

  2. 「ファイル バックアップセットの修復」を選択して、「OK」をクリックします。

    「バックアップセットの選択」ウィンドウが表示されます。

  3. 修復が必要なファイルバックアップセットを探し、選択して、「開く」をクリックします。

    修復するかどうかを確認するメッセージが表示されます。

  4. 「はい」をクリックし、修復を実行します。
  5. バックアップセットが暗号化されていると、そのパスワードを入力するよう要求されます。パスワードを入力して「OK」をクリックします。

バックアップセットのカタログの修復が実行され、アクティビティモニタウィンドウに進行状況が表示されます。終了したとき、アクティビティモニタの「履歴」タブをクリックすると、再作成が成功したかどうかについて詳細が表示されます。失敗した場合は、「ログ」ボタンをクリックして詳細を確認してください。

不完全なカタログの修復

カタログの作成操作を停止すると、次のダイアログボックスが表示されます。

458

「復帰」は、カタログの再作成を中止し、処理中だったメディアからカタログの更新を再開できるようにします。(あとで更新を再開する場合は、「既存のカタログファイルを更新する」機能を使用します。)

「保存」は、処理中だったメディアからのデータで、これ以上カタログの修復を行わない場合に選択します。これまでにカタログ化されたデータはすべて検索可能にする必要があります。(あとで更新を再開する場合は、「既存のカタログファイルを更新する」機能を使用します。)次のメディアがあれば、そこからカタログの再作成が再開されます。「保存」オプションの使用後に、そのバックアップセットへデータのバックアップを行った場合は、残り容量がないと見なされ、新規のメディアが要求されます。

バックアップセットメディアの検証

手動でバックアップセットメディアを検証するには、Retrospect のナビゲーションバーから「ツール」>「メディアの検証」を選択します。メディアの検証は、検証を使用しなかった基本バックアップ(またはアーカイブ)後に、バックアップセットメディアのオフライン検証を行う場合に役立ちます。

検証を行わずにスクリプトによるバックアップ(またはアーカイブ)を実行することで、バックアップウィンドウを最大化したい場合には、検証スクリプトを使用してオフライン検証をスケジュールする必要があります。詳しくは、スクリプトによる検証を参照してください。

検証可能な場合、メディアの検証はバックアップセットメディアのデータを、選択したバックアップセットのファイルとバックアップ時に生成された MD5 とを比較することにより検証します。つまり、バックアップ元ボリュームにアクセスする必要がないので、該当するボリュームのスローダウンを防止します。

特定の状況下では、バックアップ時に生成された MD5 にアクセスしません。Retrospect 16.5 以前のバージョンを使用して作成されたすべてのバックアップと、「バックアップ操作中に MD5 ダイジェストを生成」環境設定を無効にして作成されたバックアップが、これに該当します。詳しくは、検証環境設定を参照してください。

この場合、バックアップセットメディアのすべてのファイルがチェックされて、読み出し可能であることが確認されます。

  • メディアの検証では、複数のメディアにまたがるバックアップを検証する場合、メディアの再セットが要求されます。

メディアの読み取りを検証するには

  1. 「ツール」>「メディアの検証」を順にクリックします。

    「バックアップセットの選択」ウィンドウが表示されます。

  2. 検証するバックアップセットを選択し、「OK」をクリックします。

    バックアップセットメディアの検証が実行され、アクティビティモニタウィンドウに進行状況が表示されます。

    バックアップセットが CD/DVD、リムーバブルディスク、またはテープを使用する場合は、必要に応じて、各バックアップセットメンバーをセットするように要求されます。

    要求されたバックアップセットメンバーを持っていないが、他にも検証するバックアップセットメンバーがある場合は、「選択」をクリックして「OK」をクリックし、次に要求されたメディアメンバーを挿入してください。

  3. 終了したとき、アクティビティモニタの「履歴」タブをクリックすると、再作成が成功したかどうかについて詳細が表示されます。失敗した場合は、「ログ」ボタンをクリックして詳細を確認してください。
  4. 検証できなかったファイルは、新規バックアップセットにバックアップしておくことをお勧めします。
  5. 「終了」をクリックします。

外部スクリプト

Retrospect のイベントは、実行可能ファイルを作成できる任意のスクリプト作成言語でオーサリングできる、外部スクリプトで処理できます。単一の実行可能スクリプトを Retrospect または Retrospect クライアントに添付して、イベントでの処理を実行できます。

この項は、Windows スクリプティングの知識があることを前提としています。Retrospect の外部スクリプト機能は、外部スクリプトで Retrospect の操作をさらに自動化したいと考えている上級のスクリプト作成者のみを対象としています。Windows スクリプティングについては、Microsoft の開発者向けの Web ベースの 文書をご覧ください。

Windows スクリプティングは種々の複雑な要素を含んでおり、Retrospect, Inc. ではその最小限の機能だけをサポートしています。

Retrospect の Windows スクリプティングサポートファイルのインストール

デフォルトの(推奨)インストールでは、Retrospect セットアッププログラムによって External Scripts フォルダがインストールされます。セットアッププログラムを使用して既存のインストールを修正して、Retrospect フォルダにこのフォルダを追加できます。

Retrospect のインストール時、External Scripts フォルダはデフォルトで次の場所にインストールされます。

..¥Program Files¥Retrospect¥Retrospect 16.5¥External Scripts

VBScript や、オペレーティングシステムで直接サポートされていない他のスクリプト言語で作成されたスクリプトを使用するには、システムに Windows Scripting Host をインストールしなければなりません。Windows Scripting Host は、 Microsoft から無料で入手できます。

Retrospect のイベント

Retrospect には、スクリプトで処理できる 15 のイベントがあります。Retrospect クライアントソフトウェアには、これらのイベントが 2 つあります。次は、イベント名と、トリガされたときの動作の説明です。

StartApp は、自動起動も含め、Retrospect が開かれると発生します。

EndApp は、Retrospect が終了すると発生します。

StartBackupServer は、Proactive Backup が起動しようとすると発生します。

StopBackupServer は、Proactive Backup の停止時に発生します。

StartScript は、スクリプトが起動しようとすると発生します。

EndScript は、スクリプトの終了時に発生します。

StartSource は、元ボリュームにはじめてアクセスしようとしたときに発生します。このイベントは、Retrospect アプリケーションと Retrospect クライアントソフトウェアの両方に存在します。

EndSource は、元ボリュームのアクセス終了時に発生します。このイベントは、Retrospect アプリケーションと Retrospect クライアントソフトウェアの両方に存在します。

MediaRequest は、Retrospect がメディアを要求しようとしたときに発生し、メディア要求ウィンドウが開かれている間は 5 分ごとに発生します。

TimedOutMediaRequest は、Retrospect がメディアを要求し、初期設定で指定した時間以上待っていた場合に発生します。

ScriptCheckFailed は、スクリプトの実行後に Retrospect が終了し、先読み時間外に実行するようにスケジュールが設定されたスクリプトがあり、スクリプトのチェックが失敗したときに発生します。

NextExec は、スクリプトの実行後に Retrospect が終了し、先読み時間外に実行するようにスケジュールが設定されたスクリプトがあり、スクリプトのチェックが成功したときに発生します。

SchedStop は、スクリプトが実行中で、許可された実行時間が期限切れになるために停止しようとしたときに発生します。

PasswordEntry は、パスワードが入力されたときに発生します。

FatalBackupError は、致命的なバックアップエラーが起こったときに発生します。

Retrospect でのスクリプトの実装

外部スクリプトファイルを Retrospect のプログラムフォルダ(デフォルトのパスは ..¥Program Files¥Retrospect¥Retrospect 16.5)にコピーして、スクリプトの名前を RetroEventhandler に変更します。 .BAT、.EXE、.VBS や、Windows Scripting Host がサポートする他の拡張子など、スクリプトタイプに適合するファイル名の拡張子を追加します。

複数の RetroEventHandler ファイルが存在する場合、1 つのファイルのみが使用されます。複数のイベントで複数の動作を実行したい場合、その動作を実行する単一のスクリプトを作成しなければなりません。

Windows 版 Retrospect クライアントでのスクリプトの実装

Retrospect クライアントで外部スクリプトを使用するには、スクリプトファイルを Retrospect クライアントのプログラムフォルダ(デフォルトのパスは ..¥Program Files¥ Retrospect¥Retrospect Client )にコピーして、スクリプトの名前をRetrospect でのスクリプトの実装で説明した名前に変更します。

外部スクリプトの実行

イベントが発生すると、Retrospect は外部スクリプトに通知して、作業を続ける前にスクリプトからの応答を待ちます。5 秒後に、スクリプトが実行中であることを示す進行状況ウィンドウが表示されます。

459

スクリプトが終了すると、Retrospect は作業を続けます。

サンプルスクリプト

External Scripts フォルダには、4 つのスクリプト言語(バッチファイル、Visual Basic、VBScript、および C)で作成されたサンプルスクリプトがあります。提供された言語のサンプルのソースコードから、Retrospect イベントを処理するための独自のスクリプトを作成する方法を学習できます。サンプルスクリプトは、各イベントに送信される情報の使用方法と、受け入れ可能な戻り値の例を示しています。

Retrospect でサンプルスクリプトを使用するには、サンプルフォルダから Retrospect のプログラムフォルダにスクリプトをコピーします。

  • バッチのサンプルスクリプト .BAT では、Retrospect のプログラムフォルダにインストールされたバッチコマンド拡張機能 ask.exe を使用します。

サンプルスクリプトでは、各イベントが発生するとウインドウが表示され、イベントの名前とイベントの情報が表示されます。たとえば、Retrospect を開くと、StartApp イベントがトリガされます。

460

Retrospect が作業を続行できるように、各ウィンドウで応答しなければなりません。サンプルスクリプトによって処理される別のイベントをトリガするには、別の動作を実行しなければなりません。

サンプルスクリプトを試したら、バックアップスクリプトやスケジュールされた他の Retrospect のスクリプトに干渉しないように、Retrospect のプログラムフォルダから削除してください。